Welcome to the North American Subaru Impreza Owners Club Thursday July 18, 2019
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
Click here to visit TireRack
Brakes & Suspension Forum sponsored by The Tire Rack

Losing traction? Need new tires?
Click here to visit the NASIOC Upgrade Garage...
Go Back   NASIOC > NASIOC Technical > Brakes, Steering & Suspension

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads. 
Reply
 
Thread Tools Display Modes
Old 06-18-2019, 08:45 PM   #1
LunaTheImp
Scooby Newbie
 
Member#: 493072
Join Date: Oct 2018
Chapter/Region: NWIC
Vehicle:
'06 Impreza Wagon
Steel Grey

Default Back again - Squeak from front left.

Yesterday, I replaced my front left wheel bearing thinking it would get rid of the squeaking noise Iíve been experiencing for the last month or so. Took it for a drive and the sound is still there (turning right)

Iíve replaced both front axles, both front bearings and hubs now. What else could make a squeaking noise?
* Registered users of the site do not see these ads.
LunaTheImp is offline   Reply With Quote
Sponsored Links
* Registered users of the site do not see these ads.
Old 06-18-2019, 08:52 PM   #2
CaptainSlowbaru
Scooby Newbie
 
Member#: 445600
Join Date: Apr 2016
Chapter/Region: Tri-State
Location: Rafferty Subaru, PA
Vehicle:
2002 Outback Sport
Green

Default

Can you elaborate on this squeak?
CaptainSlowbaru is offline   Reply With Quote
Old 06-19-2019, 12:59 PM   #3
Rigid80sMTB
Scooby Newbie
 
Member#: 474556
Join Date: Sep 2017
Chapter/Region: South East
Location: Tennessee
Default

i think we might be having the same issue: https://forums.nasioc.com/forums/sho....php?t=2889573

beginning to think its the caliper.
Rigid80sMTB is offline   Reply With Quote
Old 06-19-2019, 08:21 PM   #4
LunaTheImp
Scooby Newbie
 
Member#: 493072
Join Date: Oct 2018
Chapter/Region: NWIC
Vehicle:
'06 Impreza Wagon
Steel Grey

Default

Quote:
Originally Posted by CaptainSlowbaru View Post
Can you elaborate on this squeak?


It happens when I turn right but I canít pinpoint a certain speed that gets it going. Itís high pitched. I tried taking a video of it today but only got wind noise.
LunaTheImp is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

All times are GMT -4. The time now is 11:46 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2019 Axivo Inc.
Copyright ©1999 - 2017, North American Subaru Impreza Owners Club, Inc.