Welcome to the North American Subaru Impreza Owners Club Monday June 25, 2018
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Go Back   NASIOC > NASIOC General > Member's Car Gallery

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads. 
Reply
 
Thread Tools Display Modes
Old 04-11-2018, 08:59 PM   #76
jvh22a
Scooby Newbie
 
Member#: 34368
Join Date: Mar 2003
Location: pasadena, CA
Default

after finishing the oil catch can install, I took it out for a drive and do some errands. the charge light came on about 20mins into the drive.

alternater went out! it was a new unit from rock auto. i could get a new one + shipping but wont get it in time for Saturdays autox. so I had to order one from local parts store for tomorrow.

20180411_173512 by meme meme, on Flickr

ebay catch can
20180410_223625 by meme meme, on Flickr

got a gopro hero5 session and ram heay duty mount

20180410_224225 by meme meme, on Flickr
* Registered users of the site do not see these ads.
jvh22a is offline   Reply With Quote
Sponsored Links
* Registered users of the site do not see these ads.
Old 04-15-2018, 10:18 PM   #77
jvh22a
Scooby Newbie
 
Member#: 34368
Join Date: Mar 2003
Location: pasadena, CA
Default

went to an autox event in el toro, Irvine. car ran great! no engine problems. I did notice a clunk mainly on the front right during turns. and sometimes when I'm reversing and turning.
not sure if it is the spring or something else. I'm using fortune auto coilovers and everything else is from an 03 wrx wagon.

also get a weird noise at slow speeds(rolling into a parking sport type speed) when I start to apply the brakes. sounds like maybe the calipers are clamping at an angle and binding. then as the pads touch the rotors it straightens out and the noise goes away. but at driving speeds there is no noise and brakes work amazing. using hawk hp+

the event was really fun and hot. I got about 16 or so and need to improve a lt more.
during the work assignment, I got one of the area that gets the most cones knocked over. for others that have never done the cone assignment, that's a lot of running!

very fun day and meet some cool people.
20180414_072146 by meme meme, on Flickr

20180414_071515 by meme meme, on Flickr

20180414_072150 by meme meme, on Flickr

20180414_073425 by meme meme, on Flickr

first set of runs
20180414_103950 by meme meme, on Flickr

20180414_150703 by meme meme, on Flickr

at the end of the day, the timer stopped working twice for a bit. few people had some good runs but no time.

Last edited by jvh22a; 04-15-2018 at 10:29 PM.
jvh22a is offline   Reply With Quote
Old 04-15-2018, 10:27 PM   #78
jvh22a
Scooby Newbie
 
Member#: 34368
Join Date: Mar 2003
Location: pasadena, CA
Default

<iframe width="560" height="315" src="https://www.youtube.com/embed/zGNoPLoVBRI?start=90" frameborder="0" allow="autoplay; encrypted-media" allowfullscreen></iframe>

1:33 and 1:35

you can start hearing the brake noise as I'm lining up. if anyone knows what it is let me know.

rotors and pads were new. the rears sometimes make that noise but not often

rotors blanks from oreilys
pads hawk hp+
Russell steel braided lines
jvh22a is offline   Reply With Quote
Old 05-01-2018, 01:45 AM   #79
jvh22a
Scooby Newbie
 
Member#: 34368
Join Date: Mar 2003
Location: pasadena, CA
Default

made some adjustments to the front camber bolts and top camber plates in hopes of fixing the clunking/popping noise I get during turn in.

got an alignment tomorrow and autocross on Saturday at Fontana with speed ventures.

I bought a water tank off ebay and used it for an intercooler and radiator spray. I mounted the tank in the spot were the jack use to be. ran the thick vacuum tube along the driver side panel. under the brake boost is a groument that is perfect location.

20180428_151444 by meme meme, on Flickr

20180428_211410 by meme meme, on Flickr

20180428_194216 by meme meme, on Flickr

20180429_180143 by meme meme, on Flickr

20180429_180129 by meme meme, on Flickr

20180429_180114 by meme meme, on Flickr
20180429_180153 by meme meme, on Flickr

got a sparco tow strap

20180430_222537 by meme meme, on Flickr
jvh22a is offline   Reply With Quote
Old 05-01-2018, 09:30 AM   #80
Seahawk
Scooby Specialist
 
Member#: 71665
Join Date: Oct 2004
Chapter/Region: South East
Location: Wilmington, NC
Vehicle:
1994 Impreza
White

Default

Nice work and good to see you're out enjoying all of your hard work at the autocrosses.

What are you going to use to activate the IC spray? I have a similar setup and use the spare solenoid on my TXS UTEC to activate it; it can be configured based on different parameters so I basically mimicked the Spec-C settings.
Seahawk is offline   Reply With Quote
Old 05-02-2018, 12:08 AM   #81
jvh22a
Scooby Newbie
 
Member#: 34368
Join Date: Mar 2003
Location: pasadena, CA
Default

Quote:
Originally Posted by Seahawk View Post
Nice work and good to see you're out enjoying all of your hard work at the autocrosses.

What are you going to use to activate the IC spray? I have a similar setup and use the spare solenoid on my TXS UTEC to activate it; it can be configured based on different parameters so I basically mimicked the Spec-C settings.

thanks
I'm using cobb AP3 so I don't think I can activate external switches (I'm new to this so I'm not sure)

so I was thinking of using a boost sensor switch or use tps switch like on NOS kits.

but right now its on a manual switch on the dash.

got the alignment done today. still have the front right caster at 2". so maybe next mod will be aluminum control arms and some bushings.


I signed up for Saturday autocross and next week at streets of willow. hope nothing breaks..
got the racechrono upgrade but still not sure how to use it.
jvh22a is offline   Reply With Quote
Old 05-24-2018, 01:51 AM   #82
jvh22a
Scooby Newbie
 
Member#: 34368
Join Date: Mar 2003
Location: pasadena, CA
Default

problem with washer pump. when I park on a down hill, the tank emptys out.

need to find a different pump. I even ordered another kit just in case mine was defective.

went to Fontana autocross on the 5th and ran great. wash worked great but tank is a bit small.

signed up for streets of willow but had to cancel. signed up for bimmer fest autocross this weekend at Fontana.

I was having brake noise when I first apply the brakes. removed the passenger pads and the outside pad had some chamfer to it. so I swapped the pads inside out and left to right. also cleaned and lubed brake sliders. seems to work and no noise now.
jvh22a is offline   Reply With Quote
Old 05-24-2018, 08:38 PM   #83
181stLeader
Scooby Specialist
 
Member#: 184183
Join Date: Jul 2008
Chapter/Region: SCIC
Location: The OC
Vehicle:
1996 Impreza RSTi
V8 EJ207 Aerosim Carbon

Default

Looking good! I need to get back out to El Toro. I'm goon try to come out to the one on July 21st!
181stLeader is offline   Reply With Quote
Old 05-25-2018, 01:33 AM   #84
jvh22a
Scooby Newbie
 
Member#: 34368
Join Date: Mar 2003
Location: pasadena, CA
Default

Quote:
Originally Posted by 181stLeader View Post
Looking good! I need to get back out to El Toro. I'm goon try to come out to the one on July 21st!
I have 3 more weekends before family vacation. This weekend is at fontana, next weekend at big willow with speed district. And then fontana again on the 9th.
I like el toro better, but no cone work at fontana. Post up if you go to el toro, ill go to.

After driving at these events, it kills your ego! Show how bad of a driver i am.
jvh22a is offline   Reply With Quote
Old 05-25-2018, 01:18 PM   #85
181stLeader
Scooby Specialist
 
Member#: 184183
Join Date: Jul 2008
Chapter/Region: SCIC
Location: The OC
Vehicle:
1996 Impreza RSTi
V8 EJ207 Aerosim Carbon

Default

Yeah will do! The Autox guys at SCCA are really good and their cars are setup very well too. But hey at least you are getting out there and getting seat time. The driver mod is the best mod ever!
181stLeader is offline   Reply With Quote
Old 06-03-2018, 01:17 AM   #86
jvh22a
Scooby Newbie
 
Member#: 34368
Join Date: Mar 2003
Location: pasadena, CA
Default

Anyone in So Cali, have oem downpipe and exhaust i can borrow or rent? Want to try and get my car bar. And my smog is coming up in august. Sucks, i thought you get 2 years before smog when you buy a used car.
jvh22a is offline   Reply With Quote
Old 06-03-2018, 08:40 PM   #87
SR 25 RS
Scooby Newbie
 
Member#: 97983
Join Date: Oct 2005
Chapter/Region: BAIC
Location: Oakland
Vehicle:
2017 STi
Silver

Default

incredible
SR 25 RS is offline   Reply With Quote
Old 06-06-2018, 06:52 PM   #88
jvh22a
Scooby Newbie
 
Member#: 34368
Join Date: Mar 2003
Location: pasadena, CA
Default

Quote:
Originally Posted by SR 25 RS View Post
incredible
thanks..

I went to Fontana auto cross 5/23/18

20180526_101053 by meme meme, on Flickr

very clean rx7. don't see many of them around anymore.

20180526_105027 by meme meme, on Flickr

my boy helping clean the wheels.

20180524_180927 by meme meme, on Flickr

i stopped mountain biking about 2 years ago and i feel really out of shape and my clothes are getting tighter!

so i bought a new bike rack since i sold my old one that was great but hard to access the trunk area of my sequoia and xterra. this is a rocky mounts swing away rack.

bought new new front wheel and tire. i put together the bike from a used bare frame. so had to replace all the bearings and lines, etc.
20180523_160305 by meme meme, on Flickr

20180523_180028 by meme meme, on Flickr

20180529_200655 by meme meme, on Flickr
jvh22a is offline   Reply With Quote
Old 06-06-2018, 07:02 PM   #89
jvh22a
Scooby Newbie
 
Member#: 34368
Join Date: Mar 2003
Location: pasadena, CA
Default

Fontana 5/5/18; i kept missing a section near the end right before the right. didn't notice it till the end of the day.


5/23/18


jvh22a is offline   Reply With Quote
Old 06-10-2018, 03:33 PM   #90
jvh22a
Scooby Newbie
 
Member#: 34368
Join Date: Mar 2003
Location: pasadena, CA
Default

getting ready for my trip; I moved the coupe to the other side of the garage. as I parked it, I smell gas! popped the hood and see passenger side under the intake soaked with gas. under the car was a big puddle. it was a lot! I poured some water in the area since it was so close to the up pipe. last time I drove it was from the fontana autocross.

ill have to remove everything to check what was the problem. for now I removed the pump connector and started the car to drained the lines of gas.


that night I drove about hour and half to pick up a ej205 motor. missing a few things but hope it is still good. plan is to take it apart for a budget rebuild.
I already have a ebay 16g turbo, catless up pipe,

20180609_204245 by meme meme, on Flickr

20180610_112514 by meme meme, on Flickr

20180610_112529 by meme meme, on Flickr

20180610_112550 by meme meme, on Flickr
jvh22a is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

All times are GMT -4. The time now is 12:32 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2018 Axivo Inc.
Copyright ©1999 - 2017, North American Subaru Impreza Owners Club, Inc.