Welcome to the North American Subaru Impreza Owners Club Wednesday November 14, 2018
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
Mid Atlantic Impreza Club
Mid Atlantic Impreza Club Forum sponsored by Annapolis Subaru
Go Back   NASIOC > NASIOC Chapters > Mid Atlantic Impreza Club -- MAIC

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads. 
Reply
 
Thread Tools Display Modes
Old 08-12-2014, 05:12 PM   #2526
m33p
Scooby Newbie
 
Member#: 396681
Join Date: Jul 2014
Chapter/Region: MAIC
Vehicle:
2006 WRX STi
CGM

Default

Installed a Blitz Nur Spec catback this weekend.
* Registered users of the site do not see these ads.
m33p is offline   Reply With Quote
Sponsored Links
* Registered users of the site do not see these ads.
Old 08-14-2014, 11:25 PM   #2527
MmmTabasco
Scooby Newbie
 
Member#: 233821
Join Date: Dec 2009
Chapter/Region: MAIC
Location: Washington DC suburbs
Vehicle:
2006 WRX
CGM

Default

My AccessPort arrived in the mail today and I installed my first map.

It's one of them fancy 10th anniversary commemorative silver AP's; The type men with monocles and top hats use.

I'm still learning how to make the most out of the device but so far it's pretty neat and it gives me some reading material for a few weeks. I hope to do my first data log this weekend.
MmmTabasco is offline   Reply With Quote
Old 08-14-2014, 11:40 PM   #2528
mdot1203
Scooby Newbie
 
Member#: 310527
Join Date: Feb 2012
Chapter/Region: MAIC
Location: Maryland
Vehicle:
2012 WRX Hatchback
DGM, 281hp/316tq

Default

Quote:
Originally Posted by MmmTabasco View Post
My AccessPort arrived in the mail today and I installed my first map.

It's one of them fancy 10th anniversary commemorative silver AP's; The type men with monocles and top hats use.

I'm still learning how to make the most out of the device but so far it's pretty neat and it gives me some reading material for a few weeks. I hope to do my first data log this weekend.
I ordered mine like a week before they announced that 10 years thing. Was upset at first but then I really didn't care.lol. I guess I just wanted a chance at the gold one to get all the parts for free
mdot1203 is offline   Reply With Quote
Old 08-14-2014, 11:44 PM   #2529
mdot1203
Scooby Newbie
 
Member#: 310527
Join Date: Feb 2012
Chapter/Region: MAIC
Location: Maryland
Vehicle:
2012 WRX Hatchback
DGM, 281hp/316tq

Default

Today I went Stage 2 with Cobb intake and box paired with an Invidia Catted down pipe
Running the 91 map because I'm not tripping off of .5 psi. When I get the new TMIC and EBCS on then I may go back to a 93 map



Done and done, for now. My baby is Stage 2 now and breathing like a beast.
by itcouldonlybeme, on Flickr
mdot1203 is offline   Reply With Quote
Old 08-14-2014, 11:59 PM   #2530
MmmTabasco
Scooby Newbie
 
Member#: 233821
Join Date: Dec 2009
Chapter/Region: MAIC
Location: Washington DC suburbs
Vehicle:
2006 WRX
CGM

Default

Quote:
Originally Posted by mdot1203 View Post
I ordered mine like a week before they announced that 10 years thing. Was upset at first but then I really didn't care.lol. I guess I just wanted a chance at the gold one to get all the parts for free
Yeah, free parts would have been nice.

And in fairness this silver face plate is so similar to the default one that if I didn't know there was a lottery going on I probably wouldn't have noticed the difference.
MmmTabasco is offline   Reply With Quote
Old 08-15-2014, 12:05 AM   #2531
Phileas
Scooby Newbie
 
Member#: 388362
Join Date: Apr 2014
Chapter/Region: MAIC
Location: Annapolis, MD
Vehicle:
2015 WRX Limited
ISM

Default

Installed my new OLD LED DRL/HB bulbs from Subispeed.com
Phileas is offline   Reply With Quote
Old 08-15-2014, 12:07 AM   #2532
Phileas
Scooby Newbie
 
Member#: 388362
Join Date: Apr 2014
Chapter/Region: MAIC
Location: Annapolis, MD
Vehicle:
2015 WRX Limited
ISM

Default

Got my Cobb AP in the mail today too, but I have service this weekend where I intend to complain about the idling issue that I, and many others I have read about are experiencing. So no flashy flashy until they look at it.
Phileas is offline   Reply With Quote
Old 08-15-2014, 02:30 PM   #2533
swcrow17
Scooby Specialist
 
Member#: 304498
Join Date: Dec 2011
Chapter/Region: MAIC
Location: VA
Vehicle:
07 sold :(
WRB

Default

a little refresh for the rear endlinks:

swcrow17 is offline   Reply With Quote
Old 08-15-2014, 03:51 PM   #2534
yuephoria
NASIOC Supporter
 
Member#: 64624
Join Date: Jun 2004
Chapter/Region: MAIC
Location: Kensington, MD
Vehicle:
2008 FS XT
WR Blue Pearl

Default

Made cost inquiries to various vendors about a Quaife ATB front differential for my Forester.

Yesterday I ordered JDM OEM front aero spats and Zero/Sports rear bumper skirts.
yuephoria is offline   Reply With Quote
Old 08-15-2014, 05:05 PM   #2535
simmersm
Scooby Newbie
 
Member#: 227236
Join Date: Oct 2009
Chapter/Region: MAIC
Location: Gainesville VA
Vehicle:
2006 WRX
Bright Ass Red

Default

took a 3m headlight kit after my headlights... nice and clear again. Also, just picked it up from Andrewtech yesterday getting the LGT gearset put in, Turbo XS standard muffler replacing the RFL, oil change, rear diff oil change, new belt. Sam at Andrewtech is the man!
simmersm is offline   Reply With Quote
Old 08-15-2014, 06:43 PM   #2536
psi-ops
Scooby Newbie
 
Member#: 339072
Join Date: Nov 2012
Chapter/Region: MAIC
Location: Baltimore, MD
Vehicle:
2009 Impreza WRX
OBP

Default

i drove past a golf course and right under a golf ball apparently. new windshield time :l
psi-ops is offline   Reply With Quote
Old 08-15-2014, 06:47 PM   #2537
Neysa
Scooby Newbie
 
Member#: 268694
Join Date: Dec 2010
Chapter/Region: AKIC
Location: Eagle River, AK
Vehicle:
2008 WRX
OBP

Default

Quote:
Originally Posted by psi-ops View Post
i drove past a golf course and right under a golf ball apparently. new windshield time :l
Bummer
Neysa is offline   Reply With Quote
Old 08-15-2014, 07:49 PM   #2538
blackfang
Scooby Guru
 
Member#: 131347
Join Date: Nov 2006
Chapter/Region: MAIC
Location: Richmond Va
Vehicle:
2007 Legacy 2.5i SE
98 Z/28, VN 900 custom

Default

Restored the headlights on my catfish at work. They look so much better now.

The drivers side was just as bad


blackfang is offline   Reply With Quote
Old 08-16-2014, 03:32 PM   #2539
EvileyeZ88
Scooby Specialist
 
Member#: 233501
Join Date: Dec 2009
Chapter/Region: MAIC
Location: Fairfax Va
Vehicle:
07AD 337/335SAXWAGON
99 outback sport

Default

Finally got around to installing my truhart rear lateral links.

Haven't had a rear sway bar since last September (endlinks mounting tabs snapped off) i had just been dreading the "FukYou" knuckle bolt.









Originally from Chicago with 32,000 miles, it has spent the n
Last 62,600 miles in northern VA hell.

So yeah, there was alot of rust to fight.

Next weekend, STI LCA's, roll centering kit, new inner tie rod ends, and sedan axles.

Brought to you in part by: My Thumbs
EvileyeZ88 is offline   Reply With Quote
Old 08-16-2014, 04:16 PM   #2540
ThatGy
Scooby Newbie
 
Member#: 137791
Join Date: Jan 2007
Chapter/Region: RMIC
Location: Holly Ridge, NC
Vehicle:
2002 Impreza WRX
WR Blue

Default

Quote:
Originally Posted by EvileyeZ88 View Post
Finally got around to installing my truhart rear lateral links.
What brand of swaybar is that? The reason I asked is that I noticed that you are using the Kartboy endings and I've have clearance issues with those endlinks, Perrin swaybar, and adjustable lateral links. There was some very dramatic bending issues with the Eibach ones, but just some rub makes since I've switched to Truhart for the rear lateral links. I think that the problem is that the Kartboy endlinks are shorter than the factory ones.




Here's how it looked with the Perrin bar:


Then this is what happened:


Here's how it looks with the Truhart link. Maybe I installed something wrong, but I can't figure it out.

Last edited by ThatGy; 08-16-2014 at 06:23 PM. Reason: Added more pictures
ThatGy is offline   Reply With Quote
Old 08-16-2014, 11:48 PM   #2541
EvileyeZ88
Scooby Specialist
 
Member#: 233501
Join Date: Dec 2009
Chapter/Region: MAIC
Location: Fairfax Va
Vehicle:
07AD 337/335SAXWAGON
99 outback sport

Default

It's a perrin bar for the STI, I have a wagon, so there have been issues since day one.

If you look at the right side endlink, you can see a groove that the sway bar etched out in it.

Also the reason I had to replace the lats was because the endlink mounting brackets broke off the lateral links.

I'm gonna be watching them to see if there are any clearance issues.

Brought to you in part by: My Thumbs
EvileyeZ88 is offline   Reply With Quote
Old 08-17-2014, 12:45 AM   #2542
ThatGy
Scooby Newbie
 
Member#: 137791
Join Date: Jan 2007
Chapter/Region: RMIC
Location: Holly Ridge, NC
Vehicle:
2002 Impreza WRX
WR Blue

Default

Quote:
Originally Posted by EvileyeZ88 View Post
It's a perrin bar for the STI, I have a wagon, so there have been issues since day one.

If you look at the right side endlink, you can see a groove that the sway bar etched out in it.

Also the reason I had to replace the lats was because the endlink mounting brackets broke off the lateral links.

I'm gonna be watching them to see if there are any clearance issues.

Brought to you in part by: My Thumbs
I guess that explains why it is longer. I wonder if you could have just used the STi lateral links and endings. They seem like they would be better since the endlinks are shorter and just go straight up instead of wrapping around the back of the lateral links.

I'm thinking about switching to Perrin endlinks, does anyone know if they are the same length as the factory ones?
ThatGy is offline   Reply With Quote
Old 08-17-2014, 01:35 AM   #2543
EvileyeZ88
Scooby Specialist
 
Member#: 233501
Join Date: Dec 2009
Chapter/Region: MAIC
Location: Fairfax Va
Vehicle:
07AD 337/335SAXWAGON
99 outback sport

Default

Well after looking at it, I'm having a clearance issue.

I'll see if the sti rear endlinks I have make any difference.

Brought to you in part by: My Thumbs

Last edited by EvileyeZ88; 08-17-2014 at 11:15 AM.
EvileyeZ88 is offline   Reply With Quote
Old 08-17-2014, 06:59 PM   #2544
Smurftastic
Scooby Guru
 
Member#: 243697
Join Date: Apr 2010
Chapter/Region: MAIC
Location: Virginia
Vehicle:
Stg2 +ECUtuned 02WRX
BLOD Cofounder|TopScoob31

Default

Grimmspeed upgraded IM gaskets, repainted intake manifold gunmetal, and spend five hours working on e46 suspension :\
Smurftastic is offline   Reply With Quote
Old 08-17-2014, 08:49 PM   #2545
EvileyeZ88
Scooby Specialist
 
Member#: 233501
Join Date: Dec 2009
Chapter/Region: MAIC
Location: Fairfax Va
Vehicle:
07AD 337/335SAXWAGON
99 outback sport

Default

^ that's about how long it took me to do the rear lateral links even with a lift and air tools

Brought to you in part by: My Thumbs
EvileyeZ88 is offline   Reply With Quote
Old 08-18-2014, 01:53 AM   #2546
Neysa
Scooby Newbie
 
Member#: 268694
Join Date: Dec 2010
Chapter/Region: AKIC
Location: Eagle River, AK
Vehicle:
2008 WRX
OBP

Default

Quote:
Originally Posted by EvileyeZ88 View Post

Brought to you in part by: My Thumbs
I like this better than the "sent from my x phone"
Neysa is offline   Reply With Quote
Old 08-18-2014, 02:29 PM   #2547
RavensFan7
Scooby Specialist
 
Member#: 346388
Join Date: Feb 2013
Chapter/Region: MAIC
Location: PA
Vehicle:
2001 Ej205 Impreza L
SRP

Default

Checked oil in the morning like always, and scheduled a protune.






Sent from my iPhone using NASIOC
RavensFan7 is offline   Reply With Quote
Old 08-18-2014, 02:37 PM   #2548
Mc29xMc
Scooby Newbie
 
Member#: 334338
Join Date: Oct 2012
Chapter/Region: MAIC
Location: Waldorf, MD
Vehicle:
2015 WRX
Crystal Black Silica

Default

I hit 999.0 miles when I drove into my parking spot at work
Mc29xMc is offline   Reply With Quote
Old 08-18-2014, 02:52 PM   #2549
yuephoria
NASIOC Supporter
 
Member#: 64624
Join Date: Jun 2004
Chapter/Region: MAIC
Location: Kensington, MD
Vehicle:
2008 FS XT
WR Blue Pearl

Default

Quote:
Originally Posted by RavensFan7 View Post
Checked oil in the morning like always, and scheduled a protune.
Did everything work out with the ECU?
yuephoria is offline   Reply With Quote
Old 08-18-2014, 03:22 PM   #2550
Kenmichi
Scooby Newbie
 
Member#: 329599
Join Date: Aug 2012
Chapter/Region: MAIC
Location: RVA
Vehicle:
2004 STI Aspen White
2015 Jetta TDI

Default

I passed inspection today!
Kenmichi is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

All times are GMT -4. The time now is 03:31 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2018 Axivo Inc.
Copyright ©1999 - 2017, North American Subaru Impreza Owners Club, Inc.