Welcome to the North American Subaru Impreza Owners Club Friday September 20, 2019
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Go Back   NASIOC > NASIOC General > Member's Car Gallery

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads. 
Reply
 
Thread Tools Display Modes
Old 11-01-2017, 11:03 PM   #26
jvh22a
Scooby Newbie
 
Member#: 34368
Join Date: Mar 2003
Location: pasadena, CA
Default

I got my harness from Iwire yesterday. also picked up an access port. want to thank iwire for the great service.
20171101_182158 by meme meme, on Flickr
20171101_182110 by meme meme, on Flickr


with those parts in hand, today got moving a bit. i took apart all the vents/ducts and hvac system for a cleaning. Wow it is dirty! i spent much of the day getting it cleaned and also took off the cowl and wipers to clean the fresh air duct area. thank god to took off the cowl. it was so much sand,debris, looked like a few nest in there. ill wait till i can roll the car outside and hose it down for a complete clening
before cleaning. this was about half of what was in there.
20171029_215051 by meme meme, on Flickr
20171101_182530 by meme meme, on Flickr


20171101_182504 by meme meme, on Flickr
everything cleaned. i replaced the oil in the evaporator

20171101_182419 by meme meme, on Flickr


next on the list is a crawford AOS; they said i should get a universal kit so ill order that next week.

i want to get the harness in and start the car to see anything is wrong. then ill finish up the radiator and heater hoses. but that will have to wait till next week. i made plans before i knew the harness would be finished so i cant back out of that. although i really want to.

my younger boy likes to play in the garage when im working
2017-11-01_08-04-23 by meme meme, on Flickr
* Registered users of the site do not see these ads.
jvh22a is offline   Reply With Quote
Sponsored Links
* Registered users of the site do not see these ads.
Old 11-17-2017, 03:09 AM   #27
jvh22a
Scooby Newbie
 
Member#: 34368
Join Date: Mar 2003
Location: pasadena, CA
Default

got most of the engine back together. only the lower radiator hose and coolant left.
20171115_222915 by meme meme, on Flickr

interior is still in pieces.
20171110_203228 by meme meme, on Flickr
20171111_114406 by meme meme, on Flickr
cleaned all the vents in the car. realized that subaru didnt put a screen or filter for the blower air. there was so much debris in the cowl area. it was nasty.

i got the car started and running then tried to install the cobb access port but keep getting an error. says "unable to communicate" tried everything and cant get passed that message.
20171116_114255 by meme meme, on Flickr
called cobb and the guys says "check wiring" with no further ideas on what to check or any other help.


next ,gas level gauge isnt working.

the down pipe pretty much up against the heat shield
20171115_223747 by meme meme, on Flickr

ordered some v-band clamps and stainless u bend and flex pipe to mod it. have to angle the pipe down about half an inch. then i could mod the rest of the ebay wrx exhaust.


fan set up
20171114_220329 by meme meme, on Flickr

20171114_202515 by meme meme, on Flickr
20171114_204059 by meme meme, on Flickr
jvh22a is offline   Reply With Quote
Old 11-21-2017, 09:54 PM   #28
jvh22a
Scooby Newbie
 
Member#: 34368
Join Date: Mar 2003
Location: pasadena, CA
Default

Still dealing with the cobb communication problem. Iwire sent me a brand new cobb harness to try out.
THANKS Iwire

Even with the new harness still not working. Ill deal with that later.

Next i need to finish up the exhaust. I got a cnt downpipe from ebay and the flange at the end is almost touching the heat shield right under the front part of the driveshaft. So ill have to cut off the flange and angle it down slightly. I got some 3in v-band to replace the 2 bolt flanges and a fex pipe.
The rest of the exhaust is slightly tilted so that will need to be modified.

For all this work i went and bought a inverter tig welder from harbor freight. It is a protig200 main thing i dont like is they give you a regulator instead of a flowmeter.
Miller has a sale on diversion 165 for $1600. But all thier lower end units arent made is USA so i feel HF protig 200 is a better deal.
20171121_144338 by meme meme, on Flickr
20171121_144443 by meme meme, on Flickr

Anyways, i havent tig welded in about 15 years. So need to practice.

also i cant seem to get the steering bleed. i can hear the pump trying to suck the fluid. i keep turning the wheel left to right and its not helping.

Last edited by jvh22a; 11-21-2017 at 10:30 PM.
jvh22a is offline   Reply With Quote
Old 11-30-2017, 02:11 AM   #29
jvh22a
Scooby Newbie
 
Member#: 34368
Join Date: Mar 2003
Location: pasadena, CA
Default

sent off my ecu and access port to cobb. hope they can fix my com problem. big hassle hope they can make it right

since my cheapo ebay oval exhaust didnt fit right. i went and bought another cheapo exhaust. this one is a canister. i really wanted the oval look to keep the car looking normal. but lets see how this one looks once mounted

i got to swapping my jdm seat rails with 03 rails. on the tag it says V7-V8 not sure which one it is.

once i got all the parts swapped and installed in the car, it wasnt much lower then when i put the jdm seat?rails in.

20171129_220444 by meme meme, on Flickr

not sure if i swapped everything right, but i cant be that off since most of it can only go in one way.
jvh22a is offline   Reply With Quote
Old 12-04-2017, 05:46 PM   #30
jvh22a
Scooby Newbie
 
Member#: 34368
Join Date: Mar 2003
Location: pasadena, CA
Default

cant catch a break! a few weeks ago i bought an access port from iwire and couldnt get it to install. about a week or so later i sent it into cobb and just got an email back that they can not get it installed either. AP could identy the ecu, just cant install or load maps. said that my ecu might have been on open source or something else. so they said i would likely need a new ecu.


anyone know a way around this?
is there a way to know what program was used?
can settings be changed back so that i could use the AP?


at the start of this project i bought a cheapie exhaust on ebay. i wanted an oval exhaust and found one for $120ish. once installed the muffler was tilted down on one side. i figured i could just cut the pipes and hangers and make the muffler straight. last week as i was starting my exhaust work, i noticed the the tip wasnt straight with the muffler either.

so i bought another cheap exhaust on ebay. this time a canister type. this thing is huge.

20171012_174151 by meme meme, on Flickr

to this.

20171201_145251 by meme meme, on Flickr
20171201_152237 by meme meme, on Flickr

20171201_152119 by meme meme, on Flickr


started to put back some of the interior and installed the innovate PSB-1 on an autometer pillar pod. i got a shift glow one before and didnt fit at all.

20171201_150044 by meme meme, on Flickr


i need a radio for my commutes so i invested whopping $30 for these radio and speakers. hope it works.

20171201_150740 by meme meme, on Flickr

hope to get the exhaust finished this week and once i get my ecu back, i have to bring the car down to iwire to check a few things.

still cant get the power steering bleed. if i lock the steering wheel to the right and let it go slightly, i can hear lots of bubbles in the system. i think my rack is sucking in air because all the lines look dry.


just want to drive this thing already.
jvh22a is offline   Reply With Quote
Old 12-05-2017, 04:11 PM   #31
cartwheels4amile
Scooby Specialist
 
Member#: 190405
Join Date: Sep 2008
Chapter/Region: SCIC
Location: Lake Forest, CA
Vehicle:
2002 Impreza WRX
PSM

Default

This thing is gonna be awesome! Looking forward to seeing the finished project.
cartwheels4amile is offline   Reply With Quote
Old 12-05-2017, 04:21 PM   #32
Gigs90
Scooby Specialist
 
Member#: 306719
Join Date: Jan 2012
Chapter/Region: MWSOC
Location: Troy ,Michigan
Vehicle:
2003 Sti Wagon
@jn_garage

Default

I think your seats look like V8 STi Spec C seats if they have black suede , If you do a harness merge you can always buy a haltech plug and play for the 16 bit ecu Wrx/ Sti.
Gigs90 is offline   Reply With Quote
Old 12-05-2017, 06:12 PM   #33
RallySport Direct
NASIOC Storefront Vendor
 
Member#: 33174
Join Date: Feb 2003
Chapter/Region: RMIC
Location: Salt Lake City Utah
Vehicle:
Chat Email or Phone!
888-457-2559

Default

Awesome swap! Looking forward to to this thing being done.

BTW with the AP communication issue. I assume you tried connecting the green test mode connectors right? With I-Wire having done the harness, just double check all of the test mode connectors are correct and also make sure you use the initialization connectors. I assume you've done all of this, but sometimes it's the easy things that are often overlooked.

Thanks,
Rick
RallySport Direct is offline   Reply With Quote
Old 12-05-2017, 09:04 PM   #34
D-Rodman
Scooby Specialist
 
Member#: 110078
Join Date: Mar 2006
Chapter/Region: Tri-State
Location: Long Island N.Y.
Vehicle:
05 Saabaru JDM STi
Black Ver 7 VF48 6sp RA

Default

Love swaps, keep at it, let's see more.
D-Rodman is offline   Reply With Quote
Old 12-06-2017, 11:45 AM   #35
jvh22a
Scooby Newbie
 
Member#: 34368
Join Date: Mar 2003
Location: pasadena, CA
Default

Thanks everyone! This keeps me going.

I tried everything with the AP. Iwire will help me out and see what they can do. But that will be atleast next week. Once i get the car on the road.

Since the seat is kind of high, i might get a sparco evo with buddy club rails. Ill have to skip my rs front conversion to get the seat.

Also im going to order a rebuilt rack on ebay. Its about $140 for complete rack with boots and inner tie rods. Hope that will fix the bubbling sound i get went locking the wheel to the right.
jvh22a is offline   Reply With Quote
Old 12-17-2017, 08:32 PM   #36
jvh22a
Scooby Newbie
 
Member#: 34368
Join Date: Mar 2003
Location: pasadena, CA
Default

small update.

i got the downpipe extended and added a flex pipe and innovate wideband bung
also had to modify the support hanger.

i drove it around for about 10min. ran great. alignment is way off so i didnt keep driving.

got back in i dropped the downpipe and sprayed it with a high temp paint and heat wrapped it.

got the perrin downpipe heat shield and mishimoto intercooler installed and while i was at it i replaced the power steering hose( still have a leak on the rack though).

my coolant over flow is filling up fast when reving or driving. another member told me to get a new cap. my current cap just has the rubber seal but doesnt have that thing that sticks out pass the cap on the inside. that one comes in end of this week. hope that fixes it.

i was told that my ecu problem is most likely due to ecutek locking it. but ive read a few threads that say an 02 or 03 ecu can not be unlocked even with the ecutek software. so im not sure if i should even try to unlock it because it will cost me at least $120. working or not. or go with haltech or aem like i first wanted to.

AP $650,
tuner software 150
unlock $120

or used haltech or aem
about $900ish

20171216_235543 by meme meme, on Flickr

2017-12-17_05-06-38 by meme meme, on Flickr

2017-12-17_05-20-04 by meme meme, on Flickr
jvh22a is offline   Reply With Quote
Old 12-19-2017, 04:26 PM   #37
Seahawk
Scooby Specialist
 
Member#: 71665
Join Date: Oct 2004
Chapter/Region: South East
Location: Wilmington, NC
Vehicle:
1994 Impreza
White

Default

Killer project; I'm excited for you to get it on the road! All that hard work is going to pay off soon!
Seahawk is offline   Reply With Quote
Old 12-20-2017, 01:43 PM   #38
jvh22a
Scooby Newbie
 
Member#: 34368
Join Date: Mar 2003
Location: pasadena, CA
Default

Quote:
Originally Posted by Seahawk View Post
Killer project; I'm excited for you to get it on the road! All that hard work is going to pay off soon!


thanks!! i really wanted to get this thing on the road last month, but as usual life, work and holidays slow things down.

i originally wanted to paint the engine bay and plastidip the car anthracite. but i cant find all the moldings. subaruparts only shows one side and the other side is discontinued. so i figure, get it on the road and next year( or when ever the motor blows) ill pull the motor and send the chassis to a paint shop. also each door moulding was like $100!


i got the new sti rad cap and took it for a ride. seems to work. overflow isnt filling up like it was before.

2017-12-20_10-26-40 by meme meme, on Flickr

i had installed the mishimoto intercooler the day before and removed it that night to replace a few things. i put paper towels in all ports to keep things out. when i reinstallled the intercooler, i forgot about all the towels. i just pulled the one out of the BOV port. during my test drive my idle was stuck and climbing. scratching my head for a bit i realized what i did. removed that towel and took another test drive. it happened again. this time it was worst.
i thought maybe i messed up the IAC, but it was working fine before so figured ill remove the intercooler one more time. sure enough had another towel jammed in the throttle plate.

2017-12-20_10-18-11 by meme meme, on Flickr

there is a lot of the harness left that is just looped around under the intercooler. ill have to loom that up today. i really want to shorten that harness but ill save that work for when i pull the motor.


parts just ordered.
cheapie 16g turbo
cheapie up pipe
rebuilt rack from ebay
super pro rack bushing

subarupartsdeal.com
rs bumper
bumper support
bumper foam
fog covers
the orange thing on the side
and a bunch of misc stuff.

i forgot to order the grill!

i have a corner balance and alignment set for the 29th at evasive motorsports. hope its good. i tried west end first but they said no luck till after new years.

this friday im heading to see a guy if he can unlock my ecu. sucks cause ill have to rent a trailer for this and when i get the alignment.
jvh22a is offline   Reply With Quote
Old 12-23-2017, 11:19 PM   #39
jvh22a
Scooby Newbie
 
Member#: 34368
Join Date: Mar 2003
Location: pasadena, CA
Default

got some parts yesterday. but these will have to wait till i pull the motor to replace the clutch/flywheel.

20171223_191843 by meme meme, on Flickr
20171223_115449 by meme meme, on Flickr

20171223_115733 by meme meme, on Flickr
20171223_191923 by meme meme, on Flickr

i hosed down the car to clean out the cowl area. got a lot of water in near the ecu area. so had to pull the ecu and carpet a bit to dry it out.
jvh22a is offline   Reply With Quote
Old 12-30-2017, 12:27 AM   #40
jvh22a
Scooby Newbie
 
Member#: 34368
Join Date: Mar 2003
Location: pasadena, CA
Default

well today was a complete waste of time, money and gas!!

i got a trailer early today at 7am. had an appointment for corner balance and alignment. they got the corner balance done but couldnt get the right rear toe into spec. my parts car i took everything from had damage on the right rear and had a really small bolt in the alignment hole. i replaced that with new oem hardware and i guess that made the toe really bad(thinking bent arm). looking from the rear you can tell the front part of the right rear tire is sticking out a bit. so that was a waste of $220. and ordered spc rear arms on ebay for $280ish

20171229_210037 by meme meme, on Flickr

20171229_205943 by meme meme, on Flickr

drove an hour and half to subaru to see if i can get the ecu unlocked. a few poeple think it is locked to ecutek but they couldnt do it. so i drive back home almost 2 hours in traffic.


so my options are
mspnp
haltech platinum pro pnp
haltech elite 750 or 1000
or used 03 ecu off ebay for about $120 and hope it works with the cobb AP.
and access tuner software.

today was the first time a drove the car for more then a few minutes. onced parked i had a bunch of smoke coming from the turbo area. i hope its just high temp paint or heat wrap smoking off any residue. because im just to lazy to do anymore work on this thing. i had a track day set for the Jan 13th at big willow springs and ill have to move that to another date.


on wed i got a jdm font end. i got the fenders, complete core support/front , fenders and side skirts. the guy couldnt find the rear bumper. kind of shady since he didnt say anthing about it until i asked where the rear bumper was.

i also got a jdm weapon hidden in front of the condensor
20171227_120604 by meme meme, on Flickr
20171227_120618 by meme meme, on Flickr


brake duct thing only came on the left side. hope i can still order this part for the right side. i already have the jdm fender liner with hole to connect to this.
20171227_210004 by meme meme, on Flickr


i have a mishimoto intercooler and had to remove the air splitter thing and grind down on bolt that was touching the intercooler. its the far right bolt.
20171229_205407 by meme meme, on Flickr


this is what it looks like as of today

20171229_205421 by meme meme, on Flickr
20171229_205444 by meme meme, on Flickr
20171229_205225 by meme meme, on Flickr

so got some thinking to do and decide on which way to go with the ecu. spc control arms will be here next week. i might just leave the turbo as it is for now. just to lazy to do it and maybe just hold out for when i do the clutch and flywheel.
jvh22a is offline   Reply With Quote
Old 01-02-2018, 11:32 AM   #41
Seahawk
Scooby Specialist
 
Member#: 71665
Join Date: Oct 2004
Chapter/Region: South East
Location: Wilmington, NC
Vehicle:
1994 Impreza
White

Default

If you have to get it tuned you might as well put the new turbo on now.

Why not just buy a used 02/03 WRX ecu if the one you have is locked? Surely they can't be too expensive.
Seahawk is offline   Reply With Quote
Old 01-04-2018, 12:44 AM   #42
jvh22a
Scooby Newbie
 
Member#: 34368
Join Date: Mar 2003
Location: pasadena, CA
Default

thanks for the input. i got an 02 ecu from a member here. i kind of wanted to get something newer since these ecu are getting old. but im already invested $730 for AP and another ecu that didnt work. so this one is another $110.

Spc lateral arms will be here on saturday. so i hope i can easily get all the bolts out without damaging them. alignment is set for the 16th. so hope it goes well.

ecu will be here monday. it had an AP installed before and original owner unmarried it. so it should not be a problem. once i can get it married ill take the cobb course for the tuner race software.

i was set for a track day on the 13th at big willow springs; but cant get it aligned. so next date is the 28th.
jvh22a is offline   Reply With Quote
Old 01-04-2018, 03:59 PM   #43
Bobster75
Scooby Newbie
 
Member#: 480129
Join Date: Jan 2018
Default

Ohh awesome swap👍🏻
Bobster75 is offline   Reply With Quote
Old 01-10-2018, 03:28 AM   #44
jvh22a
Scooby Newbie
 
Member#: 34368
Join Date: Mar 2003
Location: pasadena, CA
Default

thanks, that keeps me going.


2018-01-09_11-56-44 by meme meme, on Flickr

got another 02 ecu and got AP loaded and working. i loaded stage2 acn 91. the guy mailed it in a plastic shipping bag with no bubble wrap or anything to protect it!

please if you are going to mail something like an ecu take the time to wrap it.



2018-01-09_11-56-58 by meme meme, on Flickr
got the spc lateral links in. will finish that up this weekend.


2018-01-09_11-57-13 by meme meme, on Flickr

the car came with this keyless or alarm thing. when i took out the harness to send to Iwire, i forgot to label where it went. but i dont have the remotes anyways. i ordered a cheap keyless entry kit from ebay so i need to try and figure out how to install it. i had this same kit in my daily for about 2 years and worked great. so hope it will be the same.




with the new year ive been clearing my PC and moving pics from my pc to a few hard drives. ive had 2 external hard drives go bad and couldnt get the pics back. so now i have 3 external hard drives and i save the memory card from my phones.

i found some pics of few of my cars back in the day, 10 years ago.

2018-01-10_12-11-31 by meme meme, on Flickr
2018-01-09_11-53-28 by meme meme, on Flickr
2018-01-09_11-51-09 by meme meme, on Flickr
2018-01-09_11-51-49 by meme meme, on Flickr
2018-01-09_11-52-41 by meme meme, on Flickr
2018-01-09_11-52-11 by meme meme, on Flickr
my first ae86.

2018-01-10_12-05-07 by meme meme, on Flickr
my third ae86
jvh22a is offline   Reply With Quote
Old 01-10-2018, 03:35 AM   #45
jvh22a
Scooby Newbie
 
Member#: 34368
Join Date: Mar 2003
Location: pasadena, CA
Default

2018-01-10_12-06-44 by meme meme, on Flickr
350z turbonetics signal turbo kit and a bunch of stuff. dyno at 398hp to the wheels, stock motor.

2018-01-10_12-14-58 by meme meme, on Flickr
2018-01-10_12-16-13 by meme meme, on Flickr
second z 2006 added vortec supercharger. work meister wheels for track days. i used the stop tech big brake kit from the first Z.
jvh22a is offline   Reply With Quote
Old 01-10-2018, 11:15 AM   #46
Patrick Olsen
Scooby Guru
 
Member#: 120
Join Date: Jul 1999
Chapter/Region: AKIC
Location: Where the Navy sends me...
Vehicle:
1997 Legacy 2.5GT
1996 Impreza coupe

Default

Quote:
Originally Posted by jvh22a View Post
i originally wanted to paint the engine bay and plastidip the car anthracite. but i cant find all the moldings. subaruparts only shows one side and the other side is discontinued. so i figure, get it on the road and next year( or when ever the motor blows) ill pull the motor and send the chassis to a paint shop. also each door moulding was like $100!
I went through this on my '96, too. When I bought it, the car didn't have the bump strips on the passenger door or rear quarter; the mounting holes were just covered with push-pins and electrical tape. I found the quarter moulding part # and installed a new one of those:



As you found, the Subaru parts site shows the '96 coupe door moulding is NLA. So I looked up an '01 and it came up as a different part number, which is still available. [Well, it was a year ago when I was ordering parts.] The actual door skin is the same part number across all years of the coupes, so I figured the '01 moulding should fit just fine, but I wasn't sure why there would be different part numbers - black moulding is black moulding, right? I went ahead and ordered the '01 piece.

Once I got that part, I figured out what the deal is. First, the '01 part does fit on the '96. The '93-96 cars had a short piece of moulding on the front fender between the wheel well and the door; from '97 on they don't have that piece anymore. So, on my car, the driver's door has original style moulding, which comes up to leading edge of the door with a flat edge. The passenger door has the newer style ('97-01) moulding, which is rounded and doesn't come to the leading edge of the door.





Doesn't look quite right, but it's a helluva lot better than the electrical tape and panel push-pins that were covering all the holes when I bought the car!
Patrick Olsen is offline   Reply With Quote
Old 01-10-2018, 11:07 PM   #47
jvh22a
Scooby Newbie
 
Member#: 34368
Join Date: Mar 2003
Location: pasadena, CA
Default

thanks for the tip! ill look into them


i took the cobb course for the access tuner last night and got the link to download
2018-01-10_07-56-28 by meme meme, on Flickr

went on amazon and got a cheap win10 tablet. hope it will work together.

i still need to setup my PSB-1 gauge. i didnt hook up the over boost safety thing, just need to calibrate and set up the measurements.


last thing is to put the interior panels back. i hate that part.
jvh22a is offline   Reply With Quote
Old 01-20-2018, 01:05 AM   #48
jvh22a
Scooby Newbie
 
Member#: 34368
Join Date: Mar 2003
Location: pasadena, CA
Default

2018-01-13_11-52-31 by meme meme, on Flickr

not much has been done. i got the cobb access tuner and my cheap chuwi hi10 pro windows 10 tablet. works great. the tablet is really nice for only $210 with the keyboard. but it is slow typing a reply, but youtube and movies work great.

playing with the tuner race software and im really glad i didnt go with the haltech or aem. the only thing i actually used was a greddy emanage on my turbo 350z. im just lost in the program. im not scared to blow the motor so once i get it back on the ground ill play around and do some changes.

i setup the innovate psb-1 and i set the boost to psi but it keeps reading in another measurement. ive updated the firmware and programmed it about 3 times already.

i got the spc arms in today(second set) and will be installing it tomorrow. i returned the first set because of some light rust around the welds and power coat chips in a few places. i got the second set today and is about the same wear on it. ill just run it for now and use rust bullet on it later when i pull the motor.

got a big bear trip tomorrow and figured ill check around my engine and clean the air filter. this is what i found. that is half of what was in there.
2018-01-19_09-34-01 by meme meme, on Flickr
jvh22a is offline   Reply With Quote
Old 02-04-2018, 04:38 AM   #49
jvh22a
Scooby Newbie
 
Member#: 34368
Join Date: Mar 2003
Location: pasadena, CA
Default

finishing up some minor things and noticed that my turn signals blink really fast. this white connector needs to be connected that goes to the 96 turn signal. but on the jdm front there is no place to connect this. what is everyone doing for this?
20180204_001702 by meme meme, on Flickr

installing the jdm plastic thing with brake duct. my front end only came with 1 of the ducts that mount to the bumper. anyone know the parts number for this?
20180204_001408 by meme meme, on Flickr
20180204_001238 by meme meme, on Flickr


got the spc arms installed. I forgot about the swaybar mounts so now I have to remove it and install the mount
20180204_001623 by meme meme, on Flickr

got some rotor blanks and hawk hp plus pads installed today.
20180204_001312 by meme meme, on Flickr

3in ebay shifter extension. a bit to long
20180204_001551 by meme meme, on Flickr

got a ebay keyless entry kit installed.the car originally came with a bunch of relays and a bundle of wires.
20180131_111808 by meme meme, on Flickr


I got to get the charcoal canister mounted some how. its just hanging on by zipties right now and looks ugly.

I'm going back for an alignment this week and if everything works out, I'm going to sign up for a auto-x day.
jvh22a is offline   Reply With Quote
Old 02-06-2018, 12:17 PM   #50
Patrick Olsen
Scooby Guru
 
Member#: 120
Join Date: Jul 1999
Chapter/Region: AKIC
Location: Where the Navy sends me...
Vehicle:
1997 Legacy 2.5GT
1996 Impreza coupe

Default

The charcoal canister on my '96 is also partially mounted with zip-ties. The bracket is rusted all to hell. Unfortunately, the local u-pull-its basically haven't gotten any Imprezas in the past couple months, so I haven't been able to find a "new" bracket. I thought I was going to get one a few months back, only to find that the standing holding the car off the ground was basically right on the canister. Dammit!

As for your white connector, that looks to me like a foglight connector. Are you sure that goes to a turn signal?
Patrick Olsen is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

All times are GMT -4. The time now is 05:37 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2019 Axivo Inc.
Copyright ©1999 - 2019, North American Subaru Impreza Owners Club, Inc.