Welcome to the North American Subaru Impreza Owners Club Friday October 20, 2017
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
Click here to visit TireRack
Tire & Wheel Forum sponsored by The Tire Rack

Losing traction? Need new tires?
Click here to visit the NASIOC Upgrade Garage...
Go Back   NASIOC > NASIOC Technical > Tire & Wheel

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads. 
Reply
 
Thread Tools Display Modes
Old 07-17-2017, 11:08 AM   #6876
_wrxlr8r_
Scooby Newbie
 
Member#: 108886
Join Date: Mar 2006
Chapter/Region: NESIC
Location: New Hampshire
Vehicle:
2017 sti
Black

Default

Good work CV888. This gives me a great preview. I have the same size TE37 SAGA in diamond dark gunmetal waiting to go on. I just need to pick up ohlins r&t coilovers.
* Registered users of the site do not see these ads.
_wrxlr8r_ is offline   Reply With Quote
Sponsored Links
* Registered users of the site do not see these ads.
Old 07-17-2017, 02:27 PM   #6877
CV888
Scooby Newbie
 
Member#: 469394
Join Date: Jun 2017
Default

Quote:
Originally Posted by alvinli217 View Post
Aren't you rubbing at all in the rear?



I was rubbing a little bit on the rear close to bumper area running 18 x 9.5 +38 with 265/35/18 Cup2 tires



grind a little bit of the bumper and i was fine without rubbing


thats exactly what i did plus went up a little higher on height
CV888 is offline   Reply With Quote
Old 07-17-2017, 02:28 PM   #6878
CV888
Scooby Newbie
 
Member#: 469394
Join Date: Jun 2017
Default

Quote:
Originally Posted by _wrxlr8r_ View Post
Good work CV888. This gives me a great preview. I have the same size TE37 SAGA in diamond dark gunmetal waiting to go on. I just need to pick up ohlins r&t coilovers.


thats nice man what size tires are you putting?
CV888 is offline   Reply With Quote
Old 07-17-2017, 04:28 PM   #6879
_wrxlr8r_
Scooby Newbie
 
Member#: 108886
Join Date: Mar 2006
Chapter/Region: NESIC
Location: New Hampshire
Vehicle:
2017 sti
Black

Default

265/35 as well. 275 and 285 would be nice but more fender work than I want to do at this point. Good to see 265 is doable with just a proper drop, roll, grind and alignment
_wrxlr8r_ is offline   Reply With Quote
Old 07-17-2017, 04:43 PM   #6880
schkemy182
Scooby Newbie
 
Member#: 415820
Join Date: Mar 2015
Chapter/Region: MWSOC
Location: WI
Vehicle:
2015 WRX Limited
DGM

Default

Quote:
Originally Posted by _wrxlr8r_ View Post
265/35 as well. 275 and 285 would be nice but more fender work than I want to do at this point. Good to see 265 is doable with just a proper drop, roll, grind and alignment
What part of the bumper are you grinding? I have the same 18x10+35 (ZE40s though) with a 265/35 with my fenders rolled and I still rub in the rear on occasion.
schkemy182 is offline   Reply With Quote
Old 07-17-2017, 04:58 PM   #6881
_wrxlr8r_
Scooby Newbie
 
Member#: 108886
Join Date: Mar 2006
Chapter/Region: NESIC
Location: New Hampshire
Vehicle:
2017 sti
Black

Default

I imagine it's the area where the bumper and fender join. CV888 is that the part you removed or clipped back a bit?
_wrxlr8r_ is offline   Reply With Quote
Old 07-17-2017, 06:15 PM   #6882
M3lover1
Scooby Newbie
 
Member#: 440553
Join Date: Feb 2016
Chapter/Region: BAIC
Location: Bay Area
Vehicle:
2017 WRX STI Base
WRB

Default

I just installed Gram Lights 57dr 18x9.5 et38 with Michelin PSS 265/35. The rears do rub if I hit dips on freeways. Need to get rear fenders rolled. Have RCE Yellow springs and rear LCA's installed.
M3lover1 is offline   Reply With Quote
Old 07-18-2017, 02:06 AM   #6883
alvinli217
Scooby Specialist
 
Member#: 133236
Join Date: Nov 2006
Chapter/Region: International
Location: Hong Kong
Vehicle:
2016 WRB STi
04 WRB STi-GONE

Default

Quote:
Originally Posted by CV888 View Post
thats exactly what i did plus went up a little higher on height
Cool, thanks for your info!
alvinli217 is offline   Reply With Quote
Old 07-18-2017, 08:56 AM   #6884
CV888
Scooby Newbie
 
Member#: 469394
Join Date: Jun 2017
Default

Quote:
Originally Posted by _wrxlr8r_ View Post
I imagine it's the area where the bumper and fender join. CV888 is that the part you removed or clipped back a bit?


you are correct. just grinded a bit and now no more rub
CV888 is offline   Reply With Quote
Old 07-18-2017, 08:59 AM   #6885
CV888
Scooby Newbie
 
Member#: 469394
Join Date: Jun 2017
Default

Quote:
Originally Posted by jdmct9mr View Post
Will do! The anticipation is killing me! I've been debating on getting the center cap adapters but it's a bit tough to spend so much extra just to use center caps.


the thing i dont like about not having center caps is after you wash your car, water deposit in there so i use a blower to make sure it dries
CV888 is offline   Reply With Quote
Old 07-18-2017, 03:16 PM   #6886
M3lover1
Scooby Newbie
 
Member#: 440553
Join Date: Feb 2016
Chapter/Region: BAIC
Location: Bay Area
Vehicle:
2017 WRX STI Base
WRB

Default

Just a quick picture after install. Car is sitting at home couple days for now because the rears do rub a bit if I hit a dip on the freeway. Getting the rears rolled Wednesday night and hope that is enough, and not need a pull.

Gram Lights 57dr 18x9.5 +38
Michelin PSS 265/35/18
RCE Yellows with Superpro Rear LCA's.
-1.8/-2.7 f/r camber.

M3lover1 is offline   Reply With Quote
Old 07-18-2017, 10:14 PM   #6887
CV888
Scooby Newbie
 
Member#: 469394
Join Date: Jun 2017
Default 2015 WRX/STi Aftermarket wheel and tire fitment

for those that changed onto a wider wheels, how would you describe the handling of your car compared to stock?
CV888 is offline   Reply With Quote
Old 07-18-2017, 10:30 PM   #6888
aniltip
Scooby Newbie
 
Member#: 394300
Join Date: Jun 2014
Chapter/Region: NESIC
Location: North Kingstown, RI
Vehicle:
2015 WRX Limited
Dark Gray Metallic

Default

Haven't noticed much of a difference between the 18x8.5s from a 2013 STI and 18x9.5s that I run now (Done 1 autox on each set), though I would't call myself the most experienced autocrosser either.
aniltip is online now   Reply With Quote
Old 07-19-2017, 06:10 AM   #6889
jdmct9mr
Scooby Specialist
 
Member#: 289223
Join Date: Jul 2011
Chapter/Region: SCIC
Vehicle:
2015 STI
CBS

Default

Quote:
Originally Posted by CV888 View Post
the thing i dont like about not having center caps is after you wash your car, water deposit in there so i use a blower to make sure it dries


Good point. I'll make sure to use my air compressor after a wash. I hope my wheels ship by Friday.
jdmct9mr is online now   Reply With Quote
Old 07-19-2017, 12:57 PM   #6890
kaeknows
Scooby Newbie
 
Member#: 357191
Join Date: May 2013
Chapter/Region: SCIC
Location: Socal
Vehicle:
2016 WRX
ISM

Default

kaeknows is offline   Reply With Quote
Old 07-20-2017, 12:59 AM   #6891
ohemgii
Scooby Newbie
 
Member#: 457165
Join Date: Oct 2016
Default

Quote:
Originally Posted by JeffrWRX View Post
Changed my suspension, wheels, and tires up...

WedsSport TC105n 18x9.5 +35
Michelin PSS 255/35/18
Swift Spec-R's

Untitled by Jeff Ruhl, on Flickr

Untitled by Jeff Ruhl, on Flickr
I literally just ordered the same spec wheels and swift springs. I'm new to this whole modifying game, so quick question... did you have to install anything else like the LCAs, camber bolts, etc? I'm loving the way your car sits and I can't wait to install all my stuff! 😁

Edit:I also have a base model and I was told it sits different than the limitednor premium... which is why I also got springs
ohemgii is offline   Reply With Quote
Old 07-20-2017, 08:43 AM   #6892
16subaruwrx
Scooby Newbie
 
Member#: 468378
Join Date: May 2017
Default

Looking to run a 18/9.5 +38 wheel with rce yellows I've read that 255/35s fit without any issues but has anyone run 265s on this setup. Do you need to roll the fends or get LCAs etc
16subaruwrx is offline   Reply With Quote
Old 07-20-2017, 09:13 AM   #6893
Profoxcg
Scooby Newbie
 
Member#: 169036
Join Date: Jan 2008
Location: South Florida
Vehicle:
2015 STI

Default

I wonder if the car above is sticking out a bit. mine is w the same wheels and offset...
Profoxcg is offline   Reply With Quote
Old 07-20-2017, 10:39 AM   #6894
itsmet
Scooby Newbie
 
Member#: 450552
Join Date: Jul 2016
Default



This is my setup just got it aligned Volk ZE40 18x10 +39, Tires 255/35/18, Rear fenders rolled.

I actually have SPC rear LCAs so I'm running OEM camber and toe. No rubbing issues.
itsmet is offline   Reply With Quote
Old 07-20-2017, 11:48 AM   #6895
kaeknows
Scooby Newbie
 
Member#: 357191
Join Date: May 2013
Chapter/Region: SCIC
Location: Socal
Vehicle:
2016 WRX
ISM

Default

^ze40's ftw

kaeknows is offline   Reply With Quote
Old 07-20-2017, 01:23 PM   #6896
CV888
Scooby Newbie
 
Member#: 469394
Join Date: Jun 2017
Default

Quote:
Originally Posted by aniltip View Post
Haven't noticed much of a difference between the 18x8.5s from a 2013 STI and 18x9.5s that I run now (Done 1 autox on each set), though I would't call myself the most experienced autocrosser either.

mine feels like its floaty and soft? you think the tires are causing this?
CV888 is offline   Reply With Quote
Old 07-20-2017, 02:14 PM   #6897
M3lover1
Scooby Newbie
 
Member#: 440553
Join Date: Feb 2016
Chapter/Region: BAIC
Location: Bay Area
Vehicle:
2017 WRX STI Base
WRB

Default

Quote:
Originally Posted by 16subaruwrx View Post
Looking to run a 18/9.5 +38 wheel with rce yellows I've read that 255/35s fit without any issues but has anyone run 265s on this setup. Do you need to roll the fends or get LCAs etc
Mine rubs. I just put on 57dr 18x9.5 +38 with PSS 265s, also on RCE Yellows. The rear rubs, I got a roll yesterday, and its better, but the passenger side still rubs, so will have him massage it a bit more. I also have LCAs. The PSS do run wide and very square though, so that might be an issue as to why mine rubs. I have seen others on 265s with same size wheels that don't seem to rub, so experience may vary.
M3lover1 is offline   Reply With Quote
Old 07-20-2017, 06:13 PM   #6898
brianforte98
Scooby Newbie
 
Member#: 471406
Join Date: Jul 2017
Default

I have a 17 WRX, currently running stock wheels/suspension. I'm looking to make changes to both at once by going with some RCE Yellows & 18x9.5 +38 wheels. I'm curious as to what size tires I can run with this (as close to square setup as possible) without fender rolling/rubbing issues, and what people think of the RCE yellows on rough-ish roads. What I'm seeing a lot of is 265/35 or 255/40?
brianforte98 is offline   Reply With Quote
Old 07-20-2017, 07:37 PM   #6899
16subaruwrx
Scooby Newbie
 
Member#: 468378
Join Date: May 2017
Default

Quote:
Originally Posted by M3lover1 View Post
Mine rubs. I just put on 57dr 18x9.5 +38 with PSS 265s, also on RCE Yellows. The rear rubs, I got a roll yesterday, and its better, but the passenger side still rubs, so will have him massage it a bit more. I also have LCAs. The PSS do run wide and very square though, so that might be an issue as to why mine rubs. I have seen others on 265s with same size wheels that don't seem to rub, so experience may vary.
Thanks I'm probably just gonna go with 255s
16subaruwrx is offline   Reply With Quote
Old 07-20-2017, 09:44 PM   #6900
aniltip
Scooby Newbie
 
Member#: 394300
Join Date: Jun 2014
Chapter/Region: NESIC
Location: North Kingstown, RI
Vehicle:
2015 WRX Limited
Dark Gray Metallic

Default

Quote:
Originally Posted by CV888 View Post
mine feels like its floaty and soft? you think the tires are causing this?


Could be, I'm ran the same tires on both sets (just unmounted and remounted) and didn't notice a big change. What tires did you run?
aniltip is online now   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

All times are GMT -4. The time now is 02:29 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2017 Axivo Inc.
Copyright ©1999 - 2017, North American Subaru Impreza Owners Club, Inc.