Welcome to the North American Subaru Impreza Owners Club Friday November 15, 2019
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
Click here to visit TireRack
Brakes & Suspension Forum sponsored by The Tire Rack

Losing traction? Need new tires?
Click here to visit the NASIOC Upgrade Garage...
Go Back   NASIOC > NASIOC Technical > Brakes, Steering & Suspension

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.







* As an Amazon Associate I earn from qualifying purchases. 
* Registered users of the site do not see these ads. 
Reply
 
Thread Tools Display Modes
Old 12-18-2002, 08:31 PM   #1
Gargantua
Scooby Specialist
 
Member#: 15090
Join Date: Feb 2002
Location: Eureka California
Vehicle:
2002 WRX sedan
Silver

Question Odd suspension sound. any ideas?

I have the SPT suspension that was put on in june of last year. Today I notice a popping sound when I go over small bumps in the road or it "pops" when I apply the brakes at a stop sign. I got back from a long trip on monday and havent really driven it much. Could it be that something needs lubrication after going through a bunch of rain???? The sound is in the front left of the car.....what do you guys think?
thanks in advance
Steven
* Registered users of the site do not see these ads.
Gargantua is offline   Reply With Quote
Sponsored Links
* Registered users of the site do not see these ads.
Old 12-18-2002, 08:55 PM   #2
Coati
Scooby Guru
 
Member#: 9106
Join Date: Aug 2001
Chapter/Region: SCIC
Location: Wanted a Levorg
Vehicle:
2015 FXT - DGM
2008 STI - Aspen White

Default

Coati is offline   Reply With Quote
Old 12-18-2002, 09:24 PM   #3
KKL
Scooby Newbie
 
Member#: 10220
Join Date: Sep 2001
Chapter/Region: VIC
Location: N49 13' W123 03'
Vehicle:
2010 STI
World Rally Blue Pearl

Default

Hmmm, my car's developed the same thing. My only mods are mud flaps, diff protector, and skidplate. The suspension is stock and I'm on stock wheels with Dunlop SP5000's.

In my case it didn't start happening until after I had run a long TSD rally (870Km) last month. I hosed out a ton of mud that was caked up inside the strut tower (being really careful to keep it from getting inside the rubber boot). The drainage holes in the spring plate were totally plugged up with mud.

Ever since then, every time it rains, I get the occasional strange thunking noise from the right rear suspension. It usually shows up when I shift down and decelerate.

Very strange....
KKL is offline   Reply With Quote
Old 12-18-2002, 10:59 PM   #4
gtguy
Scooby Guru
 
Member#: 2184
Join Date: Aug 2000
Location: Highland Park, Ill., USA
Vehicle:
2005 Legacy GT wagon
Platinum Silver Metallic

Default Here ya go...

http://forums.nasioc.com/forums/show...ght=suspension

The Subie Gods only know why it only happens at one corner.

Kevin
gtguy is offline   Reply With Quote
Old 12-18-2002, 10:59 PM   #5
gtguy
Scooby Guru
 
Member#: 2184
Join Date: Aug 2000
Location: Highland Park, Ill., USA
Vehicle:
2005 Legacy GT wagon
Platinum Silver Metallic

Default Here ya go...

http://forums.nasioc.com/forums/show...ght=suspension

The Subie Gods only know why it only happens at one corner.

Kevin
gtguy is offline   Reply With Quote
Old 12-19-2002, 01:37 AM   #6
Gargantua
Scooby Specialist
 
Member#: 15090
Join Date: Feb 2002
Location: Eureka California
Vehicle:
2002 WRX sedan
Silver

Default

Thanks,
I am going to check out the problem and see if shiming the front left strut top does the trick
Gargantua is offline   Reply With Quote
Old 12-19-2002, 02:30 AM   #7
Coati
Scooby Guru
 
Member#: 9106
Join Date: Aug 2001
Chapter/Region: SCIC
Location: Wanted a Levorg
Vehicle:
2015 FXT - DGM
2008 STI - Aspen White

Default Re: Here ya go...

Quote:
Originally posted by gtguy
http://forums.nasioc.com/forums/show...ght=suspension

The Subie Gods only know why it only happens at one corner.

Kevin
If mine is from something like that, why would it only happen when wet?
Coati is offline   Reply With Quote
Old 12-19-2002, 11:01 AM   #8
KKL
Scooby Newbie
 
Member#: 10220
Join Date: Sep 2001
Chapter/Region: VIC
Location: N49 13' W123 03'
Vehicle:
2010 STI
World Rally Blue Pearl

Default Re: Here ya go...

Quote:
Originally posted by gtguy
http://forums.nasioc.com/forums/show...ght=suspension

The Subie Gods only know why it only happens at one corner.

Kevin
Doesn't explain my problem since I'm running the stock suspension. But I'll have to investigate it and see.
KKL is offline   Reply With Quote
Old 12-19-2002, 01:00 PM   #9
gtguy
Scooby Guru
 
Member#: 2184
Join Date: Aug 2000
Location: Highland Park, Ill., USA
Vehicle:
2005 Legacy GT wagon
Platinum Silver Metallic

Default

That posted link was for the SPT folks, only. I had a similar incident with the STi top at the driver's side front, with my DMS, and a shim fixed it.

Kevin
gtguy is offline   Reply With Quote
Old 12-19-2002, 01:00 PM   #10
gtguy
Scooby Guru
 
Member#: 2184
Join Date: Aug 2000
Location: Highland Park, Ill., USA
Vehicle:
2005 Legacy GT wagon
Platinum Silver Metallic

Default

That posted link was for the SPT folks, only. I had a similar incident with the STi top at the driver's side front, with my DMS, and a shim fixed it.

Kevin
gtguy is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Odd suspension sounds after rear sway bar scot20 Brakes, Steering & Suspension 8 07-03-2008 02:11 PM
Loud Boost Flutter Sound - Any ideas? Ronnzi Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo) 10 10-25-2007 01:56 PM
Wierd sound. Any ideas?? flabele General Community 4 01-12-2006 09:54 AM
Odd Leg Injury... Any ideas? drkwtsn Off-Topic 10 05-23-2005 03:54 PM
New HU: no sound, any ideas? Boss Car Audio, Video & Security 4 05-17-2002 01:58 AM

All times are GMT -4. The time now is 11:29 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2019 Axivo Inc.
Copyright ©1999 - 2019, North American Subaru Impreza Owners Club, Inc.

As an Amazon Associate I earn from qualifying purchases.