Welcome to the North American Subaru Impreza Owners Club Thursday March 4, 2021
Home Forums Images WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Go Back   NASIOC > NASIOC General > Member's Car Gallery

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.







* As an Amazon Associate I earn from qualifying purchases. 
* Registered users of the site do not see these ads. 
Reply
 
Thread Tools Display Modes
Old 06-13-2019, 02:18 PM   #226
JourdanWithaU
Scooby Specialist
 
Member#: 146287
Join Date: Apr 2007
Chapter/Region: BAIC
Location: NOR-CAL (South Bay Area)
Vehicle:
2011 Impreza WRX 5D
Satin White Pearl

Default

Got the tune checked and cleared for racing.

https://i.imgur.com/hQAU14W.png

Had to take the bumper/splitter off to get on the dyno.

https://i.imgur.com/vsfivtR.png

Finally got the big fresh rubber on.

https://i.imgur.com/WPLg0Tn.png

Out for some AutoX

https://i.imgur.com/wi2wpcK.png

Of course same day as Canadian Grand Prix

https://i.imgur.com/lSWvDGu.png

Dark bumpers were common.

https://i.imgur.com/Aa677Fb.png

The car survived!

https://i.imgur.com/lCuRRWY.png

Best run was my first run. Tires were too fresh and wen't giving much grip.


Didn't do well. But I was happy to have the car back out.
* Registered users of the site do not see these ads.
JourdanWithaU is offline   Reply With Quote
Sponsored Links
* Registered users of the site do not see these ads.
Old 06-14-2019, 10:30 PM   #227
MCalvert
Scooby Newbie
 
Member#: 503255
Join Date: Jun 2019
Location: Alberta, Edmonton
Vehicle:
2009 WRX STI
Rally Blye

Default

Stunning car!!
MCalvert is offline   Reply With Quote
Old 06-24-2019, 05:20 PM   #228
Zee Biker
Scooby Specialist
 
Member#: 166005
Join Date: Dec 2007
Chapter/Region: MWSOC
Location: Northern 'Burbs
Vehicle:
2005 Saab 92x
Beaten Silver

Default

What size tire were you running for Enthusiast?

Big news last week with GTA announcing spec tires for the top 2 classes!
Zee Biker is offline   Reply With Quote
Old 06-24-2019, 06:15 PM   #229
JourdanWithaU
Scooby Specialist
 
Member#: 146287
Join Date: Apr 2007
Chapter/Region: BAIC
Location: NOR-CAL (South Bay Area)
Vehicle:
2011 Impreza WRX 5D
Satin White Pearl

Default

255/40/17. Currently shelved for SLB in November.

Yeah, they got the Yokohama deal sorted. Spec tires for Street, Limited, and Unlimited. Going to hurt the people looking for records. But should level the field for competition. The spec for Limited really caught my eye. Curious to see how wide people go for that.
JourdanWithaU is offline   Reply With Quote
Old 06-25-2019, 02:13 AM   #230
werk
Scooby Newbie
 
Member#: 382167
Join Date: Feb 2014
Chapter/Region: TXIC
Location: Houston
Vehicle:
2014 wrx hatch
ISM

Default

Amazing build man! Glad i read through your thread especially seeing your wing extension from bmspec, may have to pull the trigger on that one over the password jdm piece
werk is offline   Reply With Quote
Old 07-23-2019, 01:31 PM   #231
JourdanWithaU
Scooby Specialist
 
Member#: 146287
Join Date: Apr 2007
Chapter/Region: BAIC
Location: NOR-CAL (South Bay Area)
Vehicle:
2011 Impreza WRX 5D
Satin White Pearl

Default

Where was I?

Car was running great. Geared up to do another AutoX July 7th and a trackday July 13th. The event on the 7th was a club that didn't doesn't do a street tire class so I would be able to bring out the R-comps and get some use out of those. Packed up the wheels and tools, drove 1.5 hours out to the site. Then this...

https://i.imgur.com/ldBOuqr.png

P0031, front O2 sensor crapped out.



Can't race with a broken O2. Mildly infuriated.

Amazon Prime Nexday is legit though.

https://i.imgur.com/Z9KA4m4.png

New sensor in, data looks good. Got the car checked out by my tuner again. Got the all clear for racing, again.

OUT TO THE TRACK!

https://i.imgur.com/ieeGX6S.png

Was rather hot. Day peaked at ~106. Second session was already over 90 when we went out. Now that I had an oil temp gauge, I could see that an oil cooler was necessary. Spent the day managing temps... Laptimes were not great.

https://i.imgur.com/rV4H5Ox.png

I was also promoted to the advanced group. First time in advanced and I 100% did not have the pace for it. At one point I took to the grass to let the other cars pass as we ran out of space on the main straight. Turns out, the grass was a little long.

https://i.imgur.com/dCPO1dq.png

I also yeeted my phone out the window. Luckily one of the corner workers saw it and retrieved it.

Back looks ok.

https://i.imgur.com/y8lmyJ5.png

Front is looking pretty basic.

https://i.imgur.com/hcfOlkQ.png

Caught it on video. Mount basically said, F U.


Here are the rest of the vids, https://www.youtube.com/playlist?lis...12Q-GbJ9bTitxJ
JourdanWithaU is offline   Reply With Quote
Old 07-23-2019, 04:14 PM   #232
JourdanWithaU
Scooby Specialist
 
Member#: 146287
Join Date: Apr 2007
Chapter/Region: BAIC
Location: NOR-CAL (South Bay Area)
Vehicle:
2011 Impreza WRX 5D
Satin White Pearl

Default

Some pictures from the track day.

https://i.imgur.com/oTNH89D.png

https://i.imgur.com/rHmlW46.jpg

https://i.imgur.com/7WJ31cP.jpg

After the track day, I received some more goodies.

https://i.imgur.com/CSIror8.png

Got the thing apart again.

https://i.imgur.com/J8PZDMJ.png

Oil lines made.

https://i.imgur.com/3OQaQjA.png

And all back together. Can't even tell that there's an oil cooler in there.

https://i.imgur.com/EaTCKyz.png
JourdanWithaU is offline   Reply With Quote
Old 08-01-2019, 12:27 PM   #233
JourdanWithaU
Scooby Specialist
 
Member#: 146287
Join Date: Apr 2007
Chapter/Region: BAIC
Location: NOR-CAL (South Bay Area)
Vehicle:
2011 Impreza WRX 5D
Satin White Pearl

Default

Decided to try the N1 game again...

Found a decent deal on an Invidia N1 Race. This should actually fit. Unlike the SRS N1 that melted my bumper. Being the race, it doesn't have a resonator. Only mildly worried about that.

https://i.imgur.com/PXgXhK1.png

Took a while to find motivation to actually get it going.

https://i.imgur.com/5jpMrqC.png

Q300 out.

https://i.imgur.com/itJCMG2.png

N1 in.

https://i.imgur.com/ia7cguH.png

I got a quick release pin to hold the silencer in. Thinking it would be a great little thing to make it super easy to install and remove the silencer quickly.


Is kinda loud.


https://i.imgur.com/m5TJ41J.png

Peaked at 106. Q300 peaked at 103.

Last edited by JourdanWithaU; 08-01-2019 at 02:06 PM.
JourdanWithaU is offline   Reply With Quote
Old 08-06-2019, 04:55 PM   #234
jdornski
Scooby Newbie
 
Member#: 504796
Join Date: Jul 2019
Location: Summerland BC, Canada
Vehicle:
2009 Imprezza Sedan
Black

Default ANother nice car

i have to post 3 replies to start a new thread so here you go
jdornski is offline   Reply With Quote
Old 08-28-2019, 03:20 PM   #235
JourdanWithaU
Scooby Specialist
 
Member#: 146287
Join Date: Apr 2007
Chapter/Region: BAIC
Location: NOR-CAL (South Bay Area)
Vehicle:
2011 Impreza WRX 5D
Satin White Pearl

Default

SMH...


Got my hands on a roll of gaffer tape.

Went out to tape the bumper sides to the fenders. May have gone a little overboard.

https://i.imgur.com/ELM7kyH.png

Just in time for an AutoX event.

https://i.imgur.com/tuYxRrZ.png

Hit a couple of cones. Good thing I brought the tape with me!

https://i.imgur.com/Pqm6eA4.png

On the whole, did ok. Not great. But ok. I'm starting to regret my tire choice.

https://i.imgur.com/5TF6axG.png


But the car drove ok. Didn't explode. Added 8 launches to the transmission. Seems so far the only piece that is having a bad time is the clutch.
JourdanWithaU is offline   Reply With Quote
Old 10-14-2019, 01:02 PM   #236
JourdanWithaU
Scooby Specialist
 
Member#: 146287
Join Date: Apr 2007
Chapter/Region: BAIC
Location: NOR-CAL (South Bay Area)
Vehicle:
2011 Impreza WRX 5D
Satin White Pearl

Default

Finally got the white bumper back and a bunch of bits from the dealer.

https://i.imgur.com/F2WAz91.png

Bumper on with all new clips and brackets.

https://i.imgur.com/41uB7vp.png

Finally the stars aligned and I got to do some fun things with the car...

https://i.imgur.com/qUTS4BU.png

Swapping wheels and brakes at an event wasn't fun.

https://i.imgur.com/nPkH6gk.png

The R-comps are a bit of a squeeze.

https://i.imgur.com/r7Sx17M.png

Luckily my cameras caught some of my rubber...

https://i.imgur.com/bYUcEgl.pnghttps://i.imgur.com/VDx4gpP.png

But sure enough, the car was working for too long.

https://i.imgur.com/kWuQskU.png

It's broken again. This time the clutch is totally burnt out. Couldn't even limp it home.

https://i.imgur.com/a9t1DLe.png

Running around on the slicks was fun though.
JourdanWithaU is offline   Reply With Quote
Old 10-24-2019, 05:49 PM   #237
JourdanWithaU
Scooby Specialist
 
Member#: 146287
Join Date: Apr 2007
Chapter/Region: BAIC
Location: NOR-CAL (South Bay Area)
Vehicle:
2011 Impreza WRX 5D
Satin White Pearl

Default

Ordered a new clutch. Trying Competition Clutch Stage 2 this time.

https://i.imgur.com/7sYE5m5.jpg

Got the car back to my mechanic. He seemed thrilled...

https://i.imgur.com/eYfTtFt.png

https://i.imgur.com/vOF08LZ.png

Old clutch out. Engine side didn't look too bad.

https://i.imgur.com/7OulMPR.png

Trans side however...

https://i.imgur.com/NdORtWT.png

Yeah, that would do it.

New clutch in.

https://i.imgur.com/LQTYeMH.png

Car is back home. Get to be gentile for the next few hundred miles.
JourdanWithaU is offline   Reply With Quote
Old 11-21-2019, 04:31 PM   #238
JourdanWithaU
Scooby Specialist
 
Member#: 146287
Join Date: Apr 2007
Chapter/Region: BAIC
Location: NOR-CAL (South Bay Area)
Vehicle:
2011 Impreza WRX 5D
Satin White Pearl

Default

Worked my way through clutch break-in. Pedal was still wonky. So the pedal problem wasn't a clutch problem. Problem must be with either the slave cylinder, master cylinder, or line. I figure if I'm going to change all that, I'll do the brake master cylinder too. Just all new hydralics.

Just as the clutch is broken is... Some lights come on.

https://i.imgur.com/7oooW4K.png

What's the issue?

https://i.imgur.com/6Hc6NXE.png

Of course... Off she goes...

https://i.imgur.com/jT0OrtQ.png

Wasn't alone this time.

https://i.imgur.com/hB2cCKF.png

Swapped out the hydraulics and the cam and crank position sensors.

Left side still a little advanced...

https://i.imgur.com/ip1eV5X.png

Gotta get to the timing belt... again...

https://i.imgur.com/zxZirgT.png

Belt still lined up. Perhaps the cam gear has gone bad and got stuck in advance.

While the radiator was out, a crack was found.

https://i.imgur.com/x0dHiFt.png

And while the car was on the lift a broken endlink was found.

https://i.imgur.com/FUFUmdn.png

Excuse me, both endlinks were broken...

https://i.imgur.com/sQpAvNV.png

I hope I'm starting to run out of random **** that can break...

Luckily I still have my old spherical endlinks. I just need to get a new bolt for those. SO far car is running much better than it was before. I have an appointment with my tuner next week to go over everything and see if it's clear for racing again.
JourdanWithaU is offline   Reply With Quote
Old 02-06-2021, 03:28 AM   #239
JourdanWithaU
Scooby Specialist
 
Member#: 146287
Join Date: Apr 2007
Chapter/Region: BAIC
Location: NOR-CAL (South Bay Area)
Vehicle:
2011 Impreza WRX 5D
Satin White Pearl

Default

I'm at kind of a loss on how to update this thing. I didn't think Imgur would give Nasioc the finger like it did.

Maybe I can used fb.

For clarity, the full story is on fb. The information here is abridged.

Anyway, where were we? Broken endlinks, broken cam gear, broken radiator?

K.

So, got a new cam gear in there. Engine was still knocking. Did a smoke test. Smoke was coming out of the IAT sensor...

So... New Sensor.



Also got my own boost leak tester.



Hooked that **** up...



No leaks! Cool. Also cleaned the MAF for good measure.






(4-10 hp at the wheels. LMAO)

It was also at this point that one of my lights also **** the bed...



Pulled out the broken endlinks...



The old Spheres back in...



While working on dat ass, I did some hotboi ****.



Got the stuff to get a matching rear tow strap.



TEN IMAGE LIMIT! (Please let me know if you don't see images.)
JourdanWithaU is offline   Reply With Quote
Old 02-06-2021, 03:42 AM   #240
JourdanWithaU
Scooby Specialist
 
Member#: 146287
Join Date: Apr 2007
Chapter/Region: BAIC
Location: NOR-CAL (South Bay Area)
Vehicle:
2011 Impreza WRX 5D
Satin White Pearl

Default

Then what... Oh, the battery died.



That was fun...



Keeping track of the **** that was broken and fixed...

Cam gear - Replaced
IAT - Replaced
Endlinks - Repalced
MAF - Cleaned
Radiator - YOLO

Went back to dyno, **** still ****ed. Went back to Mechanic... What do now?

MOTOR OUT!



What's the problem you might ask? Cylinder walls are fubar...



One of the pistons is also cracked...



Because I know you're asking... Barely 15k on this ****.



NEW CASE AND NEW PISTONS!!!



Also, when this went back together, added a DOM cylinder 4 cooling mod and swapped to a not cracked Koyo rad.

Back on the dyno.



It finally dynoed goodly. Making basically same power it did before.



Also learned that at full tilt, bish makes 115dB of noise. (More on this later)

JourdanWithaU is offline   Reply With Quote
Old 02-06-2021, 03:48 AM   #241
JourdanWithaU
Scooby Specialist
 
Member#: 146287
Join Date: Apr 2007
Chapter/Region: BAIC
Location: NOR-CAL (South Bay Area)
Vehicle:
2011 Impreza WRX 5D
Satin White Pearl

Default

Breaking in the engine, oil gauges started getting wonky... Wiring harness melted. NEAT.



Got my hands on some narrow brakes. Stock wheels fit again. If I take the decals off, this car can look basic AF.



Also got the Grids that I bought a year ago mounted up. They look pretty good.



Got the green light to go racing again.



Little over a year since the last time the car was driven in anger.
JourdanWithaU is offline   Reply With Quote
Old 02-06-2021, 03:53 AM   #242
JourdanWithaU
Scooby Specialist
 
Member#: 146287
Join Date: Apr 2007
Chapter/Region: BAIC
Location: NOR-CAL (South Bay Area)
Vehicle:
2011 Impreza WRX 5D
Satin White Pearl

Default

Basic:



Ready to Rock:



It was a super nice day.



Sorta got to the end of one of the tires. :/



Finished 9th and 10th out of 11. NOT LAST!



Video:


More videos:

https://www.youtube.com/playlist?lis...iccZSxRzYGPHld

Hot shots:







JourdanWithaU is offline   Reply With Quote
Old 02-06-2021, 04:03 AM   #243
JourdanWithaU
Scooby Specialist
 
Member#: 146287
Join Date: Apr 2007
Chapter/Region: BAIC
Location: NOR-CAL (South Bay Area)
Vehicle:
2011 Impreza WRX 5D
Satin White Pearl

Default

Little later, did some actual racecar ****.



The day was cold af, like 50. First session was legit. Went out with a full tank. Came back with nearly half. After ONE SESSION.



Broke into the 2:05s in the first session. New PB. Car was running great.





Second session, it warmed up a bit. Like 60. Kinda ran out of gas? Got a weird hiccup coming out of Off Ramp. Car was running warmer. But I was able to stay in it for the whole session.

Third session, it warmed up some more. Like 70. One lap and the car was too hot. But I was able to manage it with a slow lap. Mildly frustrating.

Fourth session, Challenge session. Slightly warmer, like 75. Had to alternate flying laps. Car in front of me spun on my last flyer and I had to abandon it. Kinda pissed me off.

After that it was like 80 out. Didn't even both going out. Just packed my stuff. Car runs good. It's fast. But it still can't keep its friggen cool!

Times from the whole day:



PB Video:


Full session videos:

https://www.youtube.com/playlist?lis...qpM-kzAe5aurr-

Pics:







JourdanWithaU is offline   Reply With Quote
Old 02-06-2021, 04:10 AM   #244
JourdanWithaU
Scooby Specialist
 
Member#: 146287
Join Date: Apr 2007
Chapter/Region: BAIC
Location: NOR-CAL (South Bay Area)
Vehicle:
2011 Impreza WRX 5D
Satin White Pearl

Default

So, bish is still hot... What now? Time to cut some holes in the hood!

Ordered some TrackSpec vents.

Did some eye-balling.



Going from the back side, these vents actually lined up kinda well with the structure of the hood.



Drilled holes from the backside to use as reference on the top side.



Lined up templates on the drilled holes.



CUT LINES!



DEATH WHEEL!



CUT!



Dress for success.



****, this might actually work...



That actually came out really good.



Hood not on the car yet. Waiting on some washer nozzles and for it to not be raining.
JourdanWithaU is offline   Reply With Quote
Old 02-06-2021, 04:37 AM   #245
Wild_Bill
Scooby Newbie
 
Member#: 509126
Join Date: Dec 2019
Location: Australia
Vehicle:
2002 Rs
Blue

Default Cracked pistons

Hi I was wondering if you know what caused you to crack the pistons, was it ring gaps or other issues?
Wild_Bill is offline   Reply With Quote
Old 02-07-2021, 03:14 AM   #246
JourdanWithaU
Scooby Specialist
 
Member#: 146287
Join Date: Apr 2007
Chapter/Region: BAIC
Location: NOR-CAL (South Bay Area)
Vehicle:
2011 Impreza WRX 5D
Satin White Pearl

Default

Quote:
Originally Posted by Wild_Bill View Post
Hi I was wondering if you know what caused you to crack the pistons, was it ring gaps or other issues?
I don't think there was a ring problem.

The symptom was knocking on #2 and #4.

One theory is that the engine was running lean. Which can be a tuning problem (Tuner says there wasn't a problem. I also don't think there was a tuning problem.).

Another theory; the parts were ****. The Racer X FMIC was a pile and popped apart a few times. But the Cobb pipes have been solid.

A third theory; there might have been a machining problem. Cylinders 2 and 4 could have been slightly overbored. Simple mistake as those two cylinders are the same half of the engine.

Looking at the wear over and over and over and over and over. It might be possible that it's fallout from when the timing belt tensioner broke. Piston faces looked ok. But the valves were bent. That might have been enough to do it. That one... ****ing... bolt.
JourdanWithaU is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

All times are GMT -4. The time now is 03:26 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2021, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2021 Axivo Inc.
Copyright ©1999 - 2019, North American Subaru Impreza Owners Club, Inc.

As an Amazon Associate I earn from qualifying purchases.