Welcome to the North American Subaru Impreza Owners Club Sunday August 25, 2019
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Go Back   NASIOC > NASIOC General > Newbies & FAQs

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads. 
Reply
 
Thread Tools Display Modes
Old 07-16-2019, 06:29 PM   #1
Skadoodle27
Scooby Newbie
 
Member#: 504322
Join Date: Jul 2019
Default Ac Compressor Wont Turn On.

So I have 01 2.5rs subaru Impreza. The AC compressor attempts to spin but wont actually turn on!! I checked the relays and the fuses they're all good. I bypassed the relay with a paperclip it turns on blows cold air for about 2 minutes before pressure builds up and blows freon out of somewhere. I replaced the AC relay with the horn relay and it worked again for about 2 minutes before shutting off. Now It will not work at all. Any ideas? Someone mentioned that my high pressure switch may have gone bad and someone else mentioned it just may be the clutch in the compressor.
* Registered users of the site do not see these ads.
Skadoodle27 is offline   Reply With Quote
Sponsored Links
* Registered users of the site do not see these ads.
Old 07-16-2019, 08:39 PM   #2
Unabomber
👏 Big Ron 👏
Moderator
 
Member#: 18062
Join Date: Apr 2002
Chapter/Region: MAIC
Location: I can save you a ton of cash
Vehicle:
on car parts so PM
me b4 j00 buy

Default

Low freon stops the compressor from spinning. Check/fill and if this fixes it, you likely have leak. #1 leak spot is short hose going into compressor.
Unabomber is offline   Reply With Quote
Old 07-17-2019, 06:35 PM   #3
bdubblu
Scooby Specialist
 
Member#: 251046
Join Date: Jul 2010
Chapter/Region: MAIC
Location: Mostly at my home
Vehicle:
2004 WRX Wagon
Stage 5.1.2a.2

Default

Get it filled, and when they do, have them put the dye in it so you can see the leak if it has one.
bdubblu is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

All times are GMT -4. The time now is 04:28 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2019 Axivo Inc.
Copyright ©1999 - 2019, North American Subaru Impreza Owners Club, Inc.