Welcome to the North American Subaru Impreza Owners Club Friday May 14, 2021
Home Forums Images WikiNASIOC Products Store Modifications Upgrade Garage
Click here to visit TireRack
Brakes & Suspension Forum sponsored by The Tire Rack

Losing traction? Need new tires?
Click here to visit the NASIOC Upgrade Garage...
Go Back   NASIOC > NASIOC Technical > Brakes, Steering & Suspension

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.







* As an Amazon Associate I earn from qualifying purchases. 
* Registered users of the site do not see these ads. 
Reply
 
Thread Tools Display Modes
Old 08-19-2008, 08:44 PM   #1
Maintenance Man
Scooby Newbie
 
Member#: 151610
Join Date: Jun 2007
Location: Perriysburg, Ohio
Vehicle:
2008 STI
Dark Gray Metallic

Default Clunking on 08 WRX After Pink Install

I had my STI Pink springs installed at a local "Midas" over the weekend and now notice a "Clunking" noise when I dirve over speed bumps coming from the right front. I do not notice any noise any other time while driving. Any ideas?
* Registered users of the site do not see these ads.
Maintenance Man is offline   Reply With Quote
Sponsored Links
* Registered users of the site do not see these ads.
Old 08-19-2008, 09:48 PM   #2
RaceComp Engineering
NASIOC Vendor
 
Member#: 54202
Join Date: Feb 2004
Chapter/Region: MAIC
Location: Elkridge, Maryland
Vehicle:
ASK ABOUT NEW RCE
SWAY BARS FOR STI

Default

Quote:
Originally Posted by Maintenance Man View Post
I had my STI Pink springs installed at a local "Midas" over the weekend and now notice a "Clunking" noise when I dirve over speed bumps coming from the right front. I do not notice any noise any other time while driving. Any ideas?
Yes, they prob did NOT reuse the spring liner rubber piece from the OEM spring. This is important. THey also prob didnt secure the top nut and or the conical washer and top perch in the correct position.

Myles
RaceComp Engineering is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
New rims and tires installed on 08 wrx Bobby2008WRX Tire & Wheel 6 06-09-2008 12:41 PM
Instructions for installing SS on 08 WRX? Maintenance Man Transmission (AT/MT) & Driveline 1 02-10-2008 08:46 PM
HID installation on 08 WRX Shinra21 Electrical & Lighting 6 10-14-2007 07:12 PM
Help! Noise after Pinks install. BGPKR Brakes, Steering & Suspension 3 09-21-2004 10:42 PM
Clunking sound in steering after koni install on WRX DRE1 Brakes, Steering & Suspension 4 11-13-2002 04:35 PM

All times are GMT -4. The time now is 07:58 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2021, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2021 Axivo Inc.
Copyright ©1999 - 2019, North American Subaru Impreza Owners Club, Inc.

As an Amazon Associate I earn from qualifying purchases.