Welcome to the North American Subaru Impreza Owners Club Monday April 15, 2024
Home Forums Images WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Go Back   NASIOC > NASIOC Technical > Factory 2.5L Turbo Powertrain (EJ Series Factory 2.5L Turbo)

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.







* As an Amazon Associate I earn from qualifying purchases. 
* Registered users of the site do not see these ads. 
Reply
 
Thread Tools Display Modes
Old 10-25-2008, 03:50 PM   #1
eb_rat_7
Scooby Specialist
 
Member#: 106910
Join Date: Feb 2006
Chapter/Region: NESIC
Location: MA
Vehicle:
2016 GTI
C6 ZO6 track toy

Default oil leak after turbo install

just finished up my wonder week with an 18g install. car is dripping oil and its not the oil feed line (either end) and does not seem to be coming from the oil return line. anyone have any ideas? its dripping pretty decent and you can watch the feed/drain lines and they appear to stay dry?
* Registered users of the site do not see these ads.
eb_rat_7 is offline   Reply With Quote
Sponsored Links
* Registered users of the site do not see these ads.
Old 10-25-2008, 04:27 PM   #2
eb_rat_7
Scooby Specialist
 
Member#: 106910
Join Date: Feb 2006
Chapter/Region: NESIC
Location: MA
Vehicle:
2016 GTI
C6 ZO6 track toy

Default

going to pull the turbo again. looks to be coming off the oil return line gasket (not hose)...
eb_rat_7 is offline   Reply With Quote
Old 10-25-2008, 04:28 PM   #3
boost junkie
Top Scoob 009
 
Member#: 68273
Join Date: Aug 2004
Chapter/Region: MAIC
Location: IAG Performance
Vehicle:
2012 WRX
GD Race Car

Default

You may have cracked the AVCS line, which is the hard line that goes from the AVCS port in front of the intake manifold to the back of the block, and then up to connect to the turbo oil feed line. It's pretty common to crack them when installing a turbo, they are sensitive.
boost junkie is offline   Reply With Quote
Old 10-25-2008, 08:30 PM   #4
eb_rat_7
Scooby Specialist
 
Member#: 106910
Join Date: Feb 2006
Chapter/Region: NESIC
Location: MA
Vehicle:
2016 GTI
C6 ZO6 track toy

Default

^thanks

ugg .. that was anoying..

it was the gasket from the turbo to the oil return line. with it installed you couldnt tell where the oil was coming from except it looked like it might have come from the center section. it was running along the center section and dripping from the housing.

note to people doing a turbo install. even if the turbo is NEW and comes with the return line attached- check and ensure its tight. once we tightened it it was fine. ugg... stupid fp..
eb_rat_7 is offline   Reply With Quote
Old 10-25-2008, 09:09 PM   #5
MattPersman
Scooby Specialist
 
Member#: 139385
Join Date: Jan 2007
Location: Indiana
Default

if someone else reads this in the future the WRX does not have that AVCS line that cracks. that is 04-06 STi only
MattPersman is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Coolant leak after turbo Install 855m0n0 South East Region Forum 5 03-27-2018 07:09 AM
coolant leak after turbo install Wookie768 Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo) 10 10-02-2007 05:06 PM
Oil leak after Header install? dubya tee ef fokai Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo) 10 11-26-2005 03:05 PM
Oil leak after uppipe install rmac12 Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo) 6 06-16-2005 02:50 PM
Help: bad oil leak after uppipe install abaxter34 Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo) 11 04-27-2004 03:17 AM

All times are GMT -4. The time now is 09:00 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2024, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2024 Axivo Inc.
Copyright ©1999 - 2019, North American Subaru Impreza Owners Club, Inc.

As an Amazon Associate I earn from qualifying purchases.

When you click on links to various merchants on this site and make a purchase, this can result in this site earning a commission
Affiliate programs and affiliations include, but are not limited to, the eBay Partner Network.