Welcome to the North American Subaru Impreza Owners Club Thursday November 26, 2020
Home Forums Images WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Go Back   NASIOC > NASIOC General > Newbies & FAQs

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.







* As an Amazon Associate I earn from qualifying purchases. 
* Registered users of the site do not see these ads. 
Reply
 
Thread Tools Display Modes
Old 11-19-2020, 07:13 PM   #1
Fuzzyhotdog
Scooby Newbie
 
Member#: 516376
Join Date: Jul 2020
Chapter/Region: MWSOC
Location: South Dakota
Vehicle:
2002 Forrester
TooDirty2know

Default Help! 01 impreza L EJ22 engine into a 02 forester S

01 Subaru impreza L death by rust. Obtained 02 Forester S. Both Automatic. Pulled the power train from Impreza ( EJ22 ) and bolted into the Forester ( ej25 ) slot. It runs and moves...but after a few miles it goes into LIMP MODE locking into a single gear. Should I be using the Comptuer from the EJ22 or the EJ25 ? Feel free to contact me for any details you may need to help asses...I can also live video stream symptoms. When I turn the key the dash board lights up like a christmas tree AC clutch clicks on and off and a few other unidentified noises.
* Registered users of the site do not see these ads.
Fuzzyhotdog is offline   Reply With Quote
Sponsored Links
* Registered users of the site do not see these ads.
Old 11-19-2020, 07:34 PM   #2
00redobs
Scooby Newbie
 
Member#: 325233
Join Date: Jul 2012
Location: Manitowoc, WI
Vehicle:
1999 Impreza

Default

Quote:
Originally Posted by Fuzzyhotdog View Post
When I turn the key the dash board lights up like a christmas tree AC clutch clicks on and off and a few other unidentified noises.
Test mode, unplug the green plugs.
00redobs is offline   Reply With Quote
Old 11-19-2020, 07:48 PM   #3
Jack
Add Lightness
Moderator
 
Member#: 13699
Join Date: Dec 2001
Chapter/Region: NESIC
Location: Hopkinton, MA
Vehicle:
2020 Goodbye
#fakeleader

Default

Quote:
Originally Posted by 00redobs View Post
Test mode, unplug the green plugs.
Nice catch there.
Jack is offline   Reply With Quote
Old 11-19-2020, 08:21 PM   #4
Fuzzyhotdog
Scooby Newbie
 
Member#: 516376
Join Date: Jul 2020
Chapter/Region: MWSOC
Location: South Dakota
Vehicle:
2002 Forrester
TooDirty2know

Default

OK I am dumb....https://www.iwireservices.com/post/subaru-test-mode will that cause the at temp oil light to come on too ?

Last edited by Fuzzyhotdog; 11-19-2020 at 08:28 PM.
Fuzzyhotdog is offline   Reply With Quote
Old 11-19-2020, 08:44 PM   #5
Fuzzyhotdog
Scooby Newbie
 
Member#: 516376
Join Date: Jul 2020
Chapter/Region: MWSOC
Location: South Dakota
Vehicle:
2002 Forrester
TooDirty2know

Default

Will try this ...and post update....thanks folks.....been on this project all summer.
Fuzzyhotdog is offline   Reply With Quote
Old 11-20-2020, 05:03 PM   #6
Fuzzyhotdog
Scooby Newbie
 
Member#: 516376
Join Date: Jul 2020
Chapter/Region: MWSOC
Location: South Dakota
Vehicle:
2002 Forrester
TooDirty2know

Default Test of the Guru

after unplugging the greens (test mode off). I have found that when I power on systems the AC quits the clicking. AT OIL TEMP light is flashing yet I never moved the vehicle. The idle is steady and consistant. which computer ( the one @ passenger feet ) should I be using? currently the EJ22 is installed should I be using the EJ25 ? can the transmission overheat sitting still ? can take pictures or do video if needed.

02 Forrester S with motor from 01 Impreza L 2.2L
Fuzzyhotdog is offline   Reply With Quote
Old 11-20-2020, 05:13 PM   #7
Jack
Add Lightness
Moderator
 
Member#: 13699
Join Date: Dec 2001
Chapter/Region: NESIC
Location: Hopkinton, MA
Vehicle:
2020 Goodbye
#fakeleader

Default

The EJ22 computer with the WIRING CORRECTLY GOING TO WHERE IT WOULD GO IN THE IMPREZA is what you need.

In other words......the wires from the computer to the other stuff likely isn't the same as it is in that Impreza. You'll need to figure out what's different.
Jack is offline   Reply With Quote
Old 11-21-2020, 12:43 AM   #8
Fuzzyhotdog
Scooby Newbie
 
Member#: 516376
Join Date: Jul 2020
Chapter/Region: MWSOC
Location: South Dakota
Vehicle:
2002 Forrester
TooDirty2know

Default

any idea where to start ?
Fuzzyhotdog is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

All times are GMT -4. The time now is 07:50 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2020 Axivo Inc.
Copyright ©1999 - 2019, North American Subaru Impreza Owners Club, Inc.

As an Amazon Associate I earn from qualifying purchases.