Welcome to the North American Subaru Impreza Owners Club Tuesday November 19, 2019
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Go Back   NASIOC > NASIOC General > Proven Power Bragging

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.







* As an Amazon Associate I earn from qualifying purchases. 
* Registered users of the site do not see these ads. 
Reply
 
Thread Tools Display Modes
Old 10-13-2014, 09:55 AM   #1
xluben
Scooby Guru
 
Member#: 261612
Join Date: Oct 2010
Location: Minneapolis, MN
Vehicle:
2002 WRX - 750WHP
9.5s @ 150mph

Default 2002 WRX | NF Performance | 10's on Snow Tires!

Event: 1/4 Mile at Rock Falls Raceway
Location: WI
Ambient Temp: 50F
Elevation: 845ft
Weather: Sunny and Clear
Tires: 205/60R16 Blizzak WS70 Tires on 2002 WRX Wheels

Car: 2002 WRX Sedan
Tuner: Nuke @ NF Performance
Transmission: 2012 STI 6 Speed
1/4 Mile ET: 10.98s
1/4 Mile Trap: 127.9mph
60': 1.74s
Target Boost: 30psi
Target AFR: 11's
Fuel: E85

10.98s @ 127.9mph with 1.74s 60' (snow tires)



Here's a video of an 11.1 and 10.9 sec pass:


I ran 10.99 in this car at BIR last month, but I decided to take it out again yesterday. The changes since the last passes were: addition of KillerB header setup, changed to COBB AP, swapped in a welded rear diff, put the RS flat hood back on, and put on the stock wheels with winter tires (daily driven street car and it's been getting below freezing at night).

I did a few shakedown passes with no launch just to see what it would trap. It was right around 128mph. Up from 126mph the last time, so I decided to give it a go. Ran 10.98 at 127.9 and 11.18 at 128.0 and then got the boot. 60' times were in the 1.7s range. Not as good as the 1.6's I was getting on the summer tires, but not terrible. Snow tires were a lot less stable down the track too.

************************************************** *******************

Full Build Thread Here:

http://forums.nasioc.com/forums/show....php?t=2528768

Engine:
  • OEM 2012 STI 2.5L Case
  • OEM 2012 STI Heads
  • OEM STI Nitrided Crank
  • OEM STI 11mm Oil Pump
  • OEM STI Gasket Set
  • CP 99.75mm 8.2:1 Pistons
  • Manley Turbo Tuff I Beam Rods
  • ACL Rod and Main Bearings
  • ARP Head Studs
  • GSC S1 Camshafts
  • GSC Beehive Springs w/Retainers
  • GSC Valve Seals
  • Torque Solution Motor Mounts
Intake/Exhaust/Fuel:
  • KillerB Header and EWG Uppipe
  • TurboSmar 40mm EWG
  • HKS Downpipe
  • COBB CatBack Exhaust
  • Kinugawa TD06H 60-1 Turbo
  • TurboXS FMIC
  • TurboXS RFL BOV
  • GrimmSpeed MBC
  • 04 STI Fuel Pump Hanger
  • Walbro 255 Fuel Pump
  • ID2000cc Injectors
Drivetrain/Transmission
  • OEM 2012 STI 6MT
  • OEM 2004 STI Driveshaft
  • OEM STI R180 Rear Diff Flange
  • Welded R160 Rear Diff
  • Anarchy Motive Shift Knob
  • Kartboy Short Shifter
  • Kartboy Front Shifter Bushings
  • Karboy Rear Shifter Bushings
  • Torque Solution Tranny Mount
  • Torque Solution Pitch Stop Mount
  • ACT HD Pressure Plate
  • ACT 4 Puck Unsprung Disk
Suspension/Wheels:
  • 2002 WERX Wheels
  • 205/60R16 Blizzak WS70 Tires
  • Eibach Springs
Interior/Electronics:
  • MapDCCD DCCD Controller
  • MapDCCD Vehicle Speed Sensor
  • ProSport EVO Boost Gauge
  • ProSport EVO Oil Pressure Gauge
  • AEM Wideband O2 Gauge
  • Odyssey Slim Battery
Exterior:
  • RS Flat Hood
  • OEM Fog Light Covers
  • Removed Rear Wing

Engine Bay:



Kinugawa TD06H 60-1 Turbo:

* Registered users of the site do not see these ads.
xluben is offline   Reply With Quote
Sponsored Links
* Registered users of the site do not see these ads.
Old 10-13-2014, 10:51 AM   #2
user1029
Scooby Specialist
 
Member#: 57064
Join Date: Mar 2004
Vehicle:
2008 STi IAG built
HTA86 E85 Kel272s Cos IM

Default

Next accomplishment: 10s on snow tires in the snow
user1029 is offline   Reply With Quote
Old 10-13-2014, 11:07 AM   #3
xluben
Scooby Guru
 
Member#: 261612
Join Date: Oct 2010
Location: Minneapolis, MN
Vehicle:
2002 WRX - 750WHP
9.5s @ 150mph

Default

Quote:
Originally Posted by user1029 View Post
Next accomplishment: 10s on snow tires in the snow
LOL. I think that would be a bit difficult.
xluben is offline   Reply With Quote
Old 10-13-2014, 11:09 AM   #4
Irv Weissmanhowerton
Scooby Specialist
 
Member#: 278519
Join Date: Apr 2011
Chapter/Region: SCIC
Location: Phatbotti
Vehicle:
30r E85 sti 450+whp
kb'izzle

Default

Well done, I had some studless snow tires on a spare set of wheels, thought there's a max speed of like 80 or so recommended, lol. Like the tread would peel off or something if too aggressive
Irv Weissmanhowerton is offline   Reply With Quote
Old 10-13-2014, 11:30 AM   #5
xluben
Scooby Guru
 
Member#: 261612
Join Date: Oct 2010
Location: Minneapolis, MN
Vehicle:
2002 WRX - 750WHP
9.5s @ 150mph

Default

Quote:
Originally Posted by Irv Weissmanhowerton View Post
Well done, I had some studless snow tires on a spare set of wheels, thought there's a max speed of like 80 or so recommended, lol. Like the tread would peel off or something if too aggressive
I think the Blizzaks are rated for 118mph. I could be wrong, but I think these ratings are for continuous use. They certainly didn't just fall into bits while going down the track.
xluben is offline   Reply With Quote
Old 10-13-2014, 12:24 PM   #6
besthaticouldo
Scooby Guru
 
Member#: 279660
Join Date: Apr 2011
Chapter/Region: MWSOC
Location: STL
Default

Slow.
besthaticouldo is offline   Reply With Quote
Old 10-15-2014, 01:23 PM   #7
xluben
Scooby Guru
 
Member#: 261612
Join Date: Oct 2010
Location: Minneapolis, MN
Vehicle:
2002 WRX - 750WHP
9.5s @ 150mph

Default

Old news to most here, but this is a quick video on how much 60 foot time (launch) can affect ET and trap:


Run 1:
60': 2.48
1/4: 12.12
MPH: 127.92

Run 2:
60': 1.74
1/4: 10.98
MPH: 127.92

First one is no launch and then floor it. Second one is a launch at 5750rpm's.

First is a 1/4 in 12.1s and the second is 10.9s. Trap speed is identical on both runs.
xluben is offline   Reply With Quote
Old 10-15-2014, 02:10 PM   #8
toph
Scooby Specialist
 
Member#: 78640
Join Date: Jan 2005
Chapter/Region: NESIC
Vehicle:
19 Tundra
04 STi

Default

Quote:
Originally Posted by xluben View Post
First one is no launch and then floor it. Second one is a launch at 5750rpm's.

First is a 1/4 in 12.1s and the second is 10.9s. Trap speed is identical on both runs.
Wish I could tag Celery for this post.
toph is offline   Reply With Quote
Old 10-15-2014, 08:18 PM   #9
wrxboy04
Scooby Newbie
 
Member#: 151653
Join Date: Jun 2007
Location: Rockland Ny
Vehicle:
2004 wrx
ej257 6266 10.3 at 133mph

Default

thats awsome flat foot shifting?
wrxboy04 is offline   Reply With Quote
Old 10-15-2014, 08:19 PM   #10
xluben
Scooby Guru
 
Member#: 261612
Join Date: Oct 2010
Location: Minneapolis, MN
Vehicle:
2002 WRX - 750WHP
9.5s @ 150mph

Default

Quote:
Originally Posted by toph View Post
Wish I could tag Celery for this post.
Why?

Quote:
Originally Posted by wrxboy04 View Post
thats awsome flat foot shifting?
Yes, all flat foot shifts.
xluben is offline   Reply With Quote
Old 10-15-2014, 09:24 PM   #11
toph
Scooby Specialist
 
Member#: 78640
Join Date: Jan 2005
Chapter/Region: NESIC
Vehicle:
19 Tundra
04 STi

Default

Quote:
Originally Posted by xluben View Post
Why?
http://forums.nasioc.com/forums/show...2#post42416602

#351-352.
toph is offline   Reply With Quote
Old 10-15-2014, 10:43 PM   #12
NF Performance
Scooby Newbie
 
Member#: 345246
Join Date: Jan 2013
Default

Great driving Ben

Becareful though
Too many haters are catching feelings
NF Performance is offline   Reply With Quote
Old 10-18-2014, 12:48 AM   #13
jdogma
Scooby Newbie
 
Member#: 242350
Join Date: Mar 2010
Chapter/Region: South East
Location: Atlanta
Vehicle:
2013 Carma Wolf EZ30
black

Default

Great performance! All love and no hate here, but any insight into the identical to the hundredth trap speeds when the second launch was so much better?

Thanks, John
jdogma is offline   Reply With Quote
Old 10-18-2014, 01:08 AM   #14
xluben
Scooby Guru
 
Member#: 261612
Join Date: Oct 2010
Location: Minneapolis, MN
Vehicle:
2002 WRX - 750WHP
9.5s @ 150mph

Default

Quote:
Originally Posted by toph View Post
You should link him here to set him straight. LOL.

Quote:
Originally Posted by NF Performance View Post
Great driving Ben

Becareful though
Too many haters are catching feelings
Thank you. Wouldn't be here without NF Performance backing me up!

Quote:
Originally Posted by jdogma View Post
Great performance! All love and no hate here, but any insight into the identical to the hundredth trap speeds when the second launch was so much better?

Thanks, John
Being the same down to the hundredth was just coincidence. But trap speed being very similar/repeatable is typical, and that was my point.

I made several passes with no launch and several with a 5k+ launch. ET's vary by up to 2 seconds, but the trap speeds were all between 127.0 and 128.0 mph.
xluben is offline   Reply With Quote
Old 10-18-2014, 09:02 PM   #15
happyfeet
Scooby Newbie
 
Member#: 194580
Join Date: Nov 2008
Vehicle:
05 STI
NF Performance

Default

congrat ben for 10"s
happyfeet is offline   Reply With Quote
Old 10-23-2014, 01:00 PM   #16
xluben
Scooby Guru
 
Member#: 261612
Join Date: Oct 2010
Location: Minneapolis, MN
Vehicle:
2002 WRX - 750WHP
9.5s @ 150mph

Default

Plotted out two logs I had from the track. Launch vs. No Launch.

Trap speed was very similar for both, but the no launch just gets off the line much later/slower.

Also, shifted 5th the "no launch" pass, but it didn't have a large effect either way.

Launch:


No Launch:


Overlay:
xluben is offline   Reply With Quote
Old 11-04-2014, 11:25 PM   #17
xluben
Scooby Guru
 
Member#: 261612
Join Date: Oct 2010
Location: Minneapolis, MN
Vehicle:
2002 WRX - 750WHP
9.5s @ 150mph

Default

Putting my current setup up for sale. Send me a PM if interested!

http://forums.nasioc.com/forums/show....php?t=2678149

xluben is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

All times are GMT -4. The time now is 07:35 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2019 Axivo Inc.
Copyright ©1999 - 2019, North American Subaru Impreza Owners Club, Inc.

As an Amazon Associate I earn from qualifying purchases.