Welcome to the North American Subaru Impreza Owners Club Thursday June 24, 2021
Home Forums Images WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Go Back   NASIOC > NASIOC General > General Community

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.







* As an Amazon Associate I earn from qualifying purchases. 
* Registered users of the site do not see these ads. 
Closed Thread
 
Thread Tools Display Modes
Old 05-15-2017, 04:47 PM   #1
ae86drifter
Scooby Newbie
 
Member#: 372226
Join Date: Oct 2013
Location: Las Vegas
Default 2009 WRX won't prime, crank, start

Okay so I picked up a stock 2009 wrx hatch from an insurance company after it was in a accident.

The car started fine when I got it

I installed a Tomei header, Process west intercooler, down pipe, got a new battery, new mishi radiator, mishi thermostat, grimmsped crank pulley, air pump delete.

While I was installing these parts the car sat in my garage for two months with no battery connected to it.

The car is going to be a dedicated track car so I have deleted some stuff like A/c, turn signals, head light switch, clock spring, airbags, heater core blower, radio, speakers.


Some Symptoms:

-The car will not prime the fuel pump or crank
-The fuel pump relay will not make that clicking sound when key is tuned
-When ACC is on the coolant temp guage settles on the hottest setting instead of the coldest
-The OBD port is not working, I can not connect a access port or scan tool
-The Check engine light will not illuminate at all even when accessory is on
-The security light is always flashing (I took out the keyless remote entry module but put it back in but that had no change on my problem)


What I have tested so far:
-I'm getting power to OBD port
-I'm getting power to the panel that houses the fuel pump relay
-I went to see if I could crank the engine with a screw driver attached to the two prongs on the starter, it sparked and spun freely without engaging the flywheel and cranking over.. Just spun.
-All fuses related to IGN, starter, fuel, and cigar lighter have been tested with a light up prober and all have a complete current.
-Tested the two ground straps on the passenger and driver side and they are making a complete current. (After installing the Tomei header I had to re ground the passenger side ground to the engine head.)


I suck at diagnosing problems but if I had to guess I would say my ECU is fried? I just don't see how after it started no problem before I installed these parts and now it won't start.

I'm lost in the sauce here guys.
* Registered users of the site do not see these ads.

Last edited by ae86drifter; 05-15-2017 at 05:48 PM.
ae86drifter is offline  
Sponsored Links
* Registered users of the site do not see these ads.
Old 05-15-2017, 04:55 PM   #2
Charlie-III
Scooby Guru
 
Member#: 30669
Join Date: Dec 2002
Chapter/Region: Tri-State
Location: USA, North NJ, 07456
Vehicle:
1998 Legacy 2.5GT
Silver Sleeper BK, 5MT

Default

I would check all fuses under the hood and inside the car. Either meter them or use a test light.
Likely shorted something while working on it and didn't know it.
Charlie-III is offline  
Old 05-19-2017, 06:17 PM   #3
notacarguy
*** Banned ***
 
Member#: 462586
Join Date: Feb 2017
Chapter/Region: SCIC
Location: LA
Vehicle:
2006 wrx
wrb

Default

notacarguy is offline  
Old 05-19-2017, 08:35 PM   #4
Jack
Add Lightness
Moderator
 
Member#: 13699
Join Date: Dec 2001
Chapter/Region: NESIC
Location: Hopkinton, MA
Vehicle:
2021 Building
It Better

Default

How I did a few cars might help you. Buy from insurance. Start the car. Test all the stuff that matters. Drive it around a little. Start removing things you won't need. Everything removed, get back in and start it and check stuff you still want to have.

I did this building my factory five Cobra. I did this lightening up my CRX IT racecar for prepared class. I did this when paring down the final Cobra wiring harness.

By doing this, when you accidentally remove something that you wouldn't think matters, but does, then you notice, undo the thing you did and there ya go.

I'd start by putting power directly on the fuel pump. Then see if it'll start. If it does, it's probably *something* that's on the ground side of the fuel pump.
Jack is offline  
Old 05-19-2017, 10:08 PM   #5
Knoss0s
Scooby Newbie
 
Member#: 457222
Join Date: Oct 2016
Location: Seattle, WA
Vehicle:
2014 WRX Hatchback
Black

Default 2009 WRX won't prime, crank, start

Will delete double post later.
Knoss0s is offline  
Old 05-19-2017, 10:10 PM   #6
Knoss0s
Scooby Newbie
 
Member#: 457222
Join Date: Oct 2016
Location: Seattle, WA
Vehicle:
2014 WRX Hatchback
Black

Default

Have you gotten it to crank and used starter fluid on it yet?
Knoss0s is offline  
Old 05-19-2017, 10:32 PM   #7
ae86drifter
Scooby Newbie
 
Member#: 372226
Join Date: Oct 2013
Location: Las Vegas
Default

I checked the two grounds that I know of that are on the driver and passenger side underneath the car. I don't have the grounds that the guy in the video has because I have a 2009 WRX.

How many more grounds doest the car have?
ae86drifter is offline  
Old 05-19-2017, 10:51 PM   #8
ae86drifter
Scooby Newbie
 
Member#: 372226
Join Date: Oct 2013
Location: Las Vegas
Default

So this leads to the fuel pump but I can't see where it connects too. The car had a aftermarket amp installed and I cut it out from one of these two spots.

Does any one know where they connect to and if it could be related to my problem?

ae86drifter is offline  
Old 05-19-2017, 10:52 PM   #9
ae86drifter
Scooby Newbie
 
Member#: 372226
Join Date: Oct 2013
Location: Las Vegas
Default

I'm pretty sure this one went to the seat for the seat air bag.

ae86drifter is offline  
Old 05-19-2017, 11:37 PM   #10
ae86drifter
Scooby Newbie
 
Member#: 372226
Join Date: Oct 2013
Location: Las Vegas
Default 2009 WRX won't prime, crank, start

Pretty sure this is my problem. This hoes right into the fuel pump. I drew a red line to trace where it travels. Idk what it connects to on the cut end of it though.





ae86drifter is offline  
Old 05-20-2017, 01:50 AM   #11
notacarguy
*** Banned ***
 
Member#: 462586
Join Date: Feb 2017
Chapter/Region: SCIC
Location: LA
Vehicle:
2006 wrx
wrb

Default

Quote:
Originally Posted by ae86drifter View Post
I checked the two grounds that I know of that are on the driver and passenger side underneath the car. I don't have the grounds that the guy in the video has because I have a 2009 WRX.

How many more grounds doest the car have?
derr ... my apologies.. thought that year was similiar but now membereded.. your issue is out of my youtube skills
notacarguy is offline  
Old 06-10-2021, 04:55 PM   #12
Wrx09hn
Scooby Newbie
 
Member#: 524834
Join Date: Jun 2021
Default

Hey, what was your fix? Any updates?
Wrx09hn is offline  
Old 06-10-2021, 06:44 PM   #13
Mulder
Trust no one
Moderator
 
Member#: 11170
Join Date: Oct 2001
Chapter/Region: Tri-State
Location: NYC
Vehicle:
02 RAV4 MT
15 WRX/11 CRZ

Default

Both the OP and the car are long gone.
Mulder is offline  
Closed Thread

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

All times are GMT -4. The time now is 08:06 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2021, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2021 Axivo Inc.
Copyright ©1999 - 2019, North American Subaru Impreza Owners Club, Inc.

As an Amazon Associate I earn from qualifying purchases.