Welcome to the North American Subaru Impreza Owners Club Saturday August 24, 2019
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Go Back   NASIOC > NASIOC General > Member's Car Gallery

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads. 
Reply
 
Thread Tools Display Modes
Old 03-05-2019, 06:40 PM   #101
BlueSTI4Me
Scooby Specialist
 
Member#: 34361
Join Date: Mar 2003
Chapter/Region: MWSOC
Location: MI
Vehicle:
04.7 STI
WRB IG @got2boostit2

Default

Quote:
Originally Posted by pazzoduc View Post


Maybe I missed it... what tail lights/mods are these?
Stock 2004 STi tail lights. Because flash picture, the reflectors are glowing.
* Registered users of the site do not see these ads.
BlueSTI4Me is offline   Reply With Quote
Sponsored Links
* Registered users of the site do not see these ads.
Old 03-06-2019, 05:54 AM   #102
Bru1212
Scooby Newbie
 
Member#: 178770
Join Date: Apr 2008
Chapter/Region: NESIC
Location: Western,MA
Vehicle:
06 STi
17 Fozz

Default

Love the car! One question, so you’re on Nitto 255/40/17 ? I have the same wheels and thought a 255 might rub. No fender work?
Bru1212 is offline   Reply With Quote
Old 03-06-2019, 01:14 PM   #103
BlueSTI4Me
Scooby Specialist
 
Member#: 34361
Join Date: Mar 2003
Chapter/Region: MWSOC
Location: MI
Vehicle:
04.7 STI
WRB IG @got2boostit2

Default

Quote:
Originally Posted by Bru1212 View Post
Love the car! One question, so you’re on Nitto 255/40/17 ? I have the same wheels and thought a 255 might rub. No fender work?
Since ownership I've gone through tires, lol. Now have a set of RT615K+ 255/40/17 tires and a set of Bridgestone RE71R 245/40/17 tires. Since switching to the two sets of 17x8.5 40 offset RPF1's I rolled the rear fenders to prevent rub. Fronts have never been an issue. So far so good on the rears with all of the tires used.
BlueSTI4Me is offline   Reply With Quote
Old 03-06-2019, 01:23 PM   #104
Bru1212
Scooby Newbie
 
Member#: 178770
Join Date: Apr 2008
Chapter/Region: NESIC
Location: Western,MA
Vehicle:
06 STi
17 Fozz

Default

Quote:
Originally Posted by BlueSTI4Me View Post
Since ownership I've gone through tires, lol. Now have a set of RT615K+ 255/40/17 tires and a set of Bridgestone RE71R 245/40/17 tires. Since switching to the two sets of 17x8.5 40 offset RPF1's I rolled the rear fenders to prevent rub. Fronts have never been an issue. So far so good on the rears with all of the tires used.
Appreciate it!
Bru1212 is offline   Reply With Quote
Old 05-20-2019, 03:31 PM   #105
BlueSTI4Me
Scooby Specialist
 
Member#: 34361
Join Date: Mar 2003
Chapter/Region: MWSOC
Location: MI
Vehicle:
04.7 STI
WRB IG @got2boostit2

Default

Annoyed and don't know why. Bought from this vendor a number of times, then they moved and I've bought from them at new location. But recently asked for parts quote that would normally come back immediately. Go no response after acknowledging part request. I'm at a point where I'm only going to ask once. Moved on, ordered from another vendor.
BlueSTI4Me is offline   Reply With Quote
Old 07-19-2019, 12:19 AM   #106
BlueSTI4Me
Scooby Specialist
 
Member#: 34361
Join Date: Mar 2003
Chapter/Region: MWSOC
Location: MI
Vehicle:
04.7 STI
WRB IG @got2boostit2

Default

Well several things have happened since last post. Went to Gridlife Midwest had a blast, found out my car has 5 secs of potential that I need to find. Survived the Gridlife Midwest storm of 2019.

Obtained more parts for my engine build, but still cannot start it as I need parts for the heads. Was thinking about changing turbos and going front mount with a rotated setup for the new combo, but that got but on indefinite hold as the result of a tire wall at Waterford. SMH damn head. So let's see how long it takes to get back to pre 6-14-19 status so I can move forward on this engine build.

Gridlife look.


BlueSTI4Me is offline   Reply With Quote
Old 07-19-2019, 07:18 PM   #107
VapeNashe
Scooby Newbie
 
Member#: 504427
Join Date: Jul 2019
Default

You changed the wheels?! nice
VapeNashe is offline   Reply With Quote
Old 07-20-2019, 09:30 PM   #108
BlueSTI4Me
Scooby Specialist
 
Member#: 34361
Join Date: Mar 2003
Chapter/Region: MWSOC
Location: MI
Vehicle:
04.7 STI
WRB IG @got2boostit2

Default

Quote:
Originally Posted by VapeNashe View Post
You changed the wheels?! nice
Yes bought a set of Mach V Awesome 17x9 wheels.
BlueSTI4Me is offline   Reply With Quote
Old 07-20-2019, 10:39 PM   #109
thesleekninja
Scooby Newbie
 
Member#: 504463
Join Date: Jul 2019
Vehicle:
2004 WRX Wagon
White

Default

Looking real nice!
thesleekninja is offline   Reply With Quote
Old 07-22-2019, 02:29 PM   #110
BlueSTI4Me
Scooby Specialist
 
Member#: 34361
Join Date: Mar 2003
Chapter/Region: MWSOC
Location: MI
Vehicle:
04.7 STI
WRB IG @got2boostit2

Default

Quote:
Originally Posted by thesleekninja View Post
Looking real nice!
Thanks, she was and will again in a few months.
BlueSTI4Me is offline   Reply With Quote
Old 08-02-2019, 12:06 AM   #111
BlueSTI4Me
Scooby Specialist
 
Member#: 34361
Join Date: Mar 2003
Chapter/Region: MWSOC
Location: MI
Vehicle:
04.7 STI
WRB IG @got2boostit2

Default

Tic Toc less than 13 days until she heads to the body shop.

BlueSTI4Me is offline   Reply With Quote
Old 08-02-2019, 09:50 PM   #112
BlueSTI4Me
Scooby Specialist
 
Member#: 34361
Join Date: Mar 2003
Chapter/Region: MWSOC
Location: MI
Vehicle:
04.7 STI
WRB IG @got2boostit2

Default

I really love this image captured by Nate from NVuS images at Gridlife Midwest Festival even though I'm not driving (in passenger seat). My bud Arpke is wheeling almost 5 secs a lap quicker.
BlueSTI4Me is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
the EVOlution of my STi drift_time Member's Car Gallery 72 12-11-2006 12:19 PM
New Pictures of my 05 STi, NOW WITH LESS MODS! TurboRX Member's Car Gallery 28 05-09-2006 02:36 PM
westin V. 2.0 soon to come, the evolution of my car westin_impreza Member's Car Gallery 19 03-14-2004 11:53 AM
The Evolution of my Car ERaab212 Member's Car Gallery 34 12-02-2003 02:31 PM
The Evolution of my Car ERaab212 Tri-State Area Forum 11 11-17-2003 10:09 PM

All times are GMT -4. The time now is 02:31 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2019 Axivo Inc.
Copyright ©1999 - 2019, North American Subaru Impreza Owners Club, Inc.