Welcome to the North American Subaru Impreza Owners Club Wednesday August 21, 2019
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Go Back   NASIOC > NASIOC Subaru Models > Ascent Forum

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads. 
Reply
 
Thread Tools Display Modes
Old 05-15-2019, 10:37 AM   #1
Notbrick
Scooby Specialist
 
Member#: 433072
Join Date: Oct 2015
Chapter/Region: MWSOC
Location: MO
Vehicle:
2004 STI, Stock, 55K
Silver

Default Alternator Dead at 6K miles

Alternator went out at 5,800 miles on my Ascent over the weekend.

Driving from Chicago to Saint Louis. Mother-in-law had to catch a train to KC and car shut off middle of an intersection just 100 yards from the station, an hour before she was to leave.

So yea, that was fun. Dealer said he has never seen one go out so early. I brought the car in about a month and half ago about a wurring sound I would occasionally hear when I slowed down..they told me it was the turbos.


Other than that, it has been great.
* Registered users of the site do not see these ads.
Notbrick is offline   Reply With Quote
Sponsored Links
* Registered users of the site do not see these ads.
Old 05-21-2019, 05:15 PM   #2
Notbrick
Scooby Specialist
 
Member#: 433072
Join Date: Oct 2015
Chapter/Region: MWSOC
Location: MO
Vehicle:
2004 STI, Stock, 55K
Silver

Default

Got it back today. Dealer had it for 10 days waiting to get an alternator from Subaru itself.
Notbrick is offline   Reply With Quote
Old 05-23-2019, 11:59 AM   #3
Ljspeed
Scooby Newbie
 
Member#: 467853
Join Date: May 2017
Location: San Antonio, TX
Vehicle:
2018 STI
ISM

Default

I can relate. Not for an alternator but for a windshield. We are on our second windshield and both took about a week and a half to come in from Subaru.
Ljspeed is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

All times are GMT -4. The time now is 10:59 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2019 Axivo Inc.
Copyright ©1999 - 2017, North American Subaru Impreza Owners Club, Inc.