Welcome to the North American Subaru Impreza Owners Club Saturday December 7, 2019
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
Click here to visit TireRack
Brakes & Suspension Forum sponsored by The Tire Rack

Losing traction? Need new tires?
Click here to visit the NASIOC Upgrade Garage...
Go Back   NASIOC > NASIOC Technical > Brakes, Steering & Suspension

Notices

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.







* As an Amazon Associate I earn from qualifying purchases. 
* Registered users of the site do not see these ads. 
Reply
 
Thread Tools Display Modes
Old 11-11-2019, 12:19 PM   #1
willthetech
Scooby Newbie
 
Member#: 498029
Join Date: Feb 2019
Location: Cleveland Ohio
Vehicle:
2019 WRX Premium
Pearl Blue

Default Legacy 2011 dash lights always on after rim change

So I had to get some aftermarket rims for my 2011 legacy 2.5i because the OEM metal ones were bent very bad. I got them 16 instead of 15. After the install, the break, the hill assit and other lights are always on. Someone told me the TPS sensor is screwed upů

Any ideas?
* Registered users of the site do not see these ads.
willthetech is offline   Reply With Quote
Sponsored Links
* Registered users of the site do not see these ads.
Old 11-12-2019, 10:50 AM   #2
Patrick Olsen
Scooby Guru
 
Member#: 120
Join Date: Jul 1999
Chapter/Region: AKIC
Location: Where the Navy sends me...
Vehicle:
1997 Legacy 2.5GT
1996 Impreza coupe

Default

Quote:
Originally Posted by willthetech View Post
So I had to get some aftermarket rims for my 2011 legacy 2.5i because the OEM metal ones were bent very bad.
"Metal ones" as opposed to what? Plastic ones?

Quote:
Originally Posted by willthetech View Post
I got them 16 instead of 15.


Quote:
Originally Posted by willthetech View Post
After the install, the break, the hill assit and other lights are always on. Someone told me the TPS sensor is screwed upů

Any ideas?
The obvious question is, what was done with the TPMS sensors? Were they transferred from the old wheels over to the new wheels?
Patrick Olsen is offline   Reply With Quote
Old 11-12-2019, 11:25 AM   #3
scoobydooluth
Scooby Newbie
 
Member#: 382724
Join Date: Feb 2014
Chapter/Region: MWSOC
Location: MN
Vehicle:
09 WRX Sedan
SWP

Default

TPMS shouldn't do anything to light up the brake, hill assist, or in general any "other" lights - on that note, which other lights???
(I have a TPMS light showing 24/7 in winter, and nothing else comes on with that light, all other systems work properly)

This screams to me that something got legitimately messed up in the ABS system (damaged) or the car is otherwise unhappy about something other than TPMS.

You got all 4 wheels replaced, and all with the same size tire, right?
scoobydooluth is offline   Reply With Quote
Old 11-13-2019, 10:13 AM   #4
willthetech
Scooby Newbie
 
Member#: 498029
Join Date: Feb 2019
Location: Cleveland Ohio
Vehicle:
2019 WRX Premium
Pearl Blue

Default

Quote:
Originally Posted by Patrick Olsen View Post
"Metal ones" as opposed to what? Plastic ones?





The obvious question is, what was done with the TPMS sensors? Were they transferred from the old wheels over to the new wheels?
Ha! "plastic ones", lol thanks for the laugh.

i was told they transferred everything over
willthetech is offline   Reply With Quote
Old 11-13-2019, 10:14 AM   #5
willthetech
Scooby Newbie
 
Member#: 498029
Join Date: Feb 2019
Location: Cleveland Ohio
Vehicle:
2019 WRX Premium
Pearl Blue

Default

Quote:
Originally Posted by scoobydooluth View Post
TPMS shouldn't do anything to light up the brake, hill assist, or in general any "other" lights - on that note, which other lights???
(I have a TPMS light showing 24/7 in winter, and nothing else comes on with that light, all other systems work properly)

This screams to me that something got legitimately messed up in the ABS system (damaged) or the car is otherwise unhappy about something other than TPMS.

You got all 4 wheels replaced, and all with the same size tire, right?
Yep all 16
willthetech is offline   Reply With Quote
Old 11-13-2019, 11:05 AM   #6
willthetech
Scooby Newbie
 
Member#: 498029
Join Date: Feb 2019
Location: Cleveland Ohio
Vehicle:
2019 WRX Premium
Pearl Blue

Default

So googling around it looks like this could just be a coincidence and my break switch went bad at the same time. it seems to be a common thing in that generation of subarus...

i am ordering one and ill let you guys know if that was the fix.
willthetech is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

All times are GMT -4. The time now is 03:36 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2019 Axivo Inc.
Copyright ©1999 - 2019, North American Subaru Impreza Owners Club, Inc.

As an Amazon Associate I earn from qualifying purchases.