Welcome to the North American Subaru Impreza Owners Club Sunday September 20, 2020
Home Forums Images WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Go Back   NASIOC > NASIOC General > Newbies & FAQs

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.







* As an Amazon Associate I earn from qualifying purchases. 
* Registered users of the site do not see these ads. 
 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
Old 07-29-2020, 09:20 AM   #1
JakeHovarter
Scooby Newbie
 
Member#: 498308
Join Date: Feb 2019
Default 2011 sti only making 10psi after engine rebuild

So I recently rebuilt my 2011 sti after going stage 2 external after spinning a bearing new short block was installed and many new hoses and lines also installed Iím only hitting 9-10 psi in S# have tried OTS 93 map from access port and that didnít change anything boost wise. Iíve done a boost leak test and no leaks I have a decent size waste gate crack running the oem boost control solenoid but no codes are thrown to show itís bad Iím a little lost and would like to see if anyone has any other thoughts on this issue I was making full boost before the rebuild with a boost leak and now no boost leak and I have an issue halp plz
JakeHovarter is offline   Reply With Quote
 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

All times are GMT -4. The time now is 10:53 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2020 Axivo Inc.
Copyright ©1999 - 2019, North American Subaru Impreza Owners Club, Inc.

As an Amazon Associate I earn from qualifying purchases.