Welcome to the North American Subaru Impreza Owners Club Tuesday May 18, 2021
Home Forums Images WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Go Back   NASIOC > NASIOC Subaru Models > Forester Forum

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.







* As an Amazon Associate I earn from qualifying purchases. 
* Registered users of the site do not see these ads. 
Reply
 
Thread Tools Display Modes
Old 03-28-2021, 10:23 PM   #1
Baki_kun
Scooby Newbie
 
Member#: 523262
Join Date: Mar 2021
Default Sway bar link damage?

Hello all from the PNW! First time posting here so Iíll give you the run down...
I have a 2007 Forester manual NA. with 161500 miles. Just swapped the engine for a rebuild of the same NA style.
Just checking on the breaks when I found this pieced disconnected it it the sway bar link.
Q1: would this throw an ABS light?
Q2: can I just reconnect?
Q:3 does it look damaged?

Thanks everyone!

Baki
* Registered users of the site do not see these ads.
Baki_kun is offline   Reply With Quote
Sponsored Links
* Registered users of the site do not see these ads.
Old 04-07-2021, 11:12 PM   #2
justweav6
Scooby Newbie
 
Member#: 523554
Join Date: Apr 2021
Default

Quote:
Originally Posted by Baki_kun View Post
Hello all from the PNW! First time posting here so Iíll give you the run down...
I have a 2007 Forester manual NA. with 161500 miles. Just swapped the engine for a rebuild of the same NA style.
Just checking on the breaks when I found this pieced disconnected it it the sway bar link.
Q1: would this throw an ABS light?
Q2: can I just reconnect?
Q:3 does it look damaged?

Thanks everyone!

Baki
Q1: Nope
Q2: Yes, you should be fine
Q3: There is no pic showing up
justweav6 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

All times are GMT -4. The time now is 07:51 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2021, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2021 Axivo Inc.
Copyright ©1999 - 2019, North American Subaru Impreza Owners Club, Inc.

As an Amazon Associate I earn from qualifying purchases.