Welcome to the North American Subaru Impreza Owners Club Monday December 18, 2017
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Go Back   NASIOC > NASIOC General > Car Audio, Video & Security

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads. 
Reply
 
Thread Tools Display Modes
Old 01-24-2016, 04:57 PM   #1
Brown1428
Scooby Newbie
 
Member#: 436456
Join Date: Dec 2015
Chapter/Region: South East
Vehicle:
2016 WRX LTD
CWP

Default 2016 Forester to WRX HU Transplant...

I've been doing quite a bit of research into the idea of transplanting a 7" Starlink HU from a 2016 Forester into my 2016 WRX. As has been discussed many times, the 6.2" unit is woefully inadequate.

I found a good price on a Forester unit, so I pulled the trigger and installed this weekend. Mechanically it is a perfect fit. Functionally, there are a few things to iron out:

1. USB doesn't seem to be working. The HU has a USB source feature, but it's greyed out. The connector on the rear of the unit is identical to the 6.2 unit. It may be wired differently (doubtful) or the 7" HU is expecting to detect a 2 port USB hub and not the single port in the WRX. I think the Foresters have 2 USB ports instead of one in the armrest, but I need to confirm that.

UPDATE: SVXdc helped me quite a bit with the USB issue. All that is needed is a two port USB adaptor, which I will source soon.

2. Backup camera isn't working. The wires for the camera are located in the 28 pin connector for 6.2" applications but in the 7" unit they are relocated to a separate 5 pin connector. Its possible I mis-wired something when migrating the wires. Its also possible that the forester uses a different backup camera, although that seems less likely.

UPDATE: This was indeed a mis-wire related issue. Camera now works, and the HU "maintainence" mode allows for on-screen guide line customization.

Everything else seems to work perfectly. The 7" units have a much faster UI and do not seem to suffer from the BT connection delays/woes that afflict the 6.2" unit. The steering controls are also much more responsive. Text messaging on-screen notifications are nice.

All told this project cost $375 to complete. I'm very pleased with the results. I expect the cost of second hand HUs will drop significantly as time goes on.

* Registered users of the site do not see these ads.

Last edited by Brown1428; 02-21-2016 at 09:17 PM. Reason: added update
Brown1428 is offline   Reply With Quote
Sponsored Links
* Registered users of the site do not see these ads.
Old 01-24-2016, 07:07 PM   #2
Dbui
Scooby Newbie
 
Member#: 422427
Join Date: May 2015
Chapter/Region: RMIC
Location: salt lake city
Vehicle:
2015 subaru
crystal white pearl

Default

Nice, it looks good and good job
Dbui is offline   Reply With Quote
Old 01-24-2016, 07:14 PM   #3
luke14prem
Scooby Newbie
 
Member#: 405633
Join Date: Nov 2014
Chapter/Region: NESIC
Location: NY
Vehicle:
2015 Premium 4dr
Dk gy

Default

Thanks for this...I'm also pondering swapping out my 6.2 non xm impreza stereo to a 7" unit. So I know I'd have to add in the xm antenna but other than that... Pretty straight forward you're saying?
luke14prem is offline   Reply With Quote
Old 01-24-2016, 07:19 PM   #4
16Rex
Scooby Newbie
 
Member#: 435405
Join Date: Dec 2015
Chapter/Region: SCIC
Location: Pasadena, CA
Vehicle:
2016 WRX Limited
WRB

Default

Is the 7" unit made by Clarion also?
16Rex is offline   Reply With Quote
Old 01-24-2016, 07:20 PM   #5
Brown1428
Scooby Newbie
 
Member#: 436456
Join Date: Dec 2015
Chapter/Region: South East
Vehicle:
2016 WRX LTD
CWP

Default

Quote:
Originally Posted by luke14prem View Post
Thanks for this...I'm also pondering swapping out my 6.2 non xm impreza stereo to a 7" unit.
Thanks!

It's important to note that this unit came out of a 16 Forester Premium. That's significant because it's the non-nav, non-HK 7" unit. The HK units will be much more difficult (perhaps even cost prohibitive) to integrate because they require the HK amp to work properly.

My unit has FF667UM on the faceplate. This model is also easy to spot because it has a blank where the NAV SD card slot is supposed to be.
Brown1428 is offline   Reply With Quote
Old 01-24-2016, 07:25 PM   #6
Brown1428
Scooby Newbie
 
Member#: 436456
Join Date: Dec 2015
Chapter/Region: South East
Vehicle:
2016 WRX LTD
CWP

Default

Quote:
Originally Posted by luke14prem View Post
Thanks for this...I'm also pondering swapping out my 6.2 non xm impreza stereo to a 7" unit. So I know I'd have to add in the xm antenna but other than that... Pretty straight forward you're saying?
It's 90% plug and play. The backup camera wires need to be moved from one connector to a new one, the hard to find 5 pin connector that isn't on the 6.2 harness. Other than that it is a pin for pin, connector for connector match. I need to buy a two port USB AUX plate too. As I said the USB function isn't working atm.
Brown1428 is offline   Reply With Quote
Old 01-24-2016, 07:32 PM   #7
Brown1428
Scooby Newbie
 
Member#: 436456
Join Date: Dec 2015
Chapter/Region: South East
Vehicle:
2016 WRX LTD
CWP

Default

Quote:
Originally Posted by 16Rex View Post
Is the 7" unit made by Clarion also?

No, this is a Fujitsu Ten unit.
Brown1428 is offline   Reply With Quote
Old 01-25-2016, 01:11 AM   #8
Vector
Scooby Newbie
 
Member#: 14900
Join Date: Feb 2002
Chapter/Region: MWSOC
Location: Twin Cities, MN
Vehicle:
2016 WRX Limited
LBP

Default

Might have to pull the HU and check the pins on the USB connector. That connector is a terrible design, and the pins are easy to bend without realizing it.

Looks like another good option for the 2016 crowd!
Vector is offline   Reply With Quote
Old 01-25-2016, 11:28 PM   #9
16Rex
Scooby Newbie
 
Member#: 435405
Join Date: Dec 2015
Chapter/Region: SCIC
Location: Pasadena, CA
Vehicle:
2016 WRX Limited
WRB

Default

It's an awesome option, all you have to do is find a HU from a 2016 Forester Premium.
16Rex is offline   Reply With Quote
Old 01-26-2016, 08:31 AM   #10
Brown1428
Scooby Newbie
 
Member#: 436456
Join Date: Dec 2015
Chapter/Region: South East
Vehicle:
2016 WRX LTD
CWP

Default

Quote:
Originally Posted by luke14prem View Post
Thanks for this...I'm also pondering swapping out my 6.2 non xm impreza stereo to a 7" unit. So I know I'd have to add in the xm antenna but other than that... Pretty straight forward you're saying?
There is a 7" Impreza Starlink unit on eBay as we speak. Not affiliated with the seller, except it's the same chap I bought my Forester unit from.
Brown1428 is offline   Reply With Quote
Old 01-27-2016, 07:20 PM   #11
cyralax
Scooby Newbie
 
Member#: 425154
Join Date: Jul 2015
Chapter/Region: W. Canada
Vehicle:
2016 WRX Sport
Lapis Blue Pearl

Default

Going along the same idea, would getting a JDM WRX head unit work? I got a brochure two years ago which listed head units for the Levorg and new WRX.
cyralax is offline   Reply With Quote
Old 01-28-2016, 04:14 PM   #12
nodrog321
Scooby Newbie
 
Member#: 394477
Join Date: Jun 2014
Chapter/Region: Tri-State
Location: Queens, NYC
Vehicle:
2016 WRX Limited
CWP

Default

this looks good but damn wish there was a PnP alternative to the 6.2" bluetooth problems.. I have to close my spotify app my phone connects to the car which takes what feels like an eternity after starting the car. and from time to time, the quality cuts in and out. dont even know how subaru put out such a terrible head unit..
nodrog321 is offline   Reply With Quote
Old 01-28-2016, 04:36 PM   #13
Brown1428
Scooby Newbie
 
Member#: 436456
Join Date: Dec 2015
Chapter/Region: South East
Vehicle:
2016 WRX LTD
CWP

Default

Quote:
Originally Posted by nodrog321 View Post
this looks good but damn wish there was a PnP alternative to the 6.2" bluetooth problems.. I have to close my spotify app my phone connects to the car which takes what feels like an eternity after starting the car. and from time to time, the quality cuts in and out. dont even know how subaru put out such a terrible head unit..

Unfortunately this is about as PnP as you're gonna when it comes to switching out a HU.

My experience with the 6.2" was identical. It is absolute garbage. The "insufficient network connectivity" Pandora message would drive me into fits of homicidal rage.

What I don't get is why Subaru puts the 7" unit I have in a low trim Forester but won't put the same unit in a WRX Limited as standard equipment. I can't stress enough how much better this unit is than the 6.2", it's night and day.

The only thing I'm not in love with is the white knob/button backlighting, which doesn't match the red WRX motif.
Brown1428 is offline   Reply With Quote
Old 01-29-2016, 12:24 PM   #14
Brown1428
Scooby Newbie
 
Member#: 436456
Join Date: Dec 2015
Chapter/Region: South East
Vehicle:
2016 WRX LTD
CWP

Default

If anyone knows where to find the 5 pin connector that subaru uses for the 7" Starlink units, please let me know. I've been trying to find that sucker for a while now without success.
Brown1428 is offline   Reply With Quote
Old 01-30-2016, 09:50 AM   #15
midwestmonster
Scooby Newbie
 
Member#: 54390
Join Date: Feb 2004
Chapter/Region: MWSOC
Location: Illinois
Vehicle:
2016 Sti w/nav
CWP

Default

Quote:
Originally Posted by Brown1428 View Post
Unfortunately this is about as PnP as you're gonna when it comes to switching out a HU.

My experience with the 6.2" was identical. It is absolute garbage. The "insufficient network connectivity" Pandora message would drive me into fits of homicidal rage.

What I don't get is why Subaru puts the 7" unit I have in a low trim Forester but won't put the same unit in a WRX Limited as standard equipment. I can't stress enough how much better this unit is than the 6.2", it's night and day.

The only thing I'm not in love with is the white knob/button backlighting, which doesn't match the red WRX motif.
Dude you're my hero. Seriously. I went through the hassle of swapping out cars with SOA to fix my issue. My thread is here explaining. Dealership said this swap wasn't possible because wiring is completely different. People don't realize how much better the 7" unit is over the 6.2".

Couple questions. Since the usb isn't working, I'm guessing you can't hookup an iPod, correct? If you could make a video on what functions work that would be awesome. I had thought about doing what you did but was afraid I'd be throwing away money based on the research I did. Awesome leap of faith man. You give a lot of people hope.

Last edited by midwestmonster; 01-30-2016 at 10:05 AM.
midwestmonster is offline   Reply With Quote
Old 01-30-2016, 10:11 AM   #16
Brown1428
Scooby Newbie
 
Member#: 436456
Join Date: Dec 2015
Chapter/Region: South East
Vehicle:
2016 WRX LTD
CWP

Default

Quote:
Originally Posted by midwestmonster View Post
Couple questions. Since the usb isn't working, I'm guessing you can't hookup an iPod, correct? Do the navigation controls work? If you could make a video on what functions work that would be awesome. I had thought about doing what you did but was afraid I'd be throwing away money based on the research I did. Awesome leap of faith man. You give a lot of people hope.
No, right now you can't use any device that requires USB. I use my iPhone via BT, which works flawlessly. I'm confident that USB functionality will be restored once I'm able to get my hands on the dual USB/AUX adaptor that comes with cars equipped with the 7" unit from that factory. Dealer wants $117 for it, so I'm exploring alternatives.

Navigation controls? Like steering wheel controls? All buttons work as intended, because forester has the same button layout on the steering wheel.

So right now everything works except the backup camera and USB. Both of these are easy fixes, it's just a matter of having the right parts. I'm waiting on a connector to come in before fixing the BU camera.

Thanks for the positive words. I'll be sure to post an update once everything is working.
Brown1428 is offline   Reply With Quote
Old 01-30-2016, 11:19 AM   #17
Brown1428
Scooby Newbie
 
Member#: 436456
Join Date: Dec 2015
Chapter/Region: South East
Vehicle:
2016 WRX LTD
CWP

Default

Quote:
Originally Posted by midwestmonster View Post
Dude you're my hero. Seriously. I went through the hassle of swapping out cars with SOA to fix my issue. My thread is here explaining. Dealership said this swap wasn't possible because wiring is completely different. People don't realize how much better the 7" unit is over the 6.2".

The dealer was probably thinking you wanted the 7" NAV+HK unit, which would be a huge pain to integrate. I too briefly looked into that unit as an option but quickly dismissed it after learning what would be involved.
Brown1428 is offline   Reply With Quote
Old 01-30-2016, 03:23 PM   #18
midwestmonster
Scooby Newbie
 
Member#: 54390
Join Date: Feb 2004
Chapter/Region: MWSOC
Location: Illinois
Vehicle:
2016 Sti w/nav
CWP

Default

Yeah I didn't know there was a non navigation 7" unit.
midwestmonster is offline   Reply With Quote
Old 01-30-2016, 03:49 PM   #19
biserker1
Scooby Newbie
 
Member#: 427273
Join Date: Aug 2015
Location: Philadelphia, PA
Vehicle:
2016 WRX Limited

Default

great job, do you happen to have any pictures of the back of this unit? Considering this as well...
biserker1 is offline   Reply With Quote
Old 01-30-2016, 05:02 PM   #20
Brown1428
Scooby Newbie
 
Member#: 436456
Join Date: Dec 2015
Chapter/Region: South East
Vehicle:
2016 WRX LTD
CWP

Default

Quote:
Originally Posted by biserker1 View Post
great job, do you happen to have any pictures of the back of this unit? Considering this as well...

Absolutely. When this job is finished - hopefully by next weekend when my parts arrive - I'm going to put together a more thorough post, including pictures.

As far as the "great job", it really is super easy to do so I can't take credit for much of anything
Brown1428 is offline   Reply With Quote
Old 01-30-2016, 10:08 PM   #21
biserker1
Scooby Newbie
 
Member#: 427273
Join Date: Aug 2015
Location: Philadelphia, PA
Vehicle:
2016 WRX Limited

Default

Quote:
Originally Posted by Brown1428 View Post
Absolutely. When this job is finished - hopefully by next weekend when my parts arrive - I'm going to put together a more thorough post, including pictures.

As far as the "great job", it really is super easy to do so I can't take credit for much of anything
thanks! appreciate it!
biserker1 is offline   Reply With Quote
Old 03-08-2016, 03:37 PM   #22
EJ1
Scooby Specialist
 
Member#: 61296
Join Date: May 2004
Location: ಠ_ಠ
Default

.....

Last edited by EJ1; 03-09-2016 at 10:55 AM.
EJ1 is offline   Reply With Quote
Old 03-08-2016, 04:00 PM   #23
dsn112
Scooby Specialist
 
Member#: 332561
Join Date: Sep 2012
Chapter/Region: Tri-State
Location: Southern NJ/Philly
Vehicle:
2015 GTI Autobahn
White

Default

Sorry, I think this is a waste. Just under $400 for still a junk unit. I had the 7" with Nav and HK in my legacy ltd and while better than this, still not worth any money. Easily could have put that money to something better and had real features.

For the record I upgraded my speakers and added an amp because I wanted to stay OEM, so I get it, but this seems crazy.
dsn112 is offline   Reply With Quote
Old 03-09-2016, 10:56 AM   #24
EJ1
Scooby Specialist
 
Member#: 61296
Join Date: May 2004
Location: ಠ_ಠ
Default

I was able to source one for $150 so they can be had for less than $400. Definitely worth it given the cost.
EJ1 is offline   Reply With Quote
Old 03-09-2016, 10:33 PM   #25
Brown1428
Scooby Newbie
 
Member#: 436456
Join Date: Dec 2015
Chapter/Region: South East
Vehicle:
2016 WRX LTD
CWP

Default

Quote:
Originally Posted by dsn112 View Post
Sorry, I think this is a waste. Just under $400 for still a junk unit. I had the 7" with Nav and HK in my legacy ltd and while better than this, still not worth any money. Easily could have put that money to something better and had real features.

For the record I upgraded my speakers and added an amp because I wanted to stay OEM, so I get it, but this seems crazy.
I'm pleased with the setup, but I understand this isn't for everyone. Thank you for sharing.
Brown1428 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

All times are GMT -4. The time now is 05:46 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2017 Axivo Inc.
Copyright ©1999 - 2017, North American Subaru Impreza Owners Club, Inc.