Welcome to the North American Subaru Impreza Owners Club Friday December 15, 2017
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Go Back   NASIOC > NASIOC General > Car Audio, Video & Security

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads. 
Reply
 
Thread Tools Display Modes
Old 05-26-2016, 02:50 PM   #51
foghelmut
Scooby Specialist
 
Member#: 328414
Join Date: Aug 2012
Location: Southern California
Vehicle:
2012 Impreza SP 5MT
obsidian pearl black

Default

Could this be done with a 2012-2014? I think the wiring would be the same, you'd also need the new top center vent piece. My big concern would be the mounting bracket locations. Has anyone done this? Is there a thread about it?
* Registered users of the site do not see these ads.
foghelmut is offline   Reply With Quote
Sponsored Links
* Registered users of the site do not see these ads.
Old 05-28-2016, 12:11 AM   #52
Brown1428
Scooby Newbie
 
Member#: 436456
Join Date: Dec 2015
Chapter/Region: South East
Vehicle:
2016 WRX LTD
CWP

Default

Quote:
Originally Posted by whiplash willy View Post
I ran across an Ebay Post for the FF667UM unit from a 2016 Forester. There were some decent pics of the units label and rear that might help some of you that want to swap.

I am curious if the backup camera feed will be choppy on this unit as it is on the 6.2. I would love to know once you figure out how to get it working!





This is the exact unit I purchased.
Brown1428 is offline   Reply With Quote
Old 05-28-2016, 12:13 AM   #53
Brown1428
Scooby Newbie
 
Member#: 436456
Join Date: Dec 2015
Chapter/Region: South East
Vehicle:
2016 WRX LTD
CWP

Default

Quote:
Originally Posted by intence01 View Post
+1 on the 5 pin harness, is it easily available?

How's the sound quality compared to the Clarion unit?
I never could find it, so I had to improvise. A couple folks had harnesses made, which is definitely the way to go as long as that 5 pin housing remains elusive.
Brown1428 is offline   Reply With Quote
Old 06-01-2016, 09:21 PM   #54
intence01
Scooby Specialist
 
Member#: 389409
Join Date: Apr 2014
Chapter/Region: TXIC
Location: DFW
Vehicle:
2017 STI
WRB, '15 DGM WRX RIP.

Default

Who made the harness, auto harness house or svxdc?
intence01 is offline   Reply With Quote
Old 06-01-2016, 09:25 PM   #55
rixcross
Scooby Newbie
 
Member#: 424260
Join Date: Jun 2015
Default

Brian at auto harness
rixcross is online now   Reply With Quote
Old 06-01-2016, 09:37 PM   #56
intence01
Scooby Specialist
 
Member#: 389409
Join Date: Apr 2014
Chapter/Region: TXIC
Location: DFW
Vehicle:
2017 STI
WRB, '15 DGM WRX RIP.

Default

Thanks,

Reached out to Brian, he's going to need a lot of those.
intence01 is offline   Reply With Quote
Old 06-06-2016, 03:43 PM   #57
SoSlo2
Scooby Newbie
 
Member#: 440579
Join Date: Feb 2016
Chapter/Region: MWSOC
Location: St. Louis, MO
Vehicle:
'16 WRX Limited
DGM

Default

I just stumbled upon this thread. I've been looking at options to throw in a 4 or 5 channel amp because the 6.2 unit is so stinking underpowered. This, however, might be the answer to my needs. Like others have asked, how does it compare in terms of sound quality to the stock 6.2" non-nav Clarion units in the 16's?
SoSlo2 is offline   Reply With Quote
Old 06-06-2016, 06:45 PM   #58
biserker1
Scooby Newbie
 
Member#: 427273
Join Date: Aug 2015
Location: Philadelphia, PA
Vehicle:
2016 WRX Limited

Default

Just picked this unit up and installed. I am also running the OEM Plus system. Just a few observations

This unit is about 10,000 times faster then the clarion 6.2. There is no delay in switching between stations, tracks etc.

The display is much clearer and more vibrant. The backup camera image is also much clearer.

Bluetooth connects instantaneously, downloads recent calls, contacts etc. On screen text messaging, voice recognition, etc.

iPod connects instantaneously, and begins playing directly where it left off. This works with the double USB port (sourced used).

sound - can't comment, running the OEM Plus system so it sounded awesome before the swap and still does sound great. The EQ on the new unit is set up differently.

Installations - Plug and play. The breakout harness is a must to keep the backup camera (Thanks Brian!) It took me longer to install the double usb hub since the wires were so short. The total install took under 1 hr.

I have to say, this unit is night and day compared to the 6.2. This is the unit the car should have come with. It's unbelievable how different the overall experience is with this unit compared to the original.

The total cost was under $225, far less then going aftermarket. All original controls were retained with the addition of the new options now offered in this unit. Overall, i am very happy with the outcome.
biserker1 is offline   Reply With Quote
Old 06-07-2016, 11:26 AM   #59
Nick_L
Scooby Newbie
 
Member#: 420592
Join Date: May 2015
Chapter/Region: RMIC
Location: CO
Vehicle:
16 WRX Premium CVT
WRB

Default

Where is the best place to source one of these units? You guys just checking eBay etc?
Nick_L is offline   Reply With Quote
Old 06-07-2016, 12:42 PM   #60
bji
Scooby Newbie
 
Member#: 445904
Join Date: Apr 2016
Default

Quote:
Originally Posted by SoSlo2 View Post
I just stumbled upon this thread. I've been looking at options to throw in a 4 or 5 channel amp because the 6.2 unit is so stinking underpowered. This, however, might be the answer to my needs. Like others have asked, how does it compare in terms of sound quality to the stock 6.2" non-nav Clarion units in the 16's?
Can someone tell me if there is more than one model of the 6.2 inch head units? I have a 2016 Impreza and from my reading, I believe that there was an improvement to the head units in either the 2015 or 2016 year, not sure which.

What I don't know is, if all of the complaints about speed and finickiness of bluetooth/usb connections were about the pre-2015/2016 versions of these head units, or the 2015/2016 as well. In my experience, while the 6.2 unit in my 2016 Impreza is annoyingly slow to connect to the usb drive on power-on, and similarly for bluetooth, once connected I have zero problems. The steering wheel controls function very quickly for changing volume, pause/play, and skipping forward and backward songs. I haven't used every feature though, so maybe there are some slow ones I missed.

Given the above, I don't know if the 7 inch unit described here would be a noticeable difference, except possibly in start-up times.

Does the 7 inch unit connect immediately on startup to bluetooth sources? Mine takes about 15 seconds.

Does the 7 inch unit connect immediately on startup to usb sources? Mine also takes about 15 seconds.

Those two things are pretty much the only things I find inadequate about the 2016 stock 6.2 head unit.

Last edited by bji; 06-07-2016 at 02:49 PM.
bji is offline   Reply With Quote
Old 06-07-2016, 01:19 PM   #61
SoSlo2
Scooby Newbie
 
Member#: 440579
Join Date: Feb 2016
Chapter/Region: MWSOC
Location: St. Louis, MO
Vehicle:
'16 WRX Limited
DGM

Default

Can someone please weigh in on sound quality in comparison to the 6.2 unit? Also, I'd like to know if anyone has found another place to source these outside of waiting for them to pop up on eBay. Thanks!!
SoSlo2 is offline   Reply With Quote
Old 06-07-2016, 02:35 PM   #62
intence01
Scooby Specialist
 
Member#: 389409
Join Date: Apr 2014
Chapter/Region: TXIC
Location: DFW
Vehicle:
2017 STI
WRB, '15 DGM WRX RIP.

Default

Sound Quality seems better compared to the Clarion units. I don't have much experience with the 6.2 in the WRX, but did with the Forester, and had the older no-display unit in the '15 WRX.

Sound Quality on these new Fujitsu Ten units seems to be better with stock speakers. I'm sure a speaker upgrade will do wonders, and maybe a powerpak amp as well.
intence01 is offline   Reply With Quote
Old 06-07-2016, 04:10 PM   #63
SoSlo2
Scooby Newbie
 
Member#: 440579
Join Date: Feb 2016
Chapter/Region: MWSOC
Location: St. Louis, MO
Vehicle:
'16 WRX Limited
DGM

Default

thanks for the info. I actually ended up stopping by my Subaru dealer today. (perfect weather for a free car wash) I talked with my sales guy and he was able to print off the 2017MY WRX and WRX STI Price Announcement. "The 2017 WRX Limited builds on its already impressive list of standard features with the addition of Subaru STARLINK Connected Services and the 7.0" Multimedia Audio System that incorporates voice activated controls, SiriusXM All Access Radio, SiriusXM Travel Link, Siri Eyes Free and MirrorLink, the leading industry standard for car-smartphone connectivity."

I was also able to sit in a 2016 Forester Premium and confirm that the interface is 100x better than on the 6.2" display. Audio quality also seemed better but we did not go on a test drive so I could not get the full experience there.
SoSlo2 is offline   Reply With Quote
Old 06-07-2016, 08:58 PM   #64
Brown1428
Scooby Newbie
 
Member#: 436456
Join Date: Dec 2015
Chapter/Region: South East
Vehicle:
2016 WRX LTD
CWP

Default

Quote:
Originally Posted by SoSlo2 View Post
Can someone please weigh in on sound quality in comparison to the 6.2 unit? Also, I'd like to know if anyone has found another place to source these outside of waiting for them to pop up on eBay. Thanks!!
I think the sound quality is marginally better, but if you're looking for a significant improvement you'll be better served going with another HU and/or upgraded speakers.
Brown1428 is offline   Reply With Quote
Old 06-07-2016, 09:01 PM   #65
Brown1428
Scooby Newbie
 
Member#: 436456
Join Date: Dec 2015
Chapter/Region: South East
Vehicle:
2016 WRX LTD
CWP

Default

Quote:
Originally Posted by SoSlo2 View Post
thanks for the info. I actually ended up stopping by my Subaru dealer today. (perfect weather for a free car wash) I talked with my sales guy and he was able to print off the 2017MY WRX and WRX STI Price Announcement. "The 2017 WRX Limited builds on its already impressive list of standard features with the addition of Subaru STARLINK Connected Services and the 7.0" Multimedia Audio System that incorporates voice activated controls, SiriusXM All Access Radio, SiriusXM Travel Link, Siri Eyes Free and MirrorLink, the leading industry standard for car-smartphone connectivity."

I was also able to sit in a 2016 Forester Premium and confirm that the interface is 100x better than on the 6.2" display. Audio quality also seemed better but we did not go on a test drive so I could not get the full experience there.
Careful of the dealer car washes...the only swirls in my paint are from them

I'll be keeping an eye on the 2017 Starlink offerings. Was really hoping for CarPlay in the WRX, Crosstrek, or Forester but it looks like that isn't happening.
Brown1428 is offline   Reply With Quote
Old 06-08-2016, 12:05 AM   #66
biserker1
Scooby Newbie
 
Member#: 427273
Join Date: Aug 2015
Location: Philadelphia, PA
Vehicle:
2016 WRX Limited

Default 2016 Forester to WRX HU Transplant...

Looks like mirror link is an option on these units but not supported by the iPhone.

Last edited by biserker1; 06-08-2016 at 11:24 AM.
biserker1 is offline   Reply With Quote
Old 06-21-2016, 04:19 PM   #67
rixcross
Scooby Newbie
 
Member#: 424260
Join Date: Jun 2015
Default

I just plugged mine all together. All functions work except ipod usb. I get power from the splitter cable in the arm rest, but the ipod isn't identified on the radio. Did I not push a connector in fully on the back of the radio, or do I only get bluetooth from now on?
rixcross is online now   Reply With Quote
Old 06-22-2016, 12:23 PM   #68
biserker1
Scooby Newbie
 
Member#: 427273
Join Date: Aug 2015
Location: Philadelphia, PA
Vehicle:
2016 WRX Limited

Default

Quote:
Originally Posted by rixcross View Post
I just plugged mine all together. All functions work except ipod usb. I get power from the splitter cable in the arm rest, but the ipod isn't identified on the radio. Did I not push a connector in fully on the back of the radio, or do I only get bluetooth from now on?


You either need to purchase a splitter (read a few posts back) or the dual USB port that comes standards on the forester.
biserker1 is offline   Reply With Quote
Old 06-22-2016, 12:41 PM   #69
rixcross
Scooby Newbie
 
Member#: 424260
Join Date: Jun 2015
Default

Thx, I do have the splitter. Last night, I pulled the radio out and I did, in fact, forget to plug in the black square connector on the back of the radio. The radio was already powered thru the other connections so I just pushed it in. Unfortunately, it still doesn't recognize the USB in the armrest wtih the splitter plugged in with an iphone connected. I'm wondering if I have to power cycle the radio (pull the battery) to force the radio to reset and re-identify the connector. Thoughts?
rixcross is online now   Reply With Quote
Old 06-22-2016, 01:13 PM   #70
SoSlo2
Scooby Newbie
 
Member#: 440579
Join Date: Feb 2016
Chapter/Region: MWSOC
Location: St. Louis, MO
Vehicle:
'16 WRX Limited
DGM

Default

Where are you guys finding these HU's? I've searched ebay over the past few weeks without much luck other than one out of a 2015 Impreza with a BIN of $750! No thanks..
SoSlo2 is offline   Reply With Quote
Old 06-22-2016, 01:15 PM   #71
bjcolli1
Scooby Newbie
 
Member#: 432828
Join Date: Oct 2015
Chapter/Region: E. Canada
Default

Quote:
Originally Posted by biserker1 View Post
I have a unit on the way. I am also running the OEM plus system which should just be a direct replacement. I reached out to them and have not heard back yet.
Did you hear back from OEM plus?

Just picked up the OEM plus system, but it would still be nice to have the faster working head unit.

Anyone know when I can source one of these for a reasonable price?
bjcolli1 is offline   Reply With Quote
Old 06-22-2016, 01:44 PM   #72
rixcross
Scooby Newbie
 
Member#: 424260
Join Date: Jun 2015
Default

SoSlo2 - I checked fleabay for "subaru starlink" and "2016 forester radio". 2015 and 2016 years were intemixed with new vs old style radios on the Forester, Crosstrek, and WRX. As far as I know, WRX and Crosstrek didn't come with a 7" non-nav radio or at least it wasn't very popular in those years. Mine came out of a wrecked Forester.

Last edited by rixcross; 06-22-2016 at 04:30 PM.
rixcross is online now   Reply With Quote
Old 06-22-2016, 02:06 PM   #73
biserker1
Scooby Newbie
 
Member#: 427273
Join Date: Aug 2015
Location: Philadelphia, PA
Vehicle:
2016 WRX Limited

Default

Quote:
Originally Posted by bjcolli1 View Post
Did you hear back from OEM plus?



Just picked up the OEM plus system, but it would still be nice to have the faster working head unit.



Anyone know when I can source one of these for a reasonable price?


I didn't hear back from OEM. I plugged everything in and it works great. I imagine everything is the same as Subaru wouldn't run different harnesses between their vehicles, other then the HK systems.

Sounds the same.
biserker1 is offline   Reply With Quote
Old 06-22-2016, 02:07 PM   #74
biserker1
Scooby Newbie
 
Member#: 427273
Join Date: Aug 2015
Location: Philadelphia, PA
Vehicle:
2016 WRX Limited

Default

Quote:
Originally Posted by rixcross View Post
Thx, I do have the splitter. Last night, I pulled the radio out and I did, in fact, forget to plug in the black square connector on the back of the radio. The radio was already powered thru the other connections so I just pushed it in. Unfortunately, it still doesn't recognize the USB in the armrest wtih the splitter plugged in with an iphone connected. I'm wondering if I have to power cycle the radio (pull the battery) to force the radio to reset and re-identify the connector. Thoughts?


It's worth a shot. That connector for the USB is really cheap. I know some people on the forum had issues with bent pins after pulling and reinserting the plug.
biserker1 is offline   Reply With Quote
Old 06-23-2016, 09:11 AM   #75
rixcross
Scooby Newbie
 
Member#: 424260
Join Date: Jun 2015
Default

Pulled the whole radio out and checked the USB pins. Nothing bent and the connector locks in when re-inserted. I pulled the battery terminal to force a reboot of the system and that didn't work. The radio must have some internal battery or it stores settings as it remembered my phone connections and radio stations still. Couldn't find anywhere to reset to factory settings, only the default button which only resets check boxes under system settings. Anyone have any other ideas?
rixcross is online now   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

All times are GMT -4. The time now is 11:15 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2017 Axivo Inc.
Copyright ©1999 - 2017, North American Subaru Impreza Owners Club, Inc.