Welcome to the North American Subaru Impreza Owners Club Sunday June 4, 2023
Home Forums Images WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Go Back   NASIOC > NASIOC Technical > FA Series Factory 2.0L Turbo Powertrain

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.







* As an Amazon Associate I earn from qualifying purchases. 
* Registered users of the site do not see these ads. 
Reply
 
Thread Tools Display Modes
Old 03-25-2023, 04:41 PM   #1
Skoobie0000
Scooby Newbie
 
Member#: 533682
Join Date: Mar 2023
Location: PNW
Vehicle:
2017 WRX Base
Pearl White

Default 2017 Base WRX P2006 code

Did a bit of searching but I was surprised to not find much info on P2006 other than generic, none manufacturer specific stuff. Honestly I thought for sure I'd find a 2015-2023 video on YouTube on how to deal with with code but no. So I apologize if this has been addressed and I missed it.

I do basic maintenance but this is the first real issue I've run into with the car so I don't have much experience working on it. That said, I'm not afraid to wrench on a car and I have the tools to do so including a newer Launch Tablet to scan codes and read ECU IO. Now to the details.

Code popped when my wife was on her commute. She didn't notice any change in the car as far as how well it ran. Idle was stable, didn't hesitate, nothing like that. After she got home I cleared the code and drove the car to get some gas. I was scanning the EGR vac while driving and it was red (reading out of spec). Code popped again. Car was running fine and I didn't notice any drop in performance or idle. Cleared the code once more at the gas station and it popped again on the way home. So SOMETHING is wacky.

So where do I start? From what I read on the generic info site it's either Electrical (wiring harness), physical (IMRC Valve) or a vacuum issue. Not sure if the system is vacuum controlled or electronic? Both maybe? Anyway a detailed how-to would be appreciated if someone has the time. This SEEMS like something I should be able to deal with without spending a ton at a shop. Thanks for the help. If you need more info please let me know and I'll do my best to get it to you. ***128077;
* Registered users of the site do not see these ads.
Skoobie0000 is offline   Reply With Quote
Sponsored Links
* Registered users of the site do not see these ads.
Old 03-25-2023, 06:08 PM   #2
Skoobie0000
Scooby Newbie
 
Member#: 533682
Join Date: Mar 2023
Location: PNW
Vehicle:
2017 WRX Base
Pearl White

Default

Skoobie0000 is offline   Reply With Quote
Old 03-25-2023, 06:16 PM   #3
IsActuallyFoxBodyGuy
Scooby Newbie
 
Member#: 402863
Join Date: Sep 2014
Default 2017 Base WRX P2006 code

Image appears broken to me. Iíve never seen this code, whatís the DTC definition?

Ahh I looked it up, Intake Runner stuck closed B1. I would start by verifying how the runner operated, probably a servo, and then manually operate it to see if the runner baffles move

Sent from my iPhone using NASIOC
IsActuallyFoxBodyGuy is offline   Reply With Quote
Old 03-25-2023, 06:47 PM   #4
Skoobie0000
Scooby Newbie
 
Member#: 533682
Join Date: Mar 2023
Location: PNW
Vehicle:
2017 WRX Base
Pearl White

Default

Quote:
Originally Posted by IsActuallyFoxBodyGuy View Post
Image appears broken to me. Iíve never seen this code, whatís the DTC definition?

Ahh I looked it up, Intake Runner stuck closed B1. I would start by verifying how the runner operated, probably a servo, and then manually operate it to see if the runner baffles move

Sent from my iPhone using NASIOC
Yea, DTC as follows
Tumble Generated Valve System 1(Valve Closed)

Intake Manifold Runner Control Stuck Closed Bank 1A

Problem is I haven't been able to find any schematics or photos of what I'm supposed to be looking for or how to pull it apart. ***128556;
Skoobie0000 is offline   Reply With Quote
Old 03-26-2023, 03:42 AM   #5
19std
Scooby Newbie
 
Member#: 510366
Join Date: Jan 2020
Default

How many miles? Ever cleaned the throttle body?

If not start there.
19std is offline   Reply With Quote
Old 03-29-2023, 04:31 PM   #6
Skoobie0000
Scooby Newbie
 
Member#: 533682
Join Date: Mar 2023
Location: PNW
Vehicle:
2017 WRX Base
Pearl White

Default

Quote:
Originally Posted by 19std View Post
How many miles? Ever cleaned the throttle body?

If not start there.
It's got 73k on it and no, I haven't torn it down before. That's the plan right now. Tear it down and start cleaning everything. I looked into doing a TGV delete but as of right now the CEL can't be programmed out. Called a few shops and they said that the EPA cracked down on Cobb and forced them to remove the function from the tool as of April of last year. And I don't want to drive around with a CEL on all the time.
Skoobie0000 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

All times are GMT -4. The time now is 04:35 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2023, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2023 Axivo Inc.
Copyright ©1999 - 2019, North American Subaru Impreza Owners Club, Inc.

As an Amazon Associate I earn from qualifying purchases.