Welcome to the North American Subaru Impreza Owners Club Monday March 8, 2021
Home Forums Images WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Go Back   NASIOC > NASIOC Technical > Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo)

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.







* As an Amazon Associate I earn from qualifying purchases. 
* Registered users of the site do not see these ads. 
Reply
 
Thread Tools Display Modes
Old 05-14-2020, 07:19 AM   #126
cloudhalo
Scooby Newbie
 
Member#: 501406
Join Date: May 2019
Default

Quote:
Originally Posted by subaru_gc8 View Post
should be fine, but you might have probelms filling up as if you fill up too much it might come out of the cansiter
I don't understand why people use a breather hose? Just plug the vent line for the tank and get a vented filler cap, that relives pressure automatically an allows air into the tank, i'd check motorad.com
* Registered users of the site do not see these ads.
cloudhalo is offline   Reply With Quote
Sponsored Links
* Registered users of the site do not see these ads.
Old 05-14-2020, 12:35 PM   #127
ScoobyJD
Scooby Specialist
 
Member#: 185910
Join Date: Aug 2008
Chapter/Region: MAIC
Location: Hanover, PA (17331)
Vehicle:
2007 FSXT

Default

Quote:
Originally Posted by cloudhalo View Post
I don't understand why people use a breather hose? Just plug the vent line for the tank and get a vented filler cap, that relives pressure automatically an allows air into the tank, i'd check motorad.com
This was thought exactly. I do this as well on my 94 k1500 after removing the charcoal tank. I do believe that rerouting the overfill back into the tank is a smarter idea as well.
ScoobyJD is offline   Reply With Quote
Old 05-19-2020, 07:07 PM   #128
TRebelo
Scooby Newbie
 
Member#: 328968
Join Date: Aug 2012
Chapter/Region: NESIC
Location: Rhode Island
Vehicle:
2004 WRX
San Remo Red

Default

Awesome thanks for this I got the engine bay stuff all pulled off and cleaned up during the fuel setup upgrade but wasn’t sure about the rear canister this cleared it up!
TRebelo is offline   Reply With Quote
Old 05-20-2020, 02:29 PM   #129
Joey_C
Scooby Newbie
 
Member#: 514929
Join Date: May 2020
Default

Thank you! Delete went smoothly, I can finally fill my tank in a reasonable amount of time. Good thing there’s no inspection needed for BC
Joey_C is offline   Reply With Quote
Old 11-04-2020, 08:54 PM   #130
rmarli17
Scooby Newbie
 
Member#: 519776
Join Date: Oct 2020
Default

Quote:
Originally Posted by StuartR View Post
pulled mine out today, went really smoothly.

I was having an issue with fuel ups, the system would pressurize and keep tripping the pump nozzle, would take 15 minutes to get a full tank. After this that problem has gone away. Now all I need to do if find a way to permanently clear the code...
I know it's an old thread, new to the site, I'm planning on doing this also as I keep getting P1443 codes and pumping gas is a pain. I found a video on youtube that if you just put in 50ohm resisters into the connections it'll trick the system and the codes wont pop up.
rmarli17 is offline   Reply With Quote
Old 01-19-2021, 06:50 AM   #131
AdventureboyJJ
Scooby Newbie
 
Member#: 510896
Join Date: Jan 2020
Default

Quote:
Originally Posted by rmarli17 View Post
I know it's an old thread, new to the site, I'm planning on doing this also as I keep getting P1443 codes and pumping gas is a pain. I found a video on youtube that if you just put in 50ohm resisters into the connections it'll trick the system and the codes wont pop up.
Were you able to find the resistor? I dont know or where to buy one.
AdventureboyJJ is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

All times are GMT -4. The time now is 06:00 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2021, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2021 Axivo Inc.
Copyright ©1999 - 2019, North American Subaru Impreza Owners Club, Inc.

As an Amazon Associate I earn from qualifying purchases.