Welcome to the North American Subaru Impreza Owners Club Wednesday November 20, 2019
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Go Back   NASIOC > NASIOC General > Newbies & FAQs

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.







* As an Amazon Associate I earn from qualifying purchases. 
* Registered users of the site do not see these ads. 
Reply
 
Thread Tools Display Modes
Old 10-31-2019, 09:21 AM   #1
Bad Noodle
Scooby Specialist
 
Member#: 174442
Join Date: Mar 2008
Chapter/Region: Tri-State
Location: NNJ
Vehicle:
2007 SuperWagon
I don't spell well

Default 2018 Forester XT feels like it's running rough

Just curious if anyone else with a late model forester XT feels like the stock engine calibration (tune) is off or not quite right.

- On startup, it feels like it's misfiring randomly for the first 30 sec.
- Driving it feels like it randomly loses / gains power.

I've heard that's just the way these cars are, but it seems pretty rough, even for Subaru.

oh - no mods, everything stock. 10k on the odo
* Registered users of the site do not see these ads.

Last edited by Bad Noodle; 11-01-2019 at 07:48 AM.
Bad Noodle is offline   Reply With Quote
Sponsored Links
* Registered users of the site do not see these ads.
Old 10-31-2019, 03:20 PM   #2
deep1ca
Scooby Newbie
 
Member#: 507922
Join Date: Oct 2019
Default

Try cleaning the MAF maybe
deep1ca is offline   Reply With Quote
Old 10-31-2019, 04:54 PM   #3
Opie
Floresbian
Moderator
 
Member#: 470
Join Date: Oct 1999
Chapter/Region: South East
Location: Riverview, Florida - U.S.A.
Vehicle:
2020 Canyon Denali
'18 FXT, '16 XV, '13 BRZ

Default

Does it have the latest ECM update installed?
Opie is offline   Reply With Quote
Old 11-01-2019, 07:47 AM   #4
Bad Noodle
Scooby Specialist
 
Member#: 174442
Join Date: Mar 2008
Chapter/Region: Tri-State
Location: NNJ
Vehicle:
2007 SuperWagon
I don't spell well

Default

are there ECM updates? If so, how can I find if I have the latest tune?
Bad Noodle is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

All times are GMT -4. The time now is 08:58 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2019 Axivo Inc.
Copyright ©1999 - 2019, North American Subaru Impreza Owners Club, Inc.

As an Amazon Associate I earn from qualifying purchases.