Welcome to the North American Subaru Impreza Owners Club Monday April 19, 2021
Home Forums Images WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Go Back   NASIOC > NASIOC General > General Community

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.







* As an Amazon Associate I earn from qualifying purchases. 
* Registered users of the site do not see these ads. 
Reply
 
Thread Tools Display Modes
Old 01-28-2021, 10:33 AM   #1
aiden05sti
Scooby Newbie
 
Member#: 520803
Join Date: Dec 2020
OMGHi2U 2005 Subaru STI P2109 PROBLEM!!

Hi I own a 2005 Subaru sti with the codes P2109 and I've tried everything to fix it and just can't find it any help would be appreciated. I had this problem every couple days a week then it went away for a week. I took it to a shop in the first place got some wires rewired took them forever to find it and I don't think they really did. Work fine for a month then it started happening again, going into limp mode and not being able to rev over 2500-3000 RPMS. Then took it too another shop and they replaced the throttle body and that work for a week or two then it started happening AGAIN! I've gone to through the wire, tried doing the diagnostics the best I could to my knowledge, I put in a Iwire grounding kit, replaced the throttle body for the third time, and just know replaced the ECU and was very disappointed to find out the code was still there after wasting all that money on trying to fix this long going problem. I have look at so many threads and post about the P2109, P0638 codes and can't find solutions anywhere that fixes my problems, please help
[IMG]file:///Users/aidenkimball/Desktop/OIP.bY0Vp1ydu49dpSRFxYurYQHaFM.jpeg[/IMG]
* Registered users of the site do not see these ads.
aiden05sti is offline   Reply With Quote
Sponsored Links
* Registered users of the site do not see these ads.
Old 01-28-2021, 11:01 AM   #2
Foo_Blyat
Scooby Guru
 
Member#: 93750
Join Date: Aug 2005
Chapter/Region: MWSOC
Default

If your car is WRB and low miles, I'll buy it off you and then you're problem will be solved
Foo_Blyat is offline   Reply With Quote
Old 01-28-2021, 01:02 PM   #3
aiden05sti
Scooby Newbie
 
Member#: 520803
Join Date: Dec 2020
Default haha can you fix the problem? do you know how

Quote:
Originally Posted by Foo_Blyat View Post
If your car is WRB and low miles, I'll buy it off you and then you're problem will be solved
Anyways its a 2003 bugeye with 200,000 miles on it(It's only 2003 chassis everything else is a 2005 Subaru wrx sti) and the 2005 sti engine is rebuilt with like 45,000 miles on it, aftermarket pistols rods everything, front mount, FP black turbo pushing like 450 horsepower. How much you offering? Probably won't sell but just wondering. If you have any knowledge on how to fix the problem I have please, please share any advice, thanks!
aiden05sti is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

All times are GMT -4. The time now is 07:08 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2021, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2021 Axivo Inc.
Copyright ©1999 - 2019, North American Subaru Impreza Owners Club, Inc.

As an Amazon Associate I earn from qualifying purchases.