Welcome to the North American Subaru Impreza Owners Club Friday December 4, 2020
Home Forums Images WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Go Back   NASIOC > NASIOC General > Warranty Issues & SOA Problems

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.







* As an Amazon Associate I earn from qualifying purchases. 
* Registered users of the site do not see these ads. 
Reply
 
Thread Tools Display Modes
Old 11-16-2020, 12:44 AM   #1
garjones
Scooby Newbie
 
Member#: 520312
Join Date: Nov 2020
Default 15 wrx 70k miles. Dealer lied to us about warranty while car was still stock

So We acquired my 15 wrx about 3 years ago with 30k miles on it, at around 50k miles on it we got a p0018 which is intake cam 2 out of timing. So we took it in to get it checked out, and the tech told us there was some oil in the wire, and that it just needed to be cleaned out. So he "Cleaned it out" and the code came back on the next morning. We were told that because it was wiring it wouldn't be covered under warranty, and it wasn't a big deal, it would just have to be cleared every so often (every other time i start the car, so i just reset the ECU before i turn it off). I bought the car from my father about 6 months ago with 62000 miles, and im currently at just over 70, and i decided to try and fix this because as a daily driver it is very annoying. I didn't think it was the wiring, so i switched around the intake cam sensors to see if the code followed, it didn't. SO i switched around the ocvs to see if it followed, it didn't. So i asked online and everyone was telling me it was the cam sprocket, and that it was a common issue in the first year. I took it to a shop near my house (not a Subaru specialty shop) and after telling them the code, they said the same thing ( they did not look at the car, just went off the code), and quoted about 1500$. Since I've owned the car, I've put a catback on it, intake, and a ron Watson e tune. Do you guys think it could actually just be a wiring issue? and shouldn't that have been fixed under the warranty (while it was 100% stock)? if it is actually the cam sprocket would i have a case against the dealer because it should have been under warranty? or am I SOA because its no longer stock? I've been stressing about this for a long time, Ive wanted a wrx since i was young, and finally turning 20 i can afford one just to have a dealer screw me over. I love the car, hate the dealer.
* Registered users of the site do not see these ads.
garjones is offline   Reply With Quote
Sponsored Links
* Registered users of the site do not see these ads.
Old 11-16-2020, 01:50 PM   #2
DrD
Scooby Guru
 
Member#: 22412
Join Date: Aug 2002
Chapter/Region: SWIC
Location: Albuquerque, NM
Vehicle:
2012 Legacy 2.5GT
Ice Silver Metallic

Default

Have you called SoA to see what they say? I would call them and see what they say - technically, no one has confirmed it's the sprocket on your car yet, correct? They will probably want you to bring it in to a dealership for diagnosis, though. The exhaust isn't a concern - not sure what they would say about the intake, but the tune is going to be a red flag for them.

You are out of warranty, but if the problem manifested itself while you were in warranty for the powertrain, and was definitely a hardware issue, I would think SoA would help you out. You need to call them, though.
DrD is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

All times are GMT -4. The time now is 12:48 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2020 Axivo Inc.
Copyright ©1999 - 2019, North American Subaru Impreza Owners Club, Inc.

As an Amazon Associate I earn from qualifying purchases.