Welcome to the North American Subaru Impreza Owners Club Thursday August 18, 2022
Home Forums Images WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Go Back   NASIOC > NASIOC Technical > Transmission (AT/MT) & Driveline

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.







* As an Amazon Associate I earn from qualifying purchases. 
* Registered users of the site do not see these ads. 
 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
Old 01-04-2022, 02:59 PM   #1
cguajardo
Scooby Newbie
 
Member#: 448488
Join Date: Jun 2016
Location: Texas
Vehicle:
2017 WRX Base
DGM

Question Clutch question - 2017 WRX

Hey fellow subie-friends, got a question I didn't see particular answers to via searching so I thought I'd post.

Basically, I'm trying to figure out if I need to have the clutch replaced in my 2017 WRX (58k miles).

Background - I took a trip out to the mountains here in CO and on the way back got stuck in some horrible stop and go traffic (2+ hours of 2mph - 5mph movement). In this constant accordion like traffic where we wouldn't actually stop, I found myself constantly feathering the clutch into/out of 1st gear. I'd try to coast in neutral as much as possible but with the constant braking and accelerating between that horrible 2-10mph zone, I found that I couldn't manage creeping slowly without constantly going in and out of 1st. Anyways, eventually I started to smell a rubbery-like burning smell and figured it was my clutch plate. I also started experiencing massive chatter/shaking when letting go of the clutch pedal in 1st. I pulled over as quickly as I could find a safe pull-off and waited for about 25 minutes before continuing home (once the traffic was finally flowing again).

I suppose my question is -- does this abuse and reaching the point of that violent chatter indicate that I should now be expecting to replace the clutch, or can those components overheat like that and then continue to be used once they cool down? (i.e. did I kill my clutch completely or only reduce its lifespan by a bit?)

Apologies for the newbie question, but this is just a situation I've not dealt with before so I'm trying to learn.
cguajardo is offline   Reply With Quote
 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

All times are GMT -4. The time now is 03:48 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2022, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2022 Axivo Inc.
Copyright ©1999 - 2019, North American Subaru Impreza Owners Club, Inc.

As an Amazon Associate I earn from qualifying purchases.