Welcome to the North American Subaru Impreza Owners Club Sunday August 19, 2018
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
North West Impreza Club
Go Back   NASIOC > NASIOC Chapters > North West Impreza Club Forum -- NWIC

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads. 
Reply
 
Thread Tools Display Modes
Old 12-02-2013, 12:52 PM   #5726
jdreisinger
Scooby Specialist
 
Member#: 127138
Join Date: Sep 2006
Chapter/Region: NWIC
Location: Seattle
Vehicle:
2015 Nissan GT-R
2000 2.5RS Sedan

Default

Threw a CEL . 2nd time since I've had the car and it doesn't even have 15k miles. Not really sure what it could be since the only 'performance' mod is a Perrin catback and it's been on since last December...
* Registered users of the site do not see these ads.
jdreisinger is offline   Reply With Quote
Sponsored Links
* Registered users of the site do not see these ads.
Old 12-02-2013, 01:08 PM   #5727
silverton
Scooby Newbie
 
Member#: 331131
Join Date: Sep 2012
Chapter/Region: NWIC
Location: Burien, WA
Vehicle:
2001 2.5RS-T
Silver..thorn Metallic

Default

Quote:
Originally Posted by jdreisinger View Post
Threw a CEL . 2nd time since I've had the car and it doesn't even have 15k miles. Not really sure what it could be since the only 'performance' mod is a Perrin catback and it's been on since last December...
Welcome to subaru life! You eventually get used to it.
silverton is offline   Reply With Quote
Old 12-02-2013, 01:18 PM   #5728
AK33
Scooby Newbie
 
Member#: 374777
Join Date: Nov 2013
Chapter/Region: NWIC
Location: Enumclaw, WA
Vehicle:
2014 Impreza Sport
White

Default

Just ordered my new wheels and tires. I went with Motegi Racing MR122 18x8 +45mm offset Satin Black wheels and Toyo Proxes 4 Plus 225/40R18 tires. I am also going to use red aluminum lug nuts to add a little more to the look since almost everything else on my car is white/black. I almost forgot I ordered white/black badge covers for front, back, and steering wheel last night as well.





Waiting for the next 2 weeks for them to get here is going to feel like forever.
AK33 is offline   Reply With Quote
Old 12-02-2013, 01:59 PM   #5729
eugeneutopia
Scooby Specialist
 
Member#: 322957
Join Date: Jun 2012
Chapter/Region: NWIC
Location: West Seattle
Vehicle:
2010 FXT
OBP - Black

Default

Quote:
Originally Posted by jdreisinger View Post
Threw a CEL . 2nd time since I've had the car and it doesn't even have 15k miles. Not really sure what it could be since the only 'performance' mod is a Perrin catback and it's been on since last December...
Gas cap screwed on tight? That'll do it....
eugeneutopia is offline   Reply With Quote
Old 12-02-2013, 02:37 PM   #5730
jdreisinger
Scooby Specialist
 
Member#: 127138
Join Date: Sep 2006
Chapter/Region: NWIC
Location: Seattle
Vehicle:
2015 Nissan GT-R
2000 2.5RS Sedan

Default

Quote:
Originally Posted by silverton View Post
Welcome to subaru life! You eventually get used to it.
My '06 2.5i that I had from brand new to 60k never had anything go wrong at all. I thought I left my VW to get away from CEL issues
Quote:
Originally Posted by eugeneutopia View Post
Gas cap screwed on tight? That'll do it....
Yeah, My gas light just came on this morning actually, so it's been on for almost 3 weeks (was out of town last week) . Where the hell is the OBD2 port on these cars anyways? I looked under the wheel really quick this morning and didn't see it.
jdreisinger is offline   Reply With Quote
Old 12-02-2013, 03:02 PM   #5731
eugeneutopia
Scooby Specialist
 
Member#: 322957
Join Date: Jun 2012
Chapter/Region: NWIC
Location: West Seattle
Vehicle:
2010 FXT
OBP - Black

Default

If it's in the same place as mine (Forester), it's there... mine is semi-flush, so a quick blind scan with my hand may be hit or miss.

It's right about here:

eugeneutopia is offline   Reply With Quote
Old 12-02-2013, 03:04 PM   #5732
jdreisinger
Scooby Specialist
 
Member#: 127138
Join Date: Sep 2006
Chapter/Region: NWIC
Location: Seattle
Vehicle:
2015 Nissan GT-R
2000 2.5RS Sedan

Default

Ah, a little further down than my blind hand was this morning haha. Thanks, will try to go get it checked out on lunch
jdreisinger is offline   Reply With Quote
Old 12-02-2013, 05:34 PM   #5733
Konathebarbarian
Scooby Newbie
 
Member#: 370557
Join Date: Oct 2013
Chapter/Region: NWIC
Location: Seattle
Vehicle:
'94 Legacy Touring
'98 M3/4/5

Default

Took advantage of the weekend sales Discount Tire is having and got some Nitto Motivo all seasons mounted up this morning. 225/25/17 on stock 06 WRX rims. So far so good! They look meaty compared to a 215 and fill up my wheel wells nicely
Konathebarbarian is offline   Reply With Quote
Old 12-02-2013, 05:38 PM   #5734
md2regul8
Scooby Newbie
 
Member#: 371029
Join Date: Oct 2013
Chapter/Region: NWIC
Location: Lake Stevens Washington
Vehicle:
2011 STI Hatch Black
Rotated GTX3076

Default

Well did an ETS topmount , Hawk HPS pads over the weekend,

http://sdrv.ms/186Hjlw
md2regul8 is offline   Reply With Quote
Old 12-02-2013, 06:37 PM   #5735
wraven
Scooby Newbie
 
Member#: 17757
Join Date: Apr 2002
Chapter/Region: NWIC
Location: Grand Coulee Dam area, WA, the
Vehicle:
2011 STI Sedan stg 2
WR Blue Mica

Default

Quote:
Originally Posted by Wrxguy11 View Post
I just did the fogs. I love the look.
Good job, Wrxguy11! I love the look too. I'd already tried the OEM fog lights on my '08 STI hatch. They were so weak, I couldn't tell they were on. I think this is a much better alternative.

And the price is almost the same for the light bar and PIAA's as it is for the OEM fog lamp kit.

Last edited by wraven; 12-02-2013 at 06:38 PM. Reason: one last thought
wraven is offline   Reply With Quote
Old 12-02-2013, 10:40 PM   #5736
Qdotsoo
Scooby Newbie
 
Member#: 334646
Join Date: Oct 2012
Chapter/Region: NWIC
Location: Olympia , Wa
Vehicle:
2008 IMPREZA WRX
DGM

Default

Replaced oem clutch and got a new short shifter. Work done by outback auto. Thanks guys!
Qdotsoo is offline   Reply With Quote
Old 12-03-2013, 03:09 PM   #5737
Wesley1184
Scooby Newbie
 
Member#: 301484
Join Date: Nov 2011
Chapter/Region: NWIC
Location: eugene oregon
Vehicle:
2002 wrx
red

Default

Well last night I replaced the driver front spindle on our forester along with tie rods and ball joints and if anyone is looking for a brat found a good deal

http://eugene.craigslist.org/cto/4226688140.html
Wesley1184 is offline   Reply With Quote
Old 12-03-2013, 03:43 PM   #5738
Wrxguy11
Scooby Newbie
 
Member#: 274881
Join Date: Feb 2011
Chapter/Region: NWIC
Location: Puyallup
Vehicle:
2011 Wrx
Black

Default

Quote:
Originally Posted by wraven View Post
Good job, Wrxguy11! I love the look too. I'd already tried the OEM fog lights on my '08 STI hatch. They were so weak, I couldn't tell they were on. I think this is a much better alternative. And the price is almost the same for the light bar and PIAA's as it is for the OEM fog lamp kit.
It is cheap. I used google and got my PIAA lights brand new for $97!!

Last edited by Wrxguy11; 12-03-2013 at 04:00 PM.
Wrxguy11 is offline   Reply With Quote
Old 12-04-2013, 03:47 AM   #5739
redwings1
Scooby Newbie
 
Member#: 256113
Join Date: Aug 2010
Chapter/Region: NWIC
Location: Spokane, Wa.
Vehicle:
2004 impreza sti
WRB

Default O2 sensor.

Quote:
Originally Posted by jdreisinger View Post
Threw a CEL . 2nd time since I've had the car and it doesn't even have 15k miles. Not really sure what it could be since the only 'performance' mod is a Perrin catback and it's been on since last December...
Same thing with me. Same exhaust too. Nothing wrong with the car. I bought a $6 O2 extender off ebay, five minutes under the car and nothing since.
redwings1 is offline   Reply With Quote
Old 12-04-2013, 02:50 PM   #5740
soul555top
Scooby Newbie
 
Member#: 371821
Join Date: Oct 2013
Chapter/Region: NWIC
Location: Bellevue, WA
Vehicle:
2012 WRX
Ice Silver Metallic

Default

Meant to post here yesterday, but I have now had my 12 WRX for a bit over a month. Have been researching and doing some mods as time permits with a busy work schedule, but here is what I have done so far: (was already lowered on Cobb springs and has low end sound system/alarm...)

Cobb AP V2
Cobb SF Intake with Box
Cobb Shift Knob
Kartboy Short Shifter + Front/Rear Kartboy Bushings
Full 30K Service @ Outback Auto
H9 Headlight Bulb Mod via DanielSternLighting

So far everything I have done has been pretty awesome. The SS is obviously kickass, although the initial NVH was startling, it has since gotten quieter to the point I like the noise. The OTS Stage 1 maps have been great and the increase in smoothness is pretty much amazing. The sounds coming from the tune (I assume) and the intake (at wot and also the whooshing noise) are awesome, yet quiet, just how I want it. The H9 mod is also pretty awesome. My headlights went from being dull and yellowish (you couldnt even tell they were on...) to clear and bright. Its nice to know also that I am not blinding people at the expense of my better vision as well.

Future mods: Cobb Downpipe + Heatshield, Subtle Radiator/Alternator Covers, Winter Wheel Setup, Clear Headlights via baking. Few chips that I may get fixed by a body shop as well (nothing major, just wouldnt mind getting the car back to perfect condition as I inherited those chips.)

Thanks to EnviedSVT for selling me the AP and Intake at a good price, and also helping me get them both setup. Also thanks to Outback Auto for doing good work at a good price.

Loving the car so far!
soul555top is offline   Reply With Quote
Old 12-04-2013, 06:33 PM   #5741
guilty_619
Scooby Newbie
 
Member#: 244075
Join Date: Apr 2010
Chapter/Region: NWIC
Location: WA
Default

Changed oil - Rotella T6 & Filter - Purolator PureONE

Cleaned MAF sensor & checked tire pressure; was down to 29.5 psi
I normally run 37-38 front, 33-34 rear. Check your winter tire pressure kids!
guilty_619 is offline   Reply With Quote
Old 12-04-2013, 06:47 PM   #5742
buzznickle45
Scooby Newbie
 
Member#: 331206
Join Date: Sep 2012
Chapter/Region: SCIC
Location: sunny san diego
Vehicle:
12 Impreza WRX
WRB

Default

dont know how it happened but i tore my rear drivers side mud flap off so i just took of the other 3 cuz it looked weird, well time to by some more
buzznickle45 is offline   Reply With Quote
Old 12-04-2013, 07:48 PM   #5743
Bast
Scooby Specialist
 
Member#: 329493
Join Date: Aug 2012
Chapter/Region: NWIC
Location: PDX
Vehicle:
1999 Impreza 2.5RS
Black Diamond Pearl

Default

Cruised out to Sauvie Island; not a bad day for it!
Bast is offline   Reply With Quote
Old 12-04-2013, 08:07 PM   #5744
Fade2black02
Scooby Newbie
 
Member#: 309997
Join Date: Feb 2012
Chapter/Region: NWIC
Location: Arlington, WA
Vehicle:
2010 STI
Blick

Default

Got my car back from VTR today. Finished with Cockpit stuff for now. Today it was Laser Jammer and License Plate Cover install.





Fade2black02 is offline   Reply With Quote
Old 12-04-2013, 10:01 PM   #5745
BigTaco425
Scooby Newbie
 
Member#: 347237
Join Date: Feb 2013
Location: Snoqualmie, WA
Vehicle:
2013 WRX Limited E85
Satin Black Vinyl

Default

Quote:
Originally Posted by soul555top View Post
Future mods: Cobb Downpipe + Heatshield, Subtle Radiator/Alternator Covers, Winter Wheel Setup, Clear Headlights via baking. Few chips that I may get fixed by a body shop as well (nothing major, just wouldnt mind getting the car back to perfect condition as I inherited those chips.)
I'd add swaybars to your list. One of the biggest bang for bucks mods IMO.
BigTaco425 is offline   Reply With Quote
Old 12-04-2013, 10:05 PM   #5746
BigTaco425
Scooby Newbie
 
Member#: 347237
Join Date: Feb 2013
Location: Snoqualmie, WA
Vehicle:
2013 WRX Limited E85
Satin Black Vinyl

Default

Quote:
Originally Posted by eugeneutopia View Post
I just got the E85 tune today. I'll let you know if the starting is hard over the next few days. I'm pretty sure it'll be a pain.

Got the injectors taken care of a while ago. DW825 to ID 725 to ID1300. It's been a journey.
Hope it hasn't been too rough the past few days. Maybe you are having a better experience than I did.
BigTaco425 is offline   Reply With Quote
Old 12-04-2013, 11:59 PM   #5747
eugeneutopia
Scooby Specialist
 
Member#: 322957
Join Date: Jun 2012
Chapter/Region: NWIC
Location: West Seattle
Vehicle:
2010 FXT
OBP - Black

Default

Quote:
Originally Posted by BigTaco425 View Post
Hope it hasn't been too rough the past few days. Maybe you are having a better experience than I did.
Starting has been only slightly longer (from one second to 3 maybe), and the power is awesome, but a few days before the tune it started to have a vacuum-leak-like hesitation/surge issue, which it still have. Makes driving it difficult. I'm headed in tomorrow to check it out. Injectors are the only thing that has changed that I think it might be, but we'll see.
eugeneutopia is offline   Reply With Quote
Old 12-05-2013, 02:25 AM   #5748
silverton
Scooby Newbie
 
Member#: 331131
Join Date: Sep 2012
Chapter/Region: NWIC
Location: Burien, WA
Vehicle:
2001 2.5RS-T
Silver..thorn Metallic

Default

Quote:
Originally Posted by buzznickle45 View Post
dont know how it happened but i tore my rear drivers side mud flap off so i just took of the other 3 cuz it looked weird, well time to by some more
I stopped backing into spaces because of this, I'm good about not backing in to the curb but if I usually park with a curb on my side and don't always get it perfectly straight. Luckily the three times I've torn my passenger side off I heard it and got out to retrieve.
silverton is offline   Reply With Quote
Old 12-05-2013, 10:45 AM   #5749
Breezio
Scooby Specialist
 
Member#: 234357
Join Date: Jan 2010
Location: Meridian, ID
Vehicle:
2009 WRX
Sportwagen zum einbauen!

Default

^ I've done that once.. :/

How about, what I received for my Subaru today...





And a KillerB oil pickup.
Breezio is offline   Reply With Quote
Old 12-05-2013, 11:04 AM   #5750
Wrxguy11
Scooby Newbie
 
Member#: 274881
Join Date: Feb 2011
Chapter/Region: NWIC
Location: Puyallup
Vehicle:
2011 Wrx
Black

Default

Quote:
Originally Posted by guilty_619 View Post
Changed oil - Rotella T6 & Filter - Purolator PureONE

Cleaned MAF sensor & checked tire pressure; was down to 29.5 psi
I normally run 37-38 front, 33-34 rear. Check your winter tire pressure kids!
Just wondering why you run such a higher pressure in the front vs rear?
Wrxguy11 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
What did you do to your Subie Today? Version 3 TrickNipple North West Impreza Club Forum -- NWIC 3796 09-07-2011 02:52 AM
What did you do to your Subie Today? Version 2 Smoke North West Impreza Club Forum -- NWIC 1978 05-21-2010 12:43 AM
What did you do to your Suby today? BREWPUBEAVER North West Impreza Club Forum -- NWIC 1197 11-01-2009 12:06 PM
What did you do to your subie today?! 07imprezadrifter General Community 277 06-14-2009 11:42 PM

All times are GMT -4. The time now is 07:37 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2018 Axivo Inc.
Copyright ©1999 - 2017, North American Subaru Impreza Owners Club, Inc.