Welcome to the North American Subaru Impreza Owners Club Friday September 20, 2019
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Go Back   NASIOC > NASIOC Technical > FA Series Factory 2.0L Turbo Powertrain

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.







* As an Amazon Associate I earn from qualifying purchases. 
* Registered users of the site do not see these ads. 
Reply
 
Thread Tools Display Modes
Old 08-24-2019, 05:34 PM   #1
Rumblingtaco
Scooby Newbie
 
Member#: 505342
Join Date: Aug 2019
Default Someone help me please

Changed my exhaust manifold gaskets and hooked every hose back up and now it won’t idle very good and my accessport says system too lean
* Registered users of the site do not see these ads.
Rumblingtaco is offline   Reply With Quote
Sponsored Links
* Registered users of the site do not see these ads.
Old 08-24-2019, 07:39 PM   #2
Rumblingtaco
Scooby Newbie
 
Member#: 505342
Join Date: Aug 2019
Default

Quote:
Originally Posted by Rumblingtaco View Post
Changed my exhaust manifold gaskets and hooked every hose back up and now it won’t idle very good and my accessport says system too lean


I was too excited to turn it back on and forgot to reconnect my bpv
Rumblingtaco is offline   Reply With Quote
Old 08-24-2019, 10:33 PM   #3
Matrex15
Scooby Newbie
 
Member#: 473848
Join Date: Sep 2017
Chapter/Region: W. Canada
Location: Victoria British Columbia Cana
Vehicle:
2015 Wrx
White

Default

Quote:
Originally Posted by Rumblingtaco View Post
I was too excited to turn it back on and forgot to reconnect my bpv
Matrex15 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

All times are GMT -4. The time now is 10:48 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2019 Axivo Inc.
Copyright ©1999 - 2019, North American Subaru Impreza Owners Club, Inc.

As an Amazon Associate I earn from qualifying purchases.