Welcome to the North American Subaru Impreza Owners Club Sunday May 29, 2022
Home Forums Images WikiNASIOC Products Store Modifications Upgrade Garage
Click here to visit TireRack
Brakes & Suspension Forum sponsored by The Tire Rack

Losing traction? Need new tires?
Click here to visit the NASIOC Upgrade Garage...
Go Back   NASIOC > NASIOC Technical > Brakes, Steering & Suspension

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.







* As an Amazon Associate I earn from qualifying purchases. 
* Registered users of the site do not see these ads. 
Reply
 
Thread Tools Display Modes
Old 08-16-2017, 10:27 AM   #1251
Web Foot STi
Scooby Guru
 
Member#: 39086
Join Date: Jun 2003
Chapter/Region: NWIC
Location: Portland, OR
Vehicle:
2004 STi
White

Default

Quote:
Originally Posted by Notbrick View Post
Thanks Web. Did you completely disassemble the assembly or just lift the boot and apply?
I didn't even jack up the car. Remember the struts are inverted and it's easy slide up the boot and slather the shaft with ~1/2 golf ball sized blob.

If I ever get my struts rebuilt/re-valved I will definitely spring for the few extra dollars to have the Zerk fittings installed, but at this point I just don't see it worth the work to disassemble the struts just to grease the shafts.
* Registered users of the site do not see these ads.
Web Foot STi is offline   Reply With Quote
Sponsored Links
* Registered users of the site do not see these ads.
Old 01-06-2022, 04:29 PM   #1252
S2000_Europe
Scooby Newbie
 
Member#: 297373
Join Date: Oct 2011
Chapter/Region: South East
Location: South East
Vehicle:
2018 STI Type RA
Black

Default

Sorry to revive this, I have a Type RA and every time I pass over a speed bump I can hear a "Clung". The struts are different from my previous MY17, but is the same problem?
S2000_Europe is offline   Reply With Quote
Old 01-07-2022, 09:07 AM   #1253
Randog77
Scooby Newbie
 
Member#: 37272
Join Date: May 2003
Location: Allentown PA
Vehicle:
2004 WRX STi
WR Blue

Default Try itÖ

I would say you should just try putting some grease on the strut and see if it helps? If it goes away ( for a while ) itís the same problem.
Randog77 is offline   Reply With Quote
Old 01-07-2022, 09:53 AM   #1254
S2000_Europe
Scooby Newbie
 
Member#: 297373
Join Date: Oct 2011
Chapter/Region: South East
Location: South East
Vehicle:
2018 STI Type RA
Black

Default

Is weird, different shock manufacter and same problem?

I will check again the grease
S2000_Europe is offline   Reply With Quote
Old 01-07-2022, 03:32 PM   #1255
Web Foot STi
Scooby Guru
 
Member#: 39086
Join Date: Jun 2003
Chapter/Region: NWIC
Location: Portland, OR
Vehicle:
2004 STi
White

Default

It's a little messy, but as I said it is easy and I have only had to do it once in ~90,000 miles now and owned the car since the end of May 2003.
Web Foot STi is offline   Reply With Quote
Old 01-19-2022, 08:48 PM   #1256
S2000_Europe
Scooby Newbie
 
Member#: 297373
Join Date: Oct 2011
Chapter/Region: South East
Location: South East
Vehicle:
2018 STI Type RA
Black

Default

Quote:
Originally Posted by S2000_Europe View Post
Sorry to revive this, I have a Type RA and every time I pass over a speed bump I can hear a "Clung". The struts are different from my previous MY17, but is the same problem?

The problem was the rear sway bar and the bushings. The dealer is going to replace the rear sway bar, bushings and bushings "retainers" (forgot the name in English)
S2000_Europe is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Only one rear suspension clunks ST3 Brakes, Steering & Suspension 1 05-16-2006 01:31 AM
05 Sti rear suspension clunking? jmanSTI Brakes, Steering & Suspension 7 03-09-2006 11:11 AM
STI rear suspension clunking scubi Brakes, Steering & Suspension 0 11-11-2005 01:58 AM
MI: STi rear suspension clunk fixes Smittys_STi Mid West Subaru Owners Club Forum -- MWSOC 24 06-29-2005 08:38 AM
Rear suspension clunk when left/right load is not balanced?? wayoutwest Brakes, Steering & Suspension 10 07-30-2004 12:35 PM

All times are GMT -4. The time now is 07:48 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2022, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2022 Axivo Inc.
Copyright ©1999 - 2019, North American Subaru Impreza Owners Club, Inc.

As an Amazon Associate I earn from qualifying purchases.