Welcome to the North American Subaru Impreza Owners Club Saturday March 23, 2019
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Go Back   NASIOC > NASIOC Technical > Service & Maintenance

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads. 
Reply
 
Thread Tools Display Modes
Old 02-07-2019, 02:24 PM   #1
jkm5164
Scooby Newbie
 
Member#: 417287
Join Date: Mar 2015
Chapter/Region: Tri-State
Location: Philly
Vehicle:
2015 WRX
WR Blue

Default VDC Light and Hill Assist Light On. ABS Light Off.

I wanted to share a problem I had that i just solved. I couldn't find anything on the internet about this issue.

2015 WRX 6MT. I had the VXMOTOR JDM Red Lens Rear Fog Light Lamp that you can get from amazon. I had it on my vehicle for 2.5 years. Recently my VDC and Hill Assist lights came on and stayed on. No ABS light though.

My snap-on scan of course couldn't pull the right body codes from the vehicle so i had to bite the bullet and take her over to the dealer.

He pulled a "Stop lamp switch code". I'm blanking on the code number. It may have been an ABS code 54 or 55.

He wanted to sell me a new stomp lamp switch. I know the fozzys have had problems, but i haven't really heard of the 15+ WRXs having issues with that switch.

He ordered the switch and i went on my way. I was going to come back and get the switch and install it myself. BUT..... I had the idea to just put my brake wiring back to stock before installing the switch...so I disconnected the 4th brake light or rear fog (whatever name you wish to call it).

After clearing the codes the lights never came back on. They have been off for 3 weeks now.

What happen was the 4th brake light unit failed somehow and was back feeding voltage to the module, confusing the heck out of it. The module didn't know what was going on with braking, so it disabled the VDC and Hill assist.

Please be aware of this issue and this product. It is the cheapest one you can find on the internet, so i guess you get what you pay for.
* Registered users of the site do not see these ads.
jkm5164 is offline   Reply With Quote
Sponsored Links
* Registered users of the site do not see these ads.
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

All times are GMT -4. The time now is 01:07 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2019 Axivo Inc.
Copyright ©1999 - 2017, North American Subaru Impreza Owners Club, Inc.