Welcome to the North American Subaru Impreza Owners Club Wednesday December 13, 2017
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Go Back   NASIOC > NASIOC Technical > Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo)

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads. 
Reply
 
Thread Tools Display Modes
Old 04-16-2004, 11:15 PM   #1
Desolate One
Scooby Newbie
 
Member#: 22797
Join Date: Aug 2002
Location: Las Vegas
Vehicle:
2003 WRX Wagon
Silver

Default CEL, engine bogs

Do not take offense to the "tone", I'm just a bit worried about my baby

Hey guys, just like the topic says- I have a CEL and the engine bogs badly. It started out as a very high idle (2k RPM), then it bogs all of a sudden and I get the CEL. I know at this point a lot of you guys are thinking, "Okay jack###, wot mods do you have?" Well let me tell ya.

Blitz FATT
STi fog light grills
STi hood scoop

Call me a ricer if you will but I feel the performance of the 'rex is enough to get me the 2.7 miles to and from work. So now you guys are all thinking, "So just take it in for warranty work then dumb###!" Right, I will. However I'm the type that HAS to know wot's going on. So wot, I like to be in the know.

Regardless. Any help would be appreciated.

Thanks.
* Registered users of the site do not see these ads.
Desolate One is offline   Reply With Quote
Sponsored Links
* Registered users of the site do not see these ads.
Old 04-17-2004, 12:17 AM   #2
Uncle Scotty
*** Banned ***
 
Member#: 16200
Join Date: Mar 2002
Vehicle:
OK buy Nates beans
westcoastroasting.com

Default

....get the code pulled and tell us what it is and go from there....
Uncle Scotty is offline   Reply With Quote
Old 04-17-2004, 12:20 AM   #3
Thumper23
Scooby Specialist
 
Member#: 11571
Join Date: Oct 2001
Chapter/Region: MAIC
Location: Virginia Beach, VA
Default

Quote:
Originally posted by Uncle Scotty
....get the code pulled and tell us what it is and go from there....
Thumper23 is online now   Reply With Quote
Old 04-17-2004, 12:56 AM   #4
Desolate One
Scooby Newbie
 
Member#: 22797
Join Date: Aug 2002
Location: Las Vegas
Vehicle:
2003 WRX Wagon
Silver

Default

Right, My palm is at my place and I'm at my girl's. I just thought I'd ask to stop worrying to the point of crapping chrimson.

Thanks for the imput!
Desolate One is offline   Reply With Quote
Old 04-17-2004, 03:25 PM   #5
Desolate One
Scooby Newbie
 
Member#: 22797
Join Date: Aug 2002
Location: Las Vegas
Vehicle:
2003 WRX Wagon
Silver

Default

Nevermind, got the recall notice today.
Desolate One is offline   Reply With Quote
Old 04-17-2004, 09:12 PM   #6
Uncle Scotty
*** Banned ***
 
Member#: 16200
Join Date: Mar 2002
Vehicle:
OK buy Nates beans
westcoastroasting.com

Default

Quote:
Originally posted by Desolate One
Nevermind, got the recall notice today.
This has nothing to do with any recall....
Uncle Scotty is offline   Reply With Quote
Old 04-17-2004, 09:32 PM   #7
Thumper23
Scooby Specialist
 
Member#: 11571
Join Date: Oct 2001
Chapter/Region: MAIC
Location: Virginia Beach, VA
Default

Quote:
Originally posted by Desolate One
Nevermind, got the recall notice today.

the only recall I know of recently is the cruise control cable

and your problem has nothing to do with the cruise control
Thumper23 is online now   Reply With Quote
Old 04-17-2004, 09:36 PM   #8
mexicanpizza
Scooby Specialist
 
Member#: 16779
Join Date: Mar 2002
Chapter/Region: SCIC
Location: Oceanside, CA
Vehicle:
2008 God's Gift to
Turbo Wagons (MS3)

Default

"WHAT", NOT "WOT"
mexicanpizza is offline   Reply With Quote
Old 04-17-2004, 09:37 PM   #9
mexicanpizza
Scooby Specialist
 
Member#: 16779
Join Date: Mar 2002
Chapter/Region: SCIC
Location: Oceanside, CA
Vehicle:
2008 God's Gift to
Turbo Wagons (MS3)

Default

oh and I say your front o2 is goners.
mexicanpizza is offline   Reply With Quote
Old 04-17-2004, 09:44 PM   #10
Desolate One
Scooby Newbie
 
Member#: 22797
Join Date: Aug 2002
Location: Las Vegas
Vehicle:
2003 WRX Wagon
Silver

Default

The recall notice I got described the problem exactly actually.

Subaru has determined that your vehicle may have been manufatured with a cruise control cable that could come out of it's track on the cruise control lever and lodge on the control lever tab when the accelerator pedal is released. If this condition occurs, the trottle will not return to the idle position and instead will remain in an open position. This condition could occur at any time without prior notice, even when the cruise control is turned off

Exactly wot had happened before the bogging the the CEL. Code is P0519, Idle Control System Malfunction (Fail Safe). Likely because the engine is idling at a higher speed than the ECU wants it to be.

Regardless, you must be right since you are the scobby guru.
Desolate One is offline   Reply With Quote
Old 04-17-2004, 09:46 PM   #11
Desolate One
Scooby Newbie
 
Member#: 22797
Join Date: Aug 2002
Location: Las Vegas
Vehicle:
2003 WRX Wagon
Silver

Default

Quote:
Originally posted by mexicanpizza
"WHAT", NOT "WOT"
This is exactly why I want to get a Scion. No jack asses on their board.
Desolate One is offline   Reply With Quote
Old 04-18-2004, 03:09 AM   #12
Uncle Scotty
*** Banned ***
 
Member#: 16200
Join Date: Mar 2002
Vehicle:
OK buy Nates beans
westcoastroasting.com

Default

Quote:
Originally posted by Desolate One
This is exactly why I want to get a Scion. No jack asses on their board.
Sure there are....you just haven't met them yet....
Uncle Scotty is offline   Reply With Quote
Old 04-18-2004, 12:08 PM   #13
Desolate One
Scooby Newbie
 
Member#: 22797
Join Date: Aug 2002
Location: Las Vegas
Vehicle:
2003 WRX Wagon
Silver

Default

Quote:
Originally posted by Uncle Scotty
Sure there are....you just haven't met them yet....
I do apologize, that statement was a bit rash (not to mention ridiculous). I was a bit upset my car was acting up w/ no reason. I only posted my question because at the time I didn't have my scan tool available and I was just looking for a bit of knowledge. Now I know not to make that mistake again. I'm getting a car charger for my palm so I always have it on hand.
Desolate One is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Engine Bogging wrpmission Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo) 7 05-21-2004 05:50 PM
CEL- engine revs then bogs kaisersling Service & Maintenance 4 04-26-2004 02:40 PM
engine bogging flent Normally Aspirated Powertrain 2 02-13-2003 05:42 PM
On Harsh 90degree turn engine bogs GregBolby General Community 4 11-03-2001 01:49 AM
Engine Bogging? djerickd Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo) 3 06-15-2001 12:47 PM

All times are GMT -4. The time now is 05:18 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2017 Axivo Inc.
Copyright ©1999 - 2017, North American Subaru Impreza Owners Club, Inc.