Welcome to the North American Subaru Impreza Owners Club Thursday May 13, 2021
Home Forums Images WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Go Back   NASIOC > NASIOC General > Member's Car Gallery

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.







* As an Amazon Associate I earn from qualifying purchases. 
* Registered users of the site do not see these ads. 
Reply
 
Thread Tools Display Modes
Old 04-06-2021, 05:17 PM   #26
Silver571
Scooby Specialist
 
Member#: 88361
Join Date: Jun 2005
Chapter/Region: TXIC
Location: Las Colinas
Vehicle:
2013 Zentorno

Default

Quote:
Originally Posted by Scooby South View Post
Oh no... Motor??? or ??? good luck getting it going again.

Bill


Fortunately, it was just the ground battery cable. Took the opportunity to relocate the battery to the trunk and switch over to an Odyssey battery.
* Registered users of the site do not see these ads.
Silver571 is offline   Reply With Quote
Sponsored Links
* Registered users of the site do not see these ads.
Old 04-06-2021, 06:07 PM   #27
Scooby South
Subtly Outspoken
Moderator
 
Member#: 238
Join Date: Sep 1999
Chapter/Region: MWSOC
Vehicle:
OG05 STi
51E

Default

Awesome news.. Pheeeeew..
Scooby South is online now   Reply With Quote
Old 04-07-2021, 03:44 PM   #28
Silver571
Scooby Specialist
 
Member#: 88361
Join Date: Jun 2005
Chapter/Region: TXIC
Location: Las Colinas
Vehicle:
2013 Zentorno

Default

Quick update, nothing fun but things that needed to be done. I ordered a whole mess of stuff from TiC, good dudes over there. Super shift kit, unabomber's sexy rearend (lennyface.txt), group N motor and trans mount, trailing arm bushings, crossmember bushings, etc. Replacing and upgrading items which have 180k on them. As stated above, also went ahead and relocated the battery to the trunk. With that came an Odyssey dry cell. Lastly, changed out the clutch to an exedy oem replacement and ACT flywheel. Motul fluids all around -- the oil looked absolutely terrible and was roughly two quarts low. Sad. I'll be tackling suspension, alignment, temp wheels, and full brake upgrade next.

On to the parts pictures, absolute box chaos in my office.







[
Silver571 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

All times are GMT -4. The time now is 09:39 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2021, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2021 Axivo Inc.
Copyright ©1999 - 2019, North American Subaru Impreza Owners Club, Inc.

As an Amazon Associate I earn from qualifying purchases.