Welcome to the North American Subaru Impreza Owners Club Sunday November 17, 2019
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
Mid Atlantic Impreza Club
Mid Atlantic Impreza Club Forum sponsored by Annapolis Subaru
Go Back   NASIOC > NASIOC Chapters > Mid Atlantic Impreza Club -- MAIC

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.







* As an Amazon Associate I earn from qualifying purchases. 
* Registered users of the site do not see these ads. 
Reply
 
Thread Tools Display Modes
Old 03-08-2017, 09:37 PM   #3876
Very WRXY
Scooby Specialist
 
Member#: 295615
Join Date: Sep 2011
Chapter/Region: MAIC
Location: SmithVEGAS
Vehicle:
2017 WRX Premium
Pure Red

Default What did you really do to your car today? V3.1

Quote:
Originally Posted by infinite012 View Post
Dropped my specB off at the body shop to get fixed up.

What happened?



Finished up the rear brake light install. Also got the climate control knobs and ignition ring on too.


* Registered users of the site do not see these ads.
Very WRXY is offline   Reply With Quote
Sponsored Links
* Registered users of the site do not see these ads.
Old 03-08-2017, 11:31 PM   #3877
infinite012
Scooby Specialist
 
Member#: 74392
Join Date: Nov 2004
Chapter/Region: MAIC
Location: Virginia
Vehicle:
15 Foz
SWP

Default

Check engine light came on, I pulled over and popped the hood to check that my engine was still present, then the wind took the hood off of the prop rod, bending it back toward the windshield. Hood and fenders got damaged.
infinite012 is offline   Reply With Quote
Old 03-09-2017, 07:01 AM   #3878
Very WRXY
Scooby Specialist
 
Member#: 295615
Join Date: Sep 2011
Chapter/Region: MAIC
Location: SmithVEGAS
Vehicle:
2017 WRX Premium
Pure Red

Default

Quote:
Originally Posted by infinite012 View Post
Check engine light came on, I pulled over and popped the hood to check that my engine was still present, then the wind took the hood off of the prop rod, bending it back toward the windshield. Hood and fenders got damaged.


Wow dude. That blows (pun intended). Going through insurance or out of your pocket? I'd assume this would be a comprehensive claim.

Also what was the CEL for? I'm sure something stupid like gas cap.
Very WRXY is offline   Reply With Quote
Old 03-09-2017, 08:18 AM   #3879
infinite012
Scooby Specialist
 
Member#: 74392
Join Date: Nov 2004
Chapter/Region: MAIC
Location: Virginia
Vehicle:
15 Foz
SWP

Default

The CEL was for P0500, which is something about vehicle speed sensor. After I pulled over, I turned the car off and then tried turning it back on, but it failed. I tried again a minute later and it took a while to crank over, but it did, but then it felt like I was running on 3 cylinders and the car died by itself. So, I cleared the code with Torque and then opened the hood. Blah blah blah comprehensive insurance claim blah blah $1600 estimate blah.
infinite012 is offline   Reply With Quote
Old 03-09-2017, 08:56 AM   #3880
Very WRXY
Scooby Specialist
 
Member#: 295615
Join Date: Sep 2011
Chapter/Region: MAIC
Location: SmithVEGAS
Vehicle:
2017 WRX Premium
Pure Red

Default

Dang man. Sorry to hear that. I wanna see pics of the damage.
Very WRXY is offline   Reply With Quote
Old 03-09-2017, 09:43 AM   #3881
96accord
Scooby Guru
 
Member#: 145105
Join Date: Apr 2007
Chapter/Region: MAIC
Location: Middle River, Maryland
Vehicle:
2007 Impreza WRX STi
'15 Accord (Daily)

Default

Quote:
Originally Posted by Very WRXY View Post
Finished up the rear brake light install. Also got the climate control knobs and ignition ring on too.
Ricer... Should have kept the Benz..
96accord is offline   Reply With Quote
Old 03-09-2017, 10:24 AM   #3882
infinite012
Scooby Specialist
 
Member#: 74392
Join Date: Nov 2004
Chapter/Region: MAIC
Location: Virginia
Vehicle:
15 Foz
SWP

Default

Quote:
Originally Posted by Very WRXY View Post
Dang man. Sorry to hear that. I wanna see pics of the damage.
I'll see if I can get the pictures the body shop took.
infinite012 is offline   Reply With Quote
Old 03-09-2017, 11:29 AM   #3883
Very WRXY
Scooby Specialist
 
Member#: 295615
Join Date: Sep 2011
Chapter/Region: MAIC
Location: SmithVEGAS
Vehicle:
2017 WRX Premium
Pure Red

Default What did you really do to your car today? V3.1

Quote:
Originally Posted by 96accord View Post
Ricer... Should have kept the Benz..

Shut your pie hole. Don't hate on all my "mods."

It's funny because friends/family keep texting me saying they see it around the area. Can't wait till I see it. Ima get my rimzzzz back.

Quote:
Originally Posted by infinite012 View Post
I'll see if I can get the pictures the body shop took.

Okay.
Very WRXY is offline   Reply With Quote
Old 03-10-2017, 06:13 PM   #3884
infinite012
Scooby Specialist
 
Member#: 74392
Join Date: Nov 2004
Chapter/Region: MAIC
Location: Virginia
Vehicle:
15 Foz
SWP

Default



Yeah...
infinite012 is offline   Reply With Quote
Old 03-10-2017, 06:33 PM   #3885
Very WRXY
Scooby Specialist
 
Member#: 295615
Join Date: Sep 2011
Chapter/Region: MAIC
Location: SmithVEGAS
Vehicle:
2017 WRX Premium
Pure Red

Default What did you really do to your car today? V3.1

Quote:
Originally Posted by infinite012 View Post

Yeah...

Damn man. She dirty. When you supposed to have her back?

Crappy photo of LED lows and c lights. (Passenger side)

Very WRXY is offline   Reply With Quote
Old 03-10-2017, 07:36 PM   #3886
infinite012
Scooby Specialist
 
Member#: 74392
Join Date: Nov 2004
Chapter/Region: MAIC
Location: Virginia
Vehicle:
15 Foz
SWP

Default

Hopefully next Wednesday
infinite012 is offline   Reply With Quote
Old 03-11-2017, 05:33 PM   #3887
Patrick Olsen
Scooby Guru
 
Member#: 120
Join Date: Jul 1999
Chapter/Region: AKIC
Location: Where the Navy sends me...
Vehicle:
1997 Legacy 2.5GT
1996 Impreza coupe

Default

Installed the STI rear swaybar bushing mounts and Energy Suspension 18mm bushings.







Driver side was easy, passenger side was a bit of a pain in the ass with the gas tank fill pipe in the way.
Patrick Olsen is offline   Reply With Quote
Old 03-11-2017, 08:46 PM   #3888
96accord
Scooby Guru
 
Member#: 145105
Join Date: Apr 2007
Chapter/Region: MAIC
Location: Middle River, Maryland
Vehicle:
2007 Impreza WRX STi
'15 Accord (Daily)

Default

Quote:
Originally Posted by Very WRXY View Post
Crappy photo of LED lows and c lights. (Passenger side)
Should have bought a Limited
96accord is offline   Reply With Quote
Old 03-11-2017, 09:05 PM   #3889
2slofouru
NASIOC Supporter
 
Member#: 90539
Join Date: Jul 2005
Chapter/Region: South East
Location: Lake Charles
Vehicle:
My BOV goes
COVFEFE!

Default

Re-booted both front cv axles and attempted to clean the tons of grease off the underside of the car.

Also pulled the rear seat out to try and see what I pulled loose when changing the fuel pump and filter a while back. Since then there has been a small evap leak that causes a code every now and then and there is a faint smell of fuel fumes. I bought a new top gasket if needed, but am afraid the problem is probably a tube or hose on the top that I can't get to without dropping the subframe and tank. :/ So yeah, I gave up on that for today and put the seat back in.
2slofouru is offline   Reply With Quote
Old 03-11-2017, 09:39 PM   #3890
Very WRXY
Scooby Specialist
 
Member#: 295615
Join Date: Sep 2011
Chapter/Region: MAIC
Location: SmithVEGAS
Vehicle:
2017 WRX Premium
Pure Red

Default

Quote:
Originally Posted by 96accord View Post
Should have bought a Limited


Pfft. Mine looks way better.
Very WRXY is offline   Reply With Quote
Old 03-14-2017, 07:51 PM   #3891
Patrick Olsen
Scooby Guru
 
Member#: 120
Join Date: Jul 1999
Chapter/Region: AKIC
Location: Where the Navy sends me...
Vehicle:
1997 Legacy 2.5GT
1996 Impreza coupe

Default

- Assisted the plows in clearing the roads. Arrived at work with all of the wheels out of balance because they were lined with snow inside the barrel.

- Popped apart my apparently-poorly-clamped-together header about a block before getting to work.

- After work, jacked the car up in a dry spot in the parking garage so I could slide the downstream side of the header back into the band clamp it had slipped out of. Didn't have a 14mm deep socket, so I couldn't try tightening the clamp any more. It made it home without popping apart again.

- Once I was home, jacked the car up in the driveway, repositioned the band clamp and tightened it back down, then added an exhaust hanger I had on hand to exert some holding force towards the driver side. That will (hopefully) keep things in place for a few days until I can get the header welded back together and lose the band clamp.

Patrick Olsen is offline   Reply With Quote
Old 03-14-2017, 10:02 PM   #3892
96accord
Scooby Guru
 
Member#: 145105
Join Date: Apr 2007
Chapter/Region: MAIC
Location: Middle River, Maryland
Vehicle:
2007 Impreza WRX STi
'15 Accord (Daily)

Default

Quote:
Originally Posted by Very WRXY View Post
Pfft. Mine looks way better.
says who?
96accord is offline   Reply With Quote
Old 03-15-2017, 12:20 PM   #3893
1stockwrx
Scooby Guru
 
Member#: 162365
Join Date: Oct 2007
Location: Virginia
Vehicle:
05 Civic Si

Default

Red does look better!
1stockwrx is offline   Reply With Quote
Old 03-15-2017, 03:49 PM   #3894
Very WRXY
Scooby Specialist
 
Member#: 295615
Join Date: Sep 2011
Chapter/Region: MAIC
Location: SmithVEGAS
Vehicle:
2017 WRX Premium
Pure Red

Default What did you really do to your car today? V3.1

Quote:
Originally Posted by 1stockwrx View Post
Red does look better!

This^

Quote:
Originally Posted by 96accord View Post
says who?

Please see above.

Quote:
Originally Posted by infinite012 View Post
Hopefully next Wednesday

Getting her back tomorrow?
Very WRXY is offline   Reply With Quote
Old 03-15-2017, 10:21 PM   #3895
infinite012
Scooby Specialist
 
Member#: 74392
Join Date: Nov 2004
Chapter/Region: MAIC
Location: Virginia
Vehicle:
15 Foz
SWP

Default

It was supposed to be ready today, but some trim pieces didn't get delivered due to the snow. Maybe next Monday.

infinite012 is offline   Reply With Quote
Old 03-16-2017, 07:14 AM   #3896
Very WRXY
Scooby Specialist
 
Member#: 295615
Join Date: Sep 2011
Chapter/Region: MAIC
Location: SmithVEGAS
Vehicle:
2017 WRX Premium
Pure Red

Default What did you really do to your car today? V3.1

Quote:
Originally Posted by infinite012 View Post
It was supposed to be ready today, but some trim pieces didn't get delivered due to the snow. Maybe next Monday.



Lame. Sorry to hear that man.

To stay on topic...I added a hair brush to my car.....for me. Wth has my life come to?
Very WRXY is offline   Reply With Quote
Old 03-16-2017, 09:45 AM   #3897
96accord
Scooby Guru
 
Member#: 145105
Join Date: Apr 2007
Chapter/Region: MAIC
Location: Middle River, Maryland
Vehicle:
2007 Impreza WRX STi
'15 Accord (Daily)

Default

Quote:
Originally Posted by Very WRXY View Post
I added a hair brush to my car.....for me. Wth has my life come to?
WTF
96accord is offline   Reply With Quote
Old 03-16-2017, 09:53 AM   #3898
Very WRXY
Scooby Specialist
 
Member#: 295615
Join Date: Sep 2011
Chapter/Region: MAIC
Location: SmithVEGAS
Vehicle:
2017 WRX Premium
Pure Red

Default

Quote:
Originally Posted by 96accord View Post
WTF


Gotta keep my cut adult hair in check. You know I don't have that random mop hair anymore that you all complained about.
Very WRXY is offline   Reply With Quote
Old 03-18-2017, 07:27 PM   #3899
Patrick Olsen
Scooby Guru
 
Member#: 120
Join Date: Jul 1999
Chapter/Region: AKIC
Location: Where the Navy sends me...
Vehicle:
1997 Legacy 2.5GT
1996 Impreza coupe

Default

- Swapped the stock header back on so I can get my crudely modded UEL header welded up.

- Finally adjusted the clutch cable so the pick-up point isn't so high off the floor. When I went to test drive the car before I bought it from emsmap the pick-up was soooo much higher than I was used to with my other cars that it was like I didn't know how to drive stick. Rev rev rev rev and there's the clutch! All better now.
Patrick Olsen is offline   Reply With Quote
Old 03-19-2017, 07:56 PM   #3900
Patrick Olsen
Scooby Guru
 
Member#: 120
Join Date: Jul 1999
Chapter/Region: AKIC
Location: Where the Navy sends me...
Vehicle:
1997 Legacy 2.5GT
1996 Impreza coupe

Default

- Finally replaced the HVAC head unit. When I got the car, the center knob (temperature control) wasn't connected to its cable; said cable was just poking out of the center stack above the stereo, so I had to manually operate it. The cable wasn't connected because the spot where it clips into the bottom of the HVAC head unit has broken off, so it wouldn't stay in place. I had picked up a new HVAC head unit at the junkyard, but getting that one out had been a bit of a pain in the ass, so I hadn't tried installing it.

In order to get enough slack in the two control cables to hook them up to the head unit, I disconnected their opposite ends, under the dash. Both were pretty easy to get to, just on either side of the tranny hump. Hooked the cables up, loosely installed the head unit, made sure the knobs actuated things corrected, then buttoned everything up. With that fixed, I was able to...

- Installed a DIN-sized storage pocket above the stereo. Now that there's no temperature control cable poking out there I could close up that hole. Hooray! The storage pocket was another junkyard part; it's a little warped along the bottom edge. Probably should've heated it up and tried to straighten it out before installing it, but that ship has sailed.
Patrick Olsen is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

All times are GMT -4. The time now is 05:36 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2019 Axivo Inc.
Copyright ©1999 - 2019, North American Subaru Impreza Owners Club, Inc.

As an Amazon Associate I earn from qualifying purchases.