Welcome to the North American Subaru Impreza Owners Club Friday November 15, 2019
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Go Back   NASIOC > NASIOC Technical > Factory 2.5L Turbo Powertrain (EJ Series Factory 2.5L Turbo)

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.







* As an Amazon Associate I earn from qualifying purchases. 
* Registered users of the site do not see these ads. 
Reply
 
Thread Tools Display Modes
Old 10-19-2019, 11:18 PM   #1
apollo23
Scooby Newbie
 
Member#: 499429
Join Date: Mar 2019
Location: British Columbia, Canada
Vehicle:
2007 WRX
UGM (45a)

Default 2007 WRX Secondary Air Injection system stuck CLOSED. Pull fuses and delete codes?

Hey all, I am the owner of a 2007 WRX with "Stage 3-ish" mods (vf39, STI top mount, catless turboback) and my secondary air injection system has been giving me a really rough time. I'm throwing a few codes, specifically ones for the valves being stuck closed (bank 1 and 2), the air pump stuck on, air pump performance, and one other thing. Seeing as the valves are stuck closed, would it be okay to just pull the fuses and related relays, and just delete the codes until I can properly block them off? I've heard people have done that before without issues for years, (of course I don't plan to wait that long to block it off, however.)

Anyway let me know if you guys think it'd be okay to do that.
* Registered users of the site do not see these ads.
apollo23 is offline   Reply With Quote
Sponsored Links
* Registered users of the site do not see these ads.
Old 10-20-2019, 01:38 PM   #2
A.S.N.F.
Scooby Newbie
 
Member#: 498940
Join Date: Mar 2019
Chapter/Region: MWSOC
Vehicle:
2010 WRX
Lightning Red

Default

Short term maybe, I have been told this can put it in limp in but I don't know what years will do this. But, time to do an air pump delete and then have a tuner like boosted performance turn it off while getting a good tune. Mechanical simplicity.
A.S.N.F. is offline   Reply With Quote
Old 10-20-2019, 04:00 PM   #3
Blktrax
Scooby Specialist
 
Member#: 220971
Join Date: Aug 2009
Chapter/Region: South East
Location: West, NC
Vehicle:
2002 WRX 224K Mi.

Default

Unless you have specifically turned off the codes in a tuning solution , every cold start will repost the codes.
Blktrax is offline   Reply With Quote
Old 10-20-2019, 11:01 PM   #4
apollo23
Scooby Newbie
 
Member#: 499429
Join Date: Mar 2019
Location: British Columbia, Canada
Vehicle:
2007 WRX
UGM (45a)

Default

I will have my tuner turn off all related codes for the time. My thoughts just are, we are having some troubles with my DAM numbers and a low boost, so I'm thinking the CEL's im throwing might be putting me in limp mode, so we are going to turn it all off so we can properly see if it's that or not.
apollo23 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

All times are GMT -4. The time now is 01:36 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2019 Axivo Inc.
Copyright ©1999 - 2019, North American Subaru Impreza Owners Club, Inc.

As an Amazon Associate I earn from qualifying purchases.