Welcome to the North American Subaru Impreza Owners Club Thursday April 26, 2018
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Go Back   NASIOC > NASIOC General > Car Audio, Video & Security

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads. 
Reply
 
Thread Tools Display Modes
Old 12-10-2017, 12:08 PM   #1
Spetnaut
Scooby Newbie
 
Member#: 464237
Join Date: Mar 2017
Chapter/Region: Tri-State
Location: Queens NY
Vehicle:
2017 WRX
WRB

Default Bluetooth info not updating MY17 WRX

So I can’t really pinpoint when this started happing, but when plying audio over Bluetooth it will show the info of the first track, then not update. Pandora over USB is also bugged, pita to get it to work. This was happening on my iPhone 6 and now with my new iPhone X. Happens with any music app, Pandora, iTunes, etc. Super frustrating. Also this is the smaller sized screen, non nav and non harmon.
* Registered users of the site do not see these ads.

Last edited by Spetnaut; 12-14-2017 at 06:43 AM.
Spetnaut is offline   Reply With Quote
Sponsored Links
* Registered users of the site do not see these ads.
Old 12-13-2017, 02:33 PM   #2
RexyGirl
Scooby Specialist
 
Member#: 63616
Join Date: Jun 2004
Chapter/Region: South East
Location: Mastro Subaru, Sanford FL
Vehicle:
1996 Volvo 850 Turbo
with mods :)

Default

There maybe a radio software update to correct this issue. Contact your local dealer
RexyGirl is offline   Reply With Quote
Old 12-13-2017, 04:07 PM   #3
Spetnaut
Scooby Newbie
 
Member#: 464237
Join Date: Mar 2017
Chapter/Region: Tri-State
Location: Queens NY
Vehicle:
2017 WRX
WRB

Default

Quote:
Originally Posted by RexyGirl View Post
There maybe a radio software update to correct this issue. Contact your local dealer
Did that, and there is not. SOA was denying my claim up until this point, dealership recognized my problem, noted my account and SOA is now looking into it.
Spetnaut is offline   Reply With Quote
Old 12-14-2017, 04:41 PM   #4
StinkyTofu
Scooby Newbie
 
Member#: 44923
Join Date: Oct 2003
Default

This is problem on the base model wrx 16' and up. Its the deck and I have been trying to find a solution for this since I got my car. Super frustrating and makes me want to change the deck out.
StinkyTofu is offline   Reply With Quote
Old 12-14-2017, 05:06 PM   #5
Spetnaut
Scooby Newbie
 
Member#: 464237
Join Date: Mar 2017
Chapter/Region: Tri-State
Location: Queens NY
Vehicle:
2017 WRX
WRB

Default

Quote:
Originally Posted by StinkyTofu View Post
This is problem on the base model wrx 16' and up. Its the deck and I have been trying to find a solution for this since I got my car. Super frustrating and makes me want to change the deck out.
Call / Email SOA and file a complaint. If enough of us do, they will have to take some action.
Spetnaut is offline   Reply With Quote
Old 12-19-2017, 11:04 AM   #6
Tavataar
Scooby Newbie
 
Member#: 479332
Join Date: Dec 2017
Location: Maryland
Vehicle:
2017 WRX
WR Blue

Default

This has always been the case for my 2017 and Samsung S7. It was one of the initial things that led me to replacing the HU entirely. The default one is just a piece of crap.
Tavataar is offline   Reply With Quote
Old 12-20-2017, 11:50 AM   #7
gnarly802
Scooby Newbie
 
Member#: 244045
Join Date: Apr 2010
Chapter/Region: NESIC
Location: Vermont
Vehicle:
2016 wrx
wrb

Default

My 16 WRX Premium does the same with my Samsung S7. Playing music via USB rarely works and lately Pandora has not worked at all.
gnarly802 is offline   Reply With Quote
Old 12-20-2017, 01:26 PM   #8
joesstripclub
Scooby Newbie
 
Member#: 461015
Join Date: Jan 2017
Location: Kansas City
Vehicle:
2017 WRX

Default

I occasionally have to exit and restart spotify to get the songs to update on the head unit. I wonder if its an issue with the head unit or just a bluetooth bug.
joesstripclub is offline   Reply With Quote
Old 12-22-2017, 09:39 AM   #9
gnarly802
Scooby Newbie
 
Member#: 244045
Join Date: Apr 2010
Chapter/Region: NESIC
Location: Vermont
Vehicle:
2016 wrx
wrb

Default

SOA's very helpful response me, "Thank you for contacting Subaru of America, Inc. We appreciate you taking time out of your day to contact us.
Some of the points you mention may be due to normal operational characteristics of the Subaru entertainment system.
Other issues are likely due to the function of the device software.
If you suspect a malfunction, I would recommend having a Subaru retailer inspect the system for you.
Thanks for the opportunity to be of assistance.
Sincerely,
Grant Noble
Subaru of America, Inc."
gnarly802 is offline   Reply With Quote
Old 12-22-2017, 11:24 PM   #10
Tavataar
Scooby Newbie
 
Member#: 479332
Join Date: Dec 2017
Location: Maryland
Vehicle:
2017 WRX
WR Blue

Default

The malfunction is a piece of **** head unit.
Tavataar is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

All times are GMT -4. The time now is 05:01 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2018 Axivo Inc.
Copyright ©1999 - 2017, North American Subaru Impreza Owners Club, Inc.