Welcome to the North American Subaru Impreza Owners Club Tuesday November 13, 2018
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Go Back   NASIOC > NASIOC General > Car Audio, Video & Security

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads. 
Reply
 
Thread Tools Display Modes
Old 03-09-2016, 10:41 PM   #26
Brown1428
Scooby Newbie
 
Member#: 436456
Join Date: Dec 2015
Chapter/Region: South East
Vehicle:
2016 WRX LTD
CWP

Default

Quote:
Originally Posted by EJ1 View Post
I was able to source one for $150 so they can be had for less than $400. Definitely worth it given the cost.
I still haven't located the appropriate connector, unfortunately. I've wired it up with heatshrink for the time being. This is not ideal, however it does work. I'm going to order the dual port USB adaptor soon. USB connectivity hasnt been a priority for me but I do want the system to be 100% functional.

Have you installed yours yet?
* Registered users of the site do not see these ads.
Brown1428 is offline   Reply With Quote
Sponsored Links
* Registered users of the site do not see these ads.
Old 03-09-2016, 11:35 PM   #27
xDezor
Scooby Newbie
 
Member#: 440399
Join Date: Feb 2016
Location: Minneapolis, MN
Vehicle:
2016 WRX Limited
Lapis Blue Pearl

Default

Very cool! I was always wondering if the forester HU would fit.
xDezor is offline   Reply With Quote
Old 03-12-2016, 10:04 PM   #28
xDezor
Scooby Newbie
 
Member#: 440399
Join Date: Feb 2016
Location: Minneapolis, MN
Vehicle:
2016 WRX Limited
Lapis Blue Pearl

Default

Quote:
Originally Posted by Brown1428 View Post
I've been doing quite a bit of research into the idea of transplanting a 7" Starlink HU from a 2016 Forester into my 2016 WRX. As has been discussed many times, the 6.2" unit is woefully inadequate.

I found a good price on a Forester unit, so I pulled the trigger and installed this weekend. Mechanically it is a perfect fit. Functionally, there are a few things to iron out:

1. USB doesn't seem to be working. The HU has a USB source feature, but it's greyed out. The connector on the rear of the unit is identical to the 6.2 unit. It may be wired differently (doubtful) or the 7" HU is expecting to detect a 2 port USB hub and not the single port in the WRX. I think the Foresters have 2 USB ports instead of one in the armrest, but I need to confirm that.

UPDATE: SVXdc helped me quite a bit with the USB issue. All that is needed is a two port USB adaptor, which I will source soon.

2. Backup camera isn't working. The wires for the camera are located in the 28 pin connector for 6.2" applications but in the 7" unit they are relocated to a separate 5 pin connector. Its possible I mis-wired something when migrating the wires. Its also possible that the forester uses a different backup camera, although that seems less likely.

UPDATE: This was indeed a mis-wire related issue. Camera now works, and the HU "maintainence" mode allows for on-screen guide line customization.

Everything else seems to work perfectly. The 7" units have a much faster UI and do not seem to suffer from the BT connection delays/woes that afflict the 6.2" unit. The steering controls are also much more responsive. Text messaging on-screen notifications are nice.

All told this project cost $375 to complete. I'm very pleased with the results. I expect the cost of second hand HUs will drop significantly as time goes on.
I was thinking about this today. This post is actually interesting for another reason.

For a while now I've been looking for an OEM-looking replacement android headunit. Many chinese manufactures remake the same basic quad-core android head unit, and sometimes they are specifically molded to fit the car. I haven't had any luck sourcing a 2015+ WRX head unit, but I have seen a few forester head units pop up recently. That might be a viable option for those of you looking to go this route.
xDezor is offline   Reply With Quote
Old 04-20-2016, 08:20 AM   #29
Brown1428
Scooby Newbie
 
Member#: 436456
Join Date: Dec 2015
Chapter/Region: South East
Vehicle:
2016 WRX LTD
CWP

Default

Looks like this 7" unit (or something similar) will be standard on WRX Limited and STi for 2017. It will be interesting to see what, if any, added functionality lies within the new 2017 non-nav 7" units.
Brown1428 is offline   Reply With Quote
Old 05-09-2016, 02:04 PM   #30
ddehr026
Scooby Newbie
 
Member#: 446512
Join Date: May 2016
Default

Quote:
Originally Posted by Brown1428 View Post
I still haven't located the appropriate connector, unfortunately. I've wired it up with heatshrink for the time being. This is not ideal, however it does work. I'm going to order the dual port USB adaptor soon. USB connectivity hasnt been a priority for me but I do want the system to be 100% functional.

Have you installed yours yet?
So glad I came across your thread! I literally made the same swap you did. the 6.2" to the 7" nav unit, and I agree, huge difference! I am having the exacty same usb issue as you are, I first thought the unit was defective, but am confident it's the dual usb thing.

Do you have a part number for the harness from subaru? Maybe I can help look. I've been working with Brian from autoharness on this and he's interested in a solution as well.

It looks like this might be the correct part number: 86257al100

Thanks!

Last edited by ddehr026; 05-09-2016 at 05:53 PM.
ddehr026 is offline   Reply With Quote
Old 05-09-2016, 07:39 PM   #31
Brown1428
Scooby Newbie
 
Member#: 436456
Join Date: Dec 2015
Chapter/Region: South East
Vehicle:
2016 WRX LTD
CWP

Default

Quote:
Originally Posted by ddehr026 View Post
So glad I came across your thread! I literally made the same swap you did. the 6.2" to the 7" nav unit, and I agree, huge difference! I am having the exacty same usb issue as you are, I first thought the unit was defective, but am confident it's the dual usb thing.

Do you have a part number for the harness from subaru? Maybe I can help look. I've been working with Brian from autoharness on this and he's interested in a solution as well.

It looks like this might be the correct part number: 86257al100

Thanks!
That is the correct part number for the dual USB/AUX adaptor. No additional wiring should be necessary, although I don't know that with certainty since I haven't installed the dual port yet. The 86257AL100 is essentially a USB hub, so it doesn't need additional wires (in regards to the USB interface) to accommodate the extra port. It's also clear that these ports aren't powered from the HU like the single port configuration is, so that remains an open question.

Just curious, how did you hook up your BU camera? Were you able to source the 5 pin connector housing from somewhere? I've got mine working but my solution isn't elegant.

Also, you have a 7" NAV unit? What model vehicle was your donor?
Brown1428 is offline   Reply With Quote
Old 05-09-2016, 08:26 PM   #32
ddehr026
Scooby Newbie
 
Member#: 446512
Join Date: May 2016
Default

Quote:
Originally Posted by Brown1428 View Post
That is the correct part number for the dual USB/AUX adaptor. No additional wiring should be necessary, although I don't know that with certainty since I haven't installed the dual port yet. The 86257AL100 is essentially a USB hub, so it doesn't need additional wires (in regards to the USB interface) to accommodate the extra port. It's also clear that these ports aren't powered from the HU like the single port configuration is, so that remains an open question.

Just curious, how did you hook up your BU camera? Were you able to source the 5 pin connector housing from somewhere? I've got mine working but my solution isn't elegant.

Also, you have a 7" NAV unit? What model vehicle was your donor?
Thanks.

Interesting that it isn't powered from hu, that would explain why I can't get a 5v reading on any of the pins on the usb in back of unit. Wonder where it's powered from?

Yes, I have the 7" nav, fm644us on face. I got mine from a Crosstrek limited donor. Brian at autoharnesshouse was able to make me a breakout harness that was plug and play with the 5 pin backup broken out, super helpful guy. Worked perfect. Now if I can just get this pesky usb going I'll be all set!!

When you said you got it working by heat shrinking, what were you referring to?
ddehr026 is offline   Reply With Quote
Old 05-09-2016, 08:35 PM   #33
Brown1428
Scooby Newbie
 
Member#: 436456
Join Date: Dec 2015
Chapter/Region: South East
Vehicle:
2016 WRX LTD
CWP

Default

Quote:
Originally Posted by ddehr026 View Post
Thanks.

Interesting that it isn't powered from hu, that would explain why I can't get a 5v reading on any of the pins on the usb in back of unit. Wonder where it's powered from?

Yes, I have the 7" nav, fm644us on face. I got mine from a Crosstrek limited donor. Brian at autoharnesshouse was able to make me a breakout harness that was plug and play with the 5 pin backup broken out, super helpful guy. Worked perfect. Now if I can just get this pesky usb going I'll be all set!!

When you said you got it working by heat shrinking, what were you referring to?
I think it may tap off the wiring that feeds the cigarette lighter in the armrest but frankly I'm not sure.

That's great that you got a NAV unit to work. Was that a non-H/K unit? I didn't even consider the NAV units because I thought they would only work with the corresponding HK amp, which obviously my setup didn't have.

Do you have the nav function working then?

I'm too ashamed to say what I meant by heatshrinking, lol. Suffice it to say it works. I'd be interested in a NAV setup and a plug and play harness.
Brown1428 is offline   Reply With Quote
Old 05-09-2016, 09:58 PM   #34
ddehr026
Scooby Newbie
 
Member#: 446512
Join Date: May 2016
Default

Quote:
Originally Posted by Brown1428 View Post
I think it may tap off the wiring that feeds the cigarette lighter in the armrest but frankly I'm not sure.

That's great that you got a NAV unit to work. Was that a non-H/K unit? I didn't even consider the NAV units because I thought they would only work with the corresponding HK amp, which obviously my setup didn't have.

Do you have the nav function working then?

I'm too ashamed to say what I meant by heatshrinking, lol. Suffice it to say it works. I'd be interested in a NAV setup and a plug and play harness.
I went from a 2015 base 6.2" 86201FJ640 (CM644UL face ID) with a 2015 7.0" w/Nav 86271FJ630 (FM643US face ID).

Nav functions perfectly, had to buy some antennas and adapters on Amazon, but it works. Also had to get a siriusxm adapter and some fakra plugs. Both work great!

It's interesting because both the single USB port and the dual USB port show using the same cable from the hu, as far as I can tell. It just be something in the dual USB port that completes the circuit or something. I'm going to try and research a bit more. Would love to find someone with a limited with the factory dual port and take the center console out to see what's there. Hmm....
ddehr026 is offline   Reply With Quote
Old 05-10-2016, 11:21 AM   #35
Mrfreshkikz
Scooby Newbie
 
Member#: 419748
Join Date: Apr 2015
Default

How can I make this work on a 2015?
Mrfreshkikz is offline   Reply With Quote
Old 05-10-2016, 07:10 PM   #36
jtranizzle
Scooby Newbie
 
Member#: 441939
Join Date: Mar 2016
Chapter/Region: TXIC
Location: HOU
Vehicle:
2016 WRX Limited 6MT
Crystal White Pearl

Default

Is there any difference in sound quality?
jtranizzle is offline   Reply With Quote
Old 05-13-2016, 11:42 AM   #37
biserker1
Scooby Newbie
 
Member#: 427273
Join Date: Aug 2015
Location: Philadelphia, PA
Vehicle:
2016 WRX Limited

Default

So about to pull the trigger on this and have a few questions.

Needed to complete the install:

Relocation of backup cam (going to have brian from autoharnesshouse create a break out harness)

Double USB input for USB function - will try and source on for cheaper then OEM

Also - in the picture below. What does the green box correspond to?

Thanks.

biserker1 is offline   Reply With Quote
Old 05-13-2016, 12:24 PM   #38
biserker1
Scooby Newbie
 
Member#: 427273
Join Date: Aug 2015
Location: Philadelphia, PA
Vehicle:
2016 WRX Limited

Default 2016 Forester to WRX HU Transplant...

Quote:
Originally Posted by Brown1428 View Post
That is the correct part number for the dual USB/AUX adaptor. No additional wiring should be necessary, although I don't know that with certainty since I haven't installed the dual port yet. The 86257AL100 is essentially a USB hub, so it doesn't need additional wires (in regards to the USB interface) to accommodate the extra port. It's also clear that these ports aren't powered from the HU like the single port configuration is, so that remains an open question.



Just curious, how did you hook up your BU camera? Were you able to source the 5 pin connector housing from somewhere? I've got mine working but my solution isn't elegant.



Also, you have a 7" NAV unit? What model vehicle was your donor?


So with this part you know how access to 2 USB inputs?

Would running the second one to the glovebox be a good idea? Looks like there are two in the center console with this set up. Kind of a waste.

Last edited by biserker1; 05-13-2016 at 12:47 PM.
biserker1 is offline   Reply With Quote
Old 05-13-2016, 11:32 PM   #39
kimitsu1994
Scooby Newbie
 
Member#: 446878
Join Date: May 2016
Default

Nice!! Looks great!
kimitsu1994 is offline   Reply With Quote
Old 05-14-2016, 10:09 AM   #40
Brown1428
Scooby Newbie
 
Member#: 436456
Join Date: Dec 2015
Chapter/Region: South East
Vehicle:
2016 WRX LTD
CWP

Default

Quote:
Originally Posted by biserker1 View Post
So about to pull the trigger on this and have a few questions.

Needed to complete the install:

Relocation of backup cam (going to have brian from autoharnesshouse create a break out harness)

Double USB input for USB function - will try and source on for cheaper then OEM

Also - in the picture below. What does the green box correspond to?

Thanks.

The green box is the telematics interface, I think. I did not use it.
Brown1428 is offline   Reply With Quote
Old 05-14-2016, 10:13 AM   #41
Brown1428
Scooby Newbie
 
Member#: 436456
Join Date: Dec 2015
Chapter/Region: South East
Vehicle:
2016 WRX LTD
CWP

Default

Quote:
Originally Posted by biserker1 View Post
So with this part you know how access to 2 USB inputs?

Would running the second one to the glovebox be a good idea? Looks like there are two in the center console with this set up. Kind of a waste.
I'm not sure how one would run a separate port to the glove box. My focus has been to match the factory setup where possible, so I didn't really consider it.
Brown1428 is offline   Reply With Quote
Old 05-14-2016, 10:16 AM   #42
biserker1
Scooby Newbie
 
Member#: 427273
Join Date: Aug 2015
Location: Philadelphia, PA
Vehicle:
2016 WRX Limited

Default

Quote:
Originally Posted by Brown1428 View Post
I'm not sure how one would run a separate port to the glove box. My focus has been to match the factory setup where possible, so I didn't really consider it.


Yeah. I researched the hub needed last night and saw what it was.

I was under the impression it was split in the back of the HU.
biserker1 is offline   Reply With Quote
Old 05-14-2016, 04:17 PM   #43
ddehr026
Scooby Newbie
 
Member#: 446512
Join Date: May 2016
Default

USB issue has been resolved. Instead of trying to locate the dual usb OEM part, I got a cheapo reverse USB splitter (two male ends, one female end) and plugged one into the single usb port, the other into a usb port cigarette adapter, then my iPhone cord into that, voila! it works

ddehr026 is offline   Reply With Quote
Old 05-14-2016, 04:33 PM   #44
Brown1428
Scooby Newbie
 
Member#: 436456
Join Date: Dec 2015
Chapter/Region: South East
Vehicle:
2016 WRX LTD
CWP

Default

Quote:
Originally Posted by ddehr026 View Post
USB issue has been resolved. Instead of trying to locate the dual usb OEM part, I got a cheapo reverse USB splitter (two male ends, one female end) and plugged one into the single usb port, the other into a usb port cigarette adapter, then my iPhone cord into that, voila! it works

Outstanding work! You just saved me $117. So it seems like it doesn't necessarily need to be a "real" USB hub, it just needs to be powered.

Solid job on this, seriously.
Brown1428 is offline   Reply With Quote
Old 05-14-2016, 04:49 PM   #45
biserker1
Scooby Newbie
 
Member#: 427273
Join Date: Aug 2015
Location: Philadelphia, PA
Vehicle:
2016 WRX Limited

Default

Quote:
Originally Posted by ddehr026 View Post
USB issue has been resolved. Instead of trying to locate the dual usb OEM part, I got a cheapo reverse USB splitter (two male ends, one female end) and plugged one into the single usb port, the other into a usb port cigarette adapter, then my iPhone cord into that, voila! it works



Awesome! I started to search for this part and couldn't believe the cheapest I found was $119
biserker1 is offline   Reply With Quote
Old 05-14-2016, 07:06 PM   #46
biserker1
Scooby Newbie
 
Member#: 427273
Join Date: Aug 2015
Location: Philadelphia, PA
Vehicle:
2016 WRX Limited

Default

I have a unit on the way. I am also running the OEM plus system which should just be a direct replacement. I reached out to them and have not heard back yet.
biserker1 is offline   Reply With Quote
Old 05-14-2016, 08:38 PM   #47
ddehr026
Scooby Newbie
 
Member#: 446512
Join Date: May 2016
Default

Quote:
Originally Posted by Brown1428 View Post
Outstanding work! You just saved me $117. So it seems like it doesn't necessarily need to be a "real" USB hub, it just needs to be powered.

Solid job on this, seriously.
Wouldn't have ever thought to try without finding your thread! Brian at autoharness came up with the idea as we were brainstorming!

Here's the one I got www.amazon.com/Electop-Female-Splitter-Charger-Cable/dp/B01ALLWDFW?

Last edited by ddehr026; 05-14-2016 at 08:49 PM.
ddehr026 is offline   Reply With Quote
Old 05-24-2016, 04:45 PM   #48
whiplash willy
Scooby Newbie
 
Member#: 424843
Join Date: Jul 2015
Location: Portland, Or
Vehicle:
2016 WRX Limited 6MT
ISM

Default

I ran across an Ebay Post for the FF667UM unit from a 2016 Forester. There were some decent pics of the units label and rear that might help some of you that want to swap.

I am curious if the backup camera feed will be choppy on this unit as it is on the 6.2. I would love to know once you figure out how to get it working!





whiplash willy is offline   Reply With Quote
Old 05-25-2016, 05:06 PM   #49
Indian_villager
Scooby Newbie
 
Member#: 429853
Join Date: Sep 2015
Default

Where did you source the 5pin harness for the backup camera?
Indian_villager is offline   Reply With Quote
Old 05-26-2016, 02:57 AM   #50
intence01
Scooby Specialist
 
Member#: 389409
Join Date: Apr 2014
Chapter/Region: TXIC
Location: DFW
Vehicle:
2017 STI
WRB, '15 DGM WRX RIP.

Default

+1 on the 5 pin harness, is it easily available?

How's the sound quality compared to the Clarion unit?
intence01 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

All times are GMT -4. The time now is 06:42 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2018 Axivo Inc.
Copyright ©1999 - 2017, North American Subaru Impreza Owners Club, Inc.