Welcome to the North American Subaru Impreza Owners Club Thursday June 4, 2020
Home Forums Images WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Go Back   NASIOC > NASIOC Technical > FA Series Factory 2.0L Turbo Powertrain

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.







* As an Amazon Associate I earn from qualifying purchases. 
* Registered users of the site do not see these ads. 
Reply
 
Thread Tools Display Modes
Old 04-09-2020, 01:12 AM   #1
JimmysRC
Scooby Newbie
 
Member#: 501341
Join Date: May 2019
Chapter/Region: MWSOC
Vehicle:
2019 WRX
Dark gray metallic

Default Check engine light

Tonight on my way home on the expressway my WRX threw a solid check engine light and a flashing cruise control light. I got home and used my access port to read the code; itís p0420 catalyst system efficiency below threshold. Yesterday I had a shop near me install a new J pipe. I donít think they went to the stage 2 tune, and I didnít think about it until now. Any ideas what may be causing the lights? Thanks.
* Registered users of the site do not see these ads.
JimmysRC is offline   Reply With Quote
Sponsored Links
* Registered users of the site do not see these ads.
Old 04-09-2020, 01:46 AM   #2
GlarryHoodDIT
Scooby Specialist
 
Member#: 460907
Join Date: Jan 2017
Chapter/Region: RMIC
Location: Colorado
Vehicle:
2016 WRX

Default

Well, if you put an aftermarket J pipe on the stock tune it can't be anymore simple then that. You replaced an OEM cat with a junk hi-flow one and your ecu can tell the difference.
GlarryHoodDIT is offline   Reply With Quote
Old 04-09-2020, 11:56 AM   #3
gn4rwhals
Scooby Specialist
 
Member#: 453427
Join Date: Aug 2016
Chapter/Region: MWSOC
Location: Detroit, MI
Vehicle:
2017 WRX
Crystal White Pearl

Default

Make sure you meet the requirements for a Stage 2 flash.

https://cobbtuning.atlassian.net/wik...n+and+ADM+Spec

Stage2

Intake Requirements: Stock airbox and stock air filter

Exhaust Requirements:

Upgraded J-pipe with high flow catalytic converter

Upgraded cat-back exhaust (stock exhaust acceptable)

Boost Control Requirements: Deleted 2nd restrictor pill (between the tee and wastegate actuator). SEE: VA WRX Wastegate Secondary Restrictor Pill Removal

Boost Targets:

91 Octane 95 RON Minimum: ~20.5psi peak boost pressure tapering down as you approach the 6900RPM redline, +/- 1.5psi.

93 Octane 98 RON Minimum: ~20.5psi peak boost pressure tapering down as you approach the 6900RPM redline, +/- 1.5psi.
gn4rwhals is offline   Reply With Quote
Old 04-11-2020, 12:37 AM   #4
JimmysRC
Scooby Newbie
 
Member#: 501341
Join Date: May 2019
Chapter/Region: MWSOC
Vehicle:
2019 WRX
Dark gray metallic

Default

Quote:
Originally Posted by gn4rwhals View Post
Make sure you meet the requirements for a Stage 2 flash.

https://cobbtuning.atlassian.net/wik...n+and+ADM+Spec

Stage2

Intake Requirements: Stock airbox and stock air filter

Exhaust Requirements:

Upgraded J-pipe with high flow catalytic converter

Upgraded cat-back exhaust (stock exhaust acceptable)

Boost Control Requirements: Deleted 2nd restrictor pill (between the tee and wastegate actuator). SEE: VA WRX Wastegate Secondary Restrictor Pill Removal

Boost Targets:

91 Octane 95 RON Minimum: ~20.5psi peak boost pressure tapering down as you approach the 6900RPM redline, +/- 1.5psi.

93 Octane 98 RON Minimum: ~20.5psi peak boost pressure tapering down as you approach the 6900RPM redline, +/- 1.5psi.
Thanks for the info. I got the stage 2 tune on the car now and the CEL is gone. I ended up calling Cobb to make sure itís all done right.
JimmysRC is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

All times are GMT -4. The time now is 04:30 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2020 Axivo Inc.
Copyright ©1999 - 2019, North American Subaru Impreza Owners Club, Inc.

As an Amazon Associate I earn from qualifying purchases.