Welcome to the North American Subaru Impreza Owners Club Sunday June 24, 2018
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Go Back   NASIOC > NASIOC Reviews > Car Part Reviews

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads. 
Reply
 
Thread Tools Display Modes
Old 04-26-2017, 01:33 AM   #51
Whooopasss
Scooby Newbie
Member Sales Rating: (2)
 
Member#: 82677
Join Date: Mar 2005
Default

Just want to bring this back up of a long term testing . We have 1 coil fail (no spark). Coil was bought 9/15. Warranty is 1 year. I am emailing cosmo right now to get info if we can buy just 1 coil or maybe they will replace it. We put back just one OEM coil and issue was resolved.


When it was working, it was smooth on a 2002 WRX pushing [email protected] with a 20G and 820 cc injector.
* Registered users of the site do not see these ads.
Whooopasss is offline   Reply With Quote
Sponsored Links
* Registered users of the site do not see these ads.
Old 05-01-2017, 01:25 AM   #52
bmxhotsauce
Scooby Specialist
Member Sales Rating: (10)
 
Member#: 127099
Join Date: Sep 2006
Chapter/Region: BAIC
Vehicle:
02 IMPERZA WRX
BLACK

Default

Quote:
Originally Posted by Whooopasss View Post
Just want to bring this back up of a long term testing . We have 1 coil fail (no spark). Coil was bought 9/15. Warranty is 1 year. I am emailing cosmo right now to get info if we can buy just 1 coil or maybe they will replace it. We put back just one OEM coil and issue was resolved.


When it was working, it was smooth on a 2002 WRX pushing [email protected] with a 20G and 820 cc injector.


Hard to complain for the price for all 4 coils packs.. would love to hear the outcome of the warranty
bmxhotsauce is offline   Reply With Quote
Old 05-01-2017, 03:50 AM   #53
methaddict
Scooby Specialist
Member Sales Rating: (27)
 
Member#: 159738
Join Date: Sep 2007
Chapter/Region: SCIC
Location: SGV
Vehicle:
2004 WRB STi 620awhp
OFCD V3, FR TS, BW8374EFR

Default

Over a year later, these coils are still running strong @ 620 awhp / 600 ft lbs. I may buy another set as backups.
methaddict is offline   Reply With Quote
Old 05-01-2017, 05:58 PM   #54
bmxhotsauce
Scooby Specialist
Member Sales Rating: (10)
 
Member#: 127099
Join Date: Sep 2006
Chapter/Region: BAIC
Vehicle:
02 IMPERZA WRX
BLACK

Default

Quote:
Originally Posted by methaddict View Post
Over a year later, these coils are still running strong @ 620 awhp / 600 ft lbs. I may buy another set as backups.
^^^^ BAD ASSSSSS!!!!
bmxhotsauce is offline   Reply With Quote
Old 01-14-2018, 01:26 PM   #55
Jackstand Johnny
Scooby Newbie
Member Sales Rating: (0)
 
Member#: 408354
Join Date: Dec 2014
Location: Williamsburg, Virginia
Vehicle:
2002 WRX Wagon 4EAT
WRB

Default

Hi everyone and happy new year. 2002 WRX stage 2 Cobb protune here. Been running thos tune for around 12k miles. Over the Summer of 2017 I noticed a drop in boost and in turn, power. Above 4k and not quote WOT I noticed fuel cut like symptoms. I am replacing my MAF sensor today with a Denso unit off Amazon. I couldnt afford to buy new coils so Im hoping this will solve or mitigate the symptoms Ive been seeing. If it doesnt I was planning on buying these Cosmo coil packs.

Can anyone give me an update on theirs who has put more than 5k miles on them? If not could anyone please chime in at all with their experience so far? Thank you in advance.
Jackstand Johnny is offline   Reply With Quote
Old 01-14-2018, 03:25 PM   #56
AFBeefcake
Scooby Specialist
Member Sales Rating: (93)
 
Member#: 27874
Join Date: Oct 2002
Chapter/Region: NESIC
Location: Ledyard,CT
Vehicle:
2002 WRX V7 EJ207
DOM1.5 6MT 360 whp

Default

I've had mine since 6/9/15 on my v7 ej207 its my DD and I'll put like 20k on these coils. Still working just fine. I do have a 3200rpm hesitation, but it did it with the stock coils too. I believe it's a fueling ocelation issue in my apartment fuel rails going to swapped to the radium rails with dampers and custom fuel lines.
AFBeefcake is offline   Reply With Quote
Old 01-15-2018, 12:26 PM   #57
Jackstand Johnny
Scooby Newbie
Member Sales Rating: (0)
 
Member#: 408354
Join Date: Dec 2014
Location: Williamsburg, Virginia
Vehicle:
2002 WRX Wagon 4EAT
WRB

Default

hank you for that update! So I actually just got off the phone with Cosmo Racing. I read that supposedly when people had a problem with a coil goingbad, Cosmo wouldnt call them or email them back and also some people said they couldnt buy just 1 single coil. So all of that is false from my experience. First off, Cosmo called me back in less than 2 days. The person I spoke with was very polite and informative with short direct answers and didnt try to hype up their product. He also told me they always respond to emails but a lot of the time it goes 2to the spam folder. Lastly He told me if I ever neede a single coil pack out of the 1 year warranty, just to email them and they would give me a price shipped for a single coil. Easy peasy. If I need coils Ill be trying them first.
Jackstand Johnny is offline   Reply With Quote
Old 03-14-2018, 07:30 PM   #58
Ghia Nut
Scooby Newbie
Member Sales Rating: (0)
 
Member#: 201302
Join Date: Jan 2009
Chapter/Region: South East
Location: Birmingham
Vehicle:
2005 WRX Wagon
Aspen White

Default

Two years on mine and yesterday dropped cylinder number 1 with blinking cell. Changed plugs on that side and swapped coil packs around. Car started fine. Once to operating temperature the missfire code followed to number 3. Going to see about ordering another set. Could always use a spare.
Ghia Nut is offline   Reply With Quote
Old 03-19-2018, 08:48 AM   #59
eclone
Scooby Specialist
Member Sales Rating: (0)
 
Member#: 31567
Join Date: Jan 2003
Default

Was having hesitation on throttle with no CEL on my S204 swap. Swapped it out yesterday and the problem was fixed.

Long term reliability seems to be a hit or miss, but atleast I have 3 OEM spares now when/if these do go.

They look EXACTLY like the ebay Napol coil packs. Came in plain unmarked brown box, probably just like any other Made in China aftermarket replacement just with fancy red casing. Prob nothing "performance" to it, but cheap replacement packs that works.
eclone is online now   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

All times are GMT -4. The time now is 08:43 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2018 Axivo Inc.
Copyright ©1999 - 2017, North American Subaru Impreza Owners Club, Inc.