Welcome to the North American Subaru Impreza Owners Club Sunday December 17, 2017
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Go Back   NASIOC > NASIOC General > General Community

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads. 
Reply
 
Thread Tools Display Modes
Old 11-12-2017, 02:40 PM   #226
ColSubaru303
Scooby Newbie
 
Member#: 477586
Join Date: Nov 2017
Default

My 2015 impreza has been chewed on by some rodents so trying to figure out what is going on. Power steering is gone.
* Registered users of the site do not see these ads.
ColSubaru303 is offline   Reply With Quote
Sponsored Links
* Registered users of the site do not see these ads.
Old 11-13-2017, 01:23 PM   #227
LimJahey
Scooby Newbie
 
Member#: 477648
Join Date: Nov 2017
Default

Just got my built car back from being built, this morning I kept looking for the small coolant leak that only happens on cold start joys of having a brand new motor
LimJahey is offline   Reply With Quote
Old 11-13-2017, 02:31 PM   #228
tramp
Scooby Specialist
 
Member#: 459629
Join Date: Dec 2016
Chapter/Region: International
Location: Knobbley Mountain
Vehicle:
2017 WRX base
WR Blue

Default

Oil and filter.
tramp is offline   Reply With Quote
Old 11-13-2017, 04:45 PM   #229
morgandelia
Scooby Newbie
 
Member#: 477662
Join Date: Nov 2017
Location: CT
Vehicle:
2013 Impreza
Burgundy

Default

Today I brought my impreza to get a car wash!
morgandelia is offline   Reply With Quote
Old 11-13-2017, 05:32 PM   #230
TEKNOSYS
Scooby Newbie
 
Member#: 79839
Join Date: Jan 2005
Chapter/Region: South East
Location: Boynton Beach, FL
Vehicle:
2004 WRX Premium
Sedan; Aspen White

Default

Timing Belt!!!
TEKNOSYS is offline   Reply With Quote
Old 11-15-2017, 06:54 PM   #231
Gel Mibson
Scooby Newbie
 
Member#: 219009
Join Date: Jul 2009
Chapter/Region: Tri-State
Location: NJ
Vehicle:
2018 LBP WRX Ltd.
2005 PSM WRX - St.2 (rip)

Default

perrin shift stop + custom red raceseng shift knob



Gel Mibson is offline   Reply With Quote
Old 11-20-2017, 03:38 AM   #232
robschilke
Scooby Newbie
 
Member#: 397553
Join Date: Jul 2014
Chapter/Region: NWIC
Location: Seattle, WA
Vehicle:
2014 GR8 DGM
Subaru Ambassador

Default


Deleted the chrome badges from my GR8 today. Later, I removed the OEM silver/red fender badges and replaced them with black/red badges.
robschilke is offline   Reply With Quote
Old 11-20-2017, 10:44 AM   #233
RC Pilot
Scooby Newbie
 
Member#: 459411
Join Date: Dec 2016
Default

Used it to tote the utility trailer over to a friends house so she could use it.

RC Pilot is offline   Reply With Quote
Old 11-20-2017, 10:48 AM   #234
Raikkonen-F1
Scooby Newbie
 
Member#: 411992
Join Date: Jan 2015
Chapter/Region: Tri-State
Vehicle:
2018 WRX STi
ISM

Default

Sold the '15 WRX and got an '18 STi
Raikkonen-F1 is offline   Reply With Quote
Old 11-20-2017, 03:56 PM   #235
Wifeismad
Scooby Newbie
 
Member#: 473263
Join Date: Aug 2017
Chapter/Region: NESIC
Location: Maine
Vehicle:
2011 WRX
SWP

Default Coolant leak!!

2011 WRX. This was technically yesterday. Panicked a bit because I found coolant on the ground under the car . After jacking it up and removing the under tray I traced it to the Mishimoto Radiator drain plug that was covered in dried coolant...and some wet. Turns out it was about 3 turns from being finger tight. It's aluminum so I used a socket that fit and grip tightened it. Will check on that every oil change from now on for sure. Then I cleaned up the mess that was everywhere, not too bad. Filled the Coolant reservoir back to the middle of full and empty.

Thankfully the head gaskets looks dry as can be.
Wifeismad is offline   Reply With Quote
Old 11-20-2017, 06:12 PM   #236
klaas
Scooby Newbie
 
Member#: 336000
Join Date: Oct 2012
Chapter/Region: International
Location: Denmark
Vehicle:
2005 Impreza STi
WRB

Default

Pulled knock sensor after a P0327 cel.
Did a resistance test and it was correct as per the FSM. Cleaned all contacts including bottom of the sensor and engine block.
So far so good, no more cel, fingers crossed.
klaas is offline   Reply With Quote
Old 12-06-2017, 05:59 PM   #237
robschilke
Scooby Newbie
 
Member#: 397553
Join Date: Jul 2014
Chapter/Region: NWIC
Location: Seattle, WA
Vehicle:
2014 GR8 DGM
Subaru Ambassador

Default



Recently had my wheels stolen (On Thanksgiving of all days - and no, I didn't have wheel locks. Lesson learned) from my 2014 GR8.

I found someone that was selling his 2015–2017 Limited STI wheels wrapped in Continental Winter Contact SIs and reached out. After mocking them up on my car (possibly painting these black later), I decided to pull the trigger.

Last edited by robschilke; 12-06-2017 at 06:19 PM.
robschilke is offline   Reply With Quote
Old 12-06-2017, 09:09 PM   #238
m3incorp
Scooby Newbie
 
Member#: 478467
Join Date: Nov 2017
Chapter/Region: RMIC
Location: Colorado
Vehicle:
2018 WRX
Charcoal Gray

Default

Bought Upgraded Kicker door speakers and tweeters, Soundstream TN1.2000D Amplifier, NVXXPLOC4, NVXXPLOC2, and Kicker 43VCWR122 12" Loaded Subwoofer Enclosure.
m3incorp is offline   Reply With Quote
Old 12-10-2017, 05:46 PM   #239
Blitzblue17
Scooby Newbie
 
Member#: 429646
Join Date: Sep 2015
Default

Painted my fender badge and installed my rear splats.
Waiting for my side skirts and Rear fog light to come in the mail next week.
Blitzblue17 is offline   Reply With Quote
Old 12-10-2017, 07:10 PM   #240
EngineHacker
Scooby Newbie
 
Member#: 462060
Join Date: Jan 2017
Location: Along the eastern seaboard.
Vehicle:
2099 WRX STI Pro
Transperent

Default

Replaced high beams and fog bulbs with a set of high end LED bulbs.
EngineHacker is offline   Reply With Quote
Old 12-10-2017, 10:13 PM   #241
eyekyu
Scooby Newbie
 
Member#: 183670
Join Date: Jul 2008
Chapter/Region: SWIC
Location: Reno
Vehicle:
2002 Bugeye
PSM

Default

Fixed a coolant leak in the upper radior hose, the hose clamp keeps coming lose. Not sure if there is any better clamps then the worm gear ones.
If anyone knows of any better one or has had success with other types, please let me know.
eyekyu is offline   Reply With Quote
Old 12-10-2017, 11:20 PM   #242
monkeyposeur
Scooby Specialist
 
Member#: 333468
Join Date: Sep 2012
Chapter/Region: RMIC
Location: SLC, UT
Vehicle:
1993 SS
03 WRB GD 205/22T 20G-XT

Default

My 93 Turbo legacy was accelerating on it's own without pressing the gas pedal. My wife called me and told me the car was possessed. She had to use the brakes to keep it from going too fast and had a scary time getting it home with our two dogs.

In park it would idle up to 5k and keep climbing. I thought it was probably a bad IACV so I dismantled the airbox and removed the 90* elbow to get at it. When I was removing the PCV hose the F-tube cracked. It is the only old OEM PCV line I had left on the car. I knew then that my day was about to get longer and more complicated fabricating a new one.

I then had to partially dismantle the turbo to have enough room to get at the crankcase breather and even then it took me a good hour to get the stupid hose off.

The IACV wasn't too sticky but I cleaned it with carb cleaner. I hit up the auto parts store and used some 3/4" silicone hose and a reducer hose to use up the remnants of the f-tube. I replaced the top of the IACV (I have three spare IACVs) for good measure.

While hooking everything back up and still at a loss for why the car was acting funny I discovered that the TPS wiring was all cracked and twisted allowing the wires to short out! I taped up the cracks and marine grade heat shrinked the wires. Put everything back together and the car is running flawlessly again!

Super cold out today but I'm glad I got it fixed and running again.

monkeyposeur is offline   Reply With Quote
Old 12-11-2017, 05:57 PM   #243
synfrag
Scooby Newbie
 
Member#: 427103
Join Date: Aug 2015
Location: Denver, CO
Vehicle:
2015 WRX
Dark Gray

Default Pulled the Crumpled Bumper Off!

Got a hit and run parked overnight a few weeks ago. Car has been parked for ... reasons. Anyway, finally getting around to further inspect damages and today spent about 2 hours pulling the bumper off.

synfrag is offline   Reply With Quote
Old 12-12-2017, 05:15 PM   #244
cerbomark
Scooby Newbie
 
Member#: 475983
Join Date: Oct 2017
Location: Upstate NY
Vehicle:
2018
Silver

Default

cerbomark is online now   Reply With Quote
Old 12-12-2017, 05:18 PM   #245
cerbomark
Scooby Newbie
 
Member#: 475983
Join Date: Oct 2017
Location: Upstate NY
Vehicle:
2018
Silver

Default



I did put on Rokblokz mud flaps this week.
cerbomark is online now   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

All times are GMT -4. The time now is 09:16 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2017 Axivo Inc.
Copyright ©1999 - 2017, North American Subaru Impreza Owners Club, Inc.