Welcome to the North American Subaru Impreza Owners Club Wednesday March 20, 2019
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Go Back   NASIOC > NASIOC Technical > Subaru Conversions

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads. 
Reply
 
Thread Tools Display Modes
Old 04-19-2003, 12:45 AM   #1
grantn
Scooby Newbie
 
Member#: 25398
Join Date: Sep 2002
Location: Los Angeles, CA
Vehicle:
2005 STi
WRB

Default Need Help

i changed the headers, up and down pipes and stealth back and the car seems to be making more noise than it should. additionally, i dont think the turbo kicks in because the car has lost a lot of power. also there is some smoke and smell coming from the turbo and no CEL.

PS: GT-Spec Headers and uppipe, TurboX Stealthback, OEM muffler.
* Registered users of the site do not see these ads.
grantn is offline   Reply With Quote
Sponsored Links
* Registered users of the site do not see these ads.
Old 04-19-2003, 12:52 AM   #2
Ver.III
Scooby Specialist
 
Member#: 1185
Join Date: Mar 2000
Location: North of the border
Vehicle:
I flap my gums
and now I'm a specialist

Default

The smell and smoke is prolly because it is new and is burning off the residue oil or paint. It should go away is a short time, should. Headers do make the low end punch not as hard, but the power band is more linear and you can rev past 6500rpm without the power dropping off. The oem muffler is a bit restrictive considering you are running a free flow up front. Also, you may have to reset the ecu. It has to learn all over again since you modded the engine. I have the Maxim headers and my car did the same thing.
Ver.III is offline   Reply With Quote
Old 04-19-2003, 01:33 AM   #3
slim speedy
Scooby Specialist
 
Member#: 2254
Join Date: Sep 2000
Chapter/Region: MAIC
Location: Chantilly, VA
Vehicle:
1992 Sentra SE-R
1999 Infiniti G20

Default

Sounds like a leak in the uppipe to me.
slim speedy is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Need Help, Need Help nicholas112481 Factory 2.5L Turbo Powertrain (EJ Series Factory 2.5L Turbo) 8 11-10-2010 01:24 PM
Need help!! Need to find a +12v switched wire NOW! Please help! nxwrxfx Electrical & Lighting 16 04-25-2006 05:29 PM
Hard Drive Recover Help much needed... ATA RAID 0 knowledge needed HELP PLEASE!!! 2k2 Off-Topic 63 12-24-2003 10:35 PM
Need help! Perrin Fuel rails installed but I need help with Fuel Evap Line STR8OUT Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo) 7 04-18-2003 12:11 PM
Need help!Need flywheel bulletin from SOA.Please help. RallyeX General Forum Archive 3 06-01-2000 07:57 AM

All times are GMT -4. The time now is 01:11 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2019 Axivo Inc.
Copyright ©1999 - 2017, North American Subaru Impreza Owners Club, Inc.