Welcome to the North American Subaru Impreza Owners Club Wednesday March 20, 2019
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Go Back   NASIOC > NASIOC General > General Community

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads. 
Reply
 
Thread Tools Display Modes
Old 02-10-2019, 09:37 PM   #1
kenshapiro2002
Scooby Newbie
 
Member#: 346708
Join Date: Feb 2013
Location: Bawlmer, MD
Default Trans Noise Due to New Mount?

Just had a new clutch , pressure plate and flywheel installed (Ď05 Saabaru).The trans mount was toast and they installed a heavy duty, ďSTI typeĒ one. Now, when I go off throttle, thereís this noise at around 2,500-3,500 that sounds like rain being tossed up into the wheel well. The guru at my shop says itís gear lash... a normal noisy gear box thatís now amplified by a much more solid trans mount... the gear noise is now transmitted into the unibody. They even offered to install a stock type mount if I canít take the sound. Make sense to yaíll?
* Registered users of the site do not see these ads.
kenshapiro2002 is offline   Reply With Quote
Sponsored Links
* Registered users of the site do not see these ads.
Old 02-10-2019, 10:45 PM   #2
Anthony18WRX
Scooby Newbie
 
Member#: 491570
Join Date: Sep 2018
Chapter/Region: RMIC
Vehicle:
2018 Subaru WRX
CBS

Default

Quote:
Originally Posted by kenshapiro2002 View Post
Just had a new clutch , pressure plate and flywheel installed (Ď05 Saabaru).The trans mount was toast and they installed a heavy duty, ďSTI typeĒ one. Now, when I go off throttle, thereís this noise at around 2,500-3,500 that sounds like rain being tossed up into the wheel well. The guru at my shop says itís gear lash... a normal noisy gear box thatís now amplified by a much more solid trans mount... the gear noise is now transmitted into the unibody. They even offered to install a stock type mount if I canít take the sound. Make sense to yaíll?
Yup. I just installed the Group N STI transmission mount not to long ago in my 18 WRX. It whines 1-3 gear the most between 2k-3k RPM. That's a normal sound to expect with a more solid mount.
Anthony18WRX is offline   Reply With Quote
Old 02-11-2019, 12:39 AM   #3
subarumod
Scooby Newbie
 
Member#: 468745
Join Date: Jun 2017
Location: SoCAL
Vehicle:
06 wrx
black as your girls soul.

Default

It goes away in time.
subarumod is offline   Reply With Quote
Old 02-11-2019, 09:30 AM   #4
kenshapiro2002
Scooby Newbie
 
Member#: 346708
Join Date: Feb 2013
Location: Bawlmer, MD
Default

Quote:
Originally Posted by subarumod View Post
It goes away in time.
As will you and I
kenshapiro2002 is offline   Reply With Quote
Old 02-17-2019, 06:53 PM   #5
Shik
NASIOC Supporter
 
Member#: 132
Join Date: Jul 1999
Chapter/Region: Tri-State
Location: PA
Vehicle:
2006 GT Ltd 5spd sdn
'15 WRX 6spd CWP, '02 WRX

Default

Quote:
Originally Posted by subarumod View Post
It goes away in time.
Maybe you get used to the sound, but it won't go away. At least, it never did in any of my Subarus, but I dig the sound so I don't mind.
Shik is offline   Reply With Quote
Old 02-17-2019, 07:05 PM   #6
kenshapiro2002
Scooby Newbie
 
Member#: 346708
Join Date: Feb 2013
Location: Bawlmer, MD
Default

Itís also doing it at very low speeds... I donít want to go back to a stock trans mount because the shifting is so much more precise but I find myself staying on light throttle instead of full lift off to kill the noise. Not digging the sound yet at all. 😂
kenshapiro2002 is offline   Reply With Quote
Old 02-17-2019, 09:24 PM   #7
SubRepairNPerform
Scooby Newbie
 
Member#: 490702
Join Date: Aug 2018
Default

Our transmissions are very loud. I work for Subaru. It is a very common issue with people having complaints of noises, all those cars had in common were aftermarket transmission mounts
SubRepairNPerform is offline   Reply With Quote
Old 02-17-2019, 09:42 PM   #8
kenshapiro2002
Scooby Newbie
 
Member#: 346708
Join Date: Feb 2013
Location: Bawlmer, MD
Default

Mine is a 2005 Saab 9-2x Aero. My stock mount was toast. The garage (IAG) installed an OEM STI mount. I also have N-Group motor mounts.
kenshapiro2002 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

All times are GMT -4. The time now is 07:02 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2019 Axivo Inc.
Copyright ©1999 - 2017, North American Subaru Impreza Owners Club, Inc.