Welcome to the North American Subaru Impreza Owners Club Monday December 11, 2017
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Go Back   NASIOC > NASIOC General > Newbies & FAQs

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads. 
Reply
 
Thread Tools Display Modes
Old 12-15-2009, 05:50 PM   #1
Joebrauk
Scooby Newbie
 
Member#: 230546
Join Date: Nov 2009
Chapter/Region: NESIC
Location: NH
Vehicle:
2004 WRX Sport Wagon
PSM

Default So the car I bought doesn't have the original engine.

I just got an 04 WRX wagon with 73k on it. I took it to my local Subaru mechanic and he said it was a good car, so I bought it.

Recently I have noticed that the exhaust is just welded together and the coolant hoses were spliced, I went back to talk to the mechanic and he said believes that the engine is not the original, I'm hoping that they did the swap properly, and it was not a rushed job.
is there anything I should check to make sure?
* Registered users of the site do not see these ads.
Joebrauk is offline   Reply With Quote
Sponsored Links
* Registered users of the site do not see these ads.
Old 12-15-2009, 06:17 PM   #2
xANDRESx
Scooby Newbie
 
Member#: 178979
Join Date: May 2008
Default

go under the intake maniful.. and try to see the number that the motor has...
xANDRESx is offline   Reply With Quote
Old 12-15-2009, 09:37 PM   #3
kasra007
Scooby Specialist
 
Member#: 225361
Join Date: Sep 2009
Chapter/Region: MAIC
Location: ashburn, va
Vehicle:
2006 wrx sti
beige

Default

Quote:
Originally Posted by Joebrauk View Post
I just got an 04 WRX wagon with 73k on it. I took it to my local Subaru mechanic and he said it was a good car, so I bought it.

Recently I have noticed that the exhaust is just welded together and the coolant hoses were spliced, I went back to talk to the mechanic and he said believes that the engine is not the original, I'm hoping that they did the swap properly, and it was not a rushed job.
is there anything I should check to make sure?

did this from the dealer or a private party? if dealer.. they should be able to tell you what swap it was. if it was a private party, just ask him.
kasra007 is offline   Reply With Quote
Old 12-16-2009, 02:52 AM   #4
theprodgalson
Scooby Specialist
 
Member#: 181054
Join Date: May 2008
Location: Fres-Yes
Vehicle:
06 WRX wagon
Obsidian Black Pearl

Default

you went back to the same mechanic that clearly didn't look to close at the car in the first place?
theprodgalson is offline   Reply With Quote
Old 12-16-2009, 04:11 PM   #5
Joebrauk
Scooby Newbie
 
Member#: 230546
Join Date: Nov 2009
Chapter/Region: NESIC
Location: NH
Vehicle:
2004 WRX Sport Wagon
PSM

Default

kasra
It was a small dealer, he didn't know.

The mechanic that looked at it knew all along, it was his boss who told me that it was good. I brought it back there to get a cel checked and talked to the guy who actually did the inspection. He informed me of the situation after I bought the car.

He said it looks good, but he was just worried about what was done when the put the engine in. I'm just pissed because the cel is for the cat, but since the exhaust was welded its not covered under warranty anymore.
Joebrauk is offline   Reply With Quote
Old 12-16-2009, 04:14 PM   #6
the suicidal eggroll
Scooby Guru
 
Member#: 51961
Join Date: Jan 2004
Chapter/Region: RMIC
Location: Broomfield, CO
Vehicle:
2005 STi
2012 WRX

Default

How long did you have the car before the CEL for the cat came on?
Does the car have a cat?
the suicidal eggroll is offline   Reply With Quote
Old 12-16-2009, 04:31 PM   #7
hdempsey
Scooby Specialist
 
Member#: 126374
Join Date: Sep 2006
Location: Oklahoma
Vehicle:
2001 Impreza 2.5RS
Pure Aspen White

Default

edit.
hdempsey is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Doesn't have the same ring to it. Dogbert2 Off-Topic 7 11-15-2007 01:01 PM
Am I the only one that doesn't have an iPod-like device? beachbum Off-Topic 72 12-15-2006 11:37 PM
WRX doesn't have the PEP it should, maybe? Electronic probs? Asinine Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo) 2 06-21-2004 12:33 PM
ECU for MT 02 WRX that doesn't have the cam position sensor problem SW00P_G Private 'Wanted' Classifieds 3 07-30-2003 12:29 PM
SOA STILL doesn't have the XT on their website gavin Forester Forum 3 06-25-2003 07:32 PM

All times are GMT -4. The time now is 04:12 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2017 Axivo Inc.
Copyright ©1999 - 2017, North American Subaru Impreza Owners Club, Inc.