Welcome to the North American Subaru Impreza Owners Club Tuesday March 20, 2018
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
Go Back   NASIOC > NASIOC Technical > Pre-2002 Factory Turbo Powertrain

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads. 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
Old 07-12-2012, 08:27 PM   #1
Scooby Newbie
Member#: 325644
Join Date: Jul 2012
Location: south west colorado
1992 legacy

Default 1992 legacy no spark

bought a 1992 subaru legacy turbo wagon with the 2.2. and this thing wont start unless you leave it sit a long time. replaced coil ign module plugs wires and still no spark. could it be the timing belt that jump or crank position sensor. it have 1200 in this car and it has only 103,000 on it

Last edited by turbo970; 07-12-2012 at 08:57 PM. Reason: typo
turbo970 is offline   Reply With Quote

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

All times are GMT -4. The time now is 03:30 PM.

Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2018 Axivo Inc.
Copyright ©1999 - 2017, North American Subaru Impreza Owners Club, Inc.