Welcome to the North American Subaru Impreza Owners Club Monday December 17, 2018
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Go Back   NASIOC > NASIOC General > Car Audio, Video & Security

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads. 
Reply
 
Thread Tools Display Modes
Old 06-29-2018, 02:50 AM   #1
Ericsbible
Scooby Newbie
 
Member#: 487610
Join Date: Jun 2018
Default Hella horn install FAIL

So about a month ago I got Hella Horns for my birthday. These only came with the relay but no harness. I tried making my harness but whenever I plugged it in it didnít work at all. So I scraped it and tried putting back on the OEM horn and then THAT didnít work. I tried cutting the plug in and seeing if that was the issue and it still didnít work. So now I have hella horns that donít work and only one horn that works. The one that works though is on the side of the car and has a different plug in which seems as no one makes a harness for that one. Any ideas?
* Registered users of the site do not see these ads.
Ericsbible is offline   Reply With Quote
Sponsored Links
* Registered users of the site do not see these ads.
Old 06-29-2018, 07:56 AM   #2
RIWRXer
Scooby Newbie
 
Member#: 481523
Join Date: Feb 2018
Location: Rhode Island
Vehicle:
2017 WRX Limited
Lapis Blue

Default

Try checking out the premade harnesses from SubiMods or Grimmspeed..... plug-n-play, my friend.
RIWRXer is online now   Reply With Quote
Old 06-29-2018, 09:38 AM   #3
standardtranny
Scooby Specialist
 
Member#: 450713
Join Date: Jul 2016
Chapter/Region: Tri-State
Location: Super bowl LII champs
Vehicle:
2017 WRX Stage 2
world rally blue

Default

just splice the Hella horns into the wires for the OEM horn in the middle of the lower grill. The relay isn't needed
standardtranny is offline   Reply With Quote
Old 06-29-2018, 12:04 PM   #4
Ericsbible
Scooby Newbie
 
Member#: 487610
Join Date: Jun 2018
Default

Quote:
Originally Posted by standardtranny View Post
just splice the Hella horns into the wires for the OEM horn in the middle of the lower grill. The relay isn't needed


The thing is, when I tried plugging back in the OEM Horn it didnít work.
Ericsbible is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

All times are GMT -4. The time now is 08:51 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2018 Axivo Inc.
Copyright ©1999 - 2017, North American Subaru Impreza Owners Club, Inc.