Welcome to the North American Subaru Impreza Owners Club Wednesday December 12, 2018
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Go Back   NASIOC > NASIOC General > Car Audio, Video & Security

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads. 
Reply
 
Thread Tools Display Modes
Old 01-09-2014, 09:42 AM   #101
MedicaeVal
Scooby Newbie
 
Member#: 378187
Join Date: Jan 2014
Location: Chapel Hill, NC
Vehicle:
2014 Impreza WRX
Blue

Default

Great guide! Thanks for the pics.
* Registered users of the site do not see these ads.
MedicaeVal is offline   Reply With Quote
Sponsored Links
* Registered users of the site do not see these ads.
Old 01-10-2014, 12:12 AM   #102
BMAN130
Scooby Newbie
 
Member#: 345020
Join Date: Jan 2013
Chapter/Region: Tri-State
Location: Hempstead NY
Vehicle:
2014 STI
WRB

Default

Subdddd
BMAN130 is offline   Reply With Quote
Old 01-12-2014, 05:05 PM   #103
CowboyD Eng6ine
Scooby Newbie
 
Member#: 365893
Join Date: Aug 2013
Chapter/Region: MAIC
Location: Motown, Delaware
Vehicle:
2013 F150 FX4

Default

Great write up, it helped me a lot with wiring stuff up and finding all the parts I needed. Came out pretty well. Only thing I can't figure is the on and off phone hook buttons from the steering controls.

CowboyD Eng6ine is offline   Reply With Quote
Old 01-13-2014, 12:47 AM   #104
Scooby06doo
Scooby Newbie
 
Member#: 378550
Join Date: Jan 2014
Location: PA
Vehicle:
2006 STI
OB

Default

i installed this exact same H/U in my G35.... took about 8 hours including figuring out which oem wires went to which wires on the bose adapter, and the steering wheel adapter programming.... it was a PITA... well worth it though... i have an 06 so i dont have steering wheel controls.... question, my car came with some cheap kenwood DD already in it.. i wanna switch to the x5500bhs... i can just buy the head unit and be good to go, correct? it already plays dvds in motion so i know the parking bypass in installed already... i just wasnt sure if there was a harness i could get that is plug and play. or if there were any other adapters i would need.... i dont mind doing all the stripping and soldering, cuz thats the easy part
Scooby06doo is offline   Reply With Quote
Old 03-30-2014, 02:13 PM   #105
a10495
Scooby Newbie
 
Member#: 382147
Join Date: Feb 2014
Location: San Jose, CA
Vehicle:
2014 WRX
DGM

Default

subbed into this!New hear and definitely want to change the factory HU to the avh x4600bt
a10495 is offline   Reply With Quote
Old 04-11-2014, 06:18 AM   #106
tacmedic357
Scooby Newbie
 
Member#: 363645
Join Date: Jul 2013
Location: suffolk, long island
Vehicle:
2011 impreza WRX
silver

Unhappy aswc

i did the auto detect and its using my bluetooth as the volume up and down i tried manually programming it and it won't register my actual volume controls but it will register my mode on the steering wheel..... any help?
tacmedic357 is offline   Reply With Quote
Old 04-11-2014, 08:05 AM   #107
Scooby06doo
Scooby Newbie
 
Member#: 378550
Join Date: Jan 2014
Location: PA
Vehicle:
2006 STI
OB

Default

Quote:
Originally Posted by tacmedic357 View Post
i did the auto detect and its using my bluetooth as the volume up and down i tried manually programming it and it won't register my actual volume controls but it will register my mode on the steering wheel..... any help?
I know you can update the black box for the steering wheel controls for newer vehicles but it takes a special wire to hook to a computer
Scooby06doo is offline   Reply With Quote
Old 04-20-2014, 11:56 AM   #108
CowboyD Eng6ine
Scooby Newbie
 
Member#: 365893
Join Date: Aug 2013
Chapter/Region: MAIC
Location: Motown, Delaware
Vehicle:
2013 F150 FX4

Default

Is there an adapter cord for a Galaxy S5 like there is for the iPhones for this unit? Just switched from a iPhone 4S to a Galaxy S5 and am using just BT. New to Android so I dunno what actually works.
CowboyD Eng6ine is offline   Reply With Quote
Old 04-20-2014, 01:10 PM   #109
Scooby06doo
Scooby Newbie
 
Member#: 378550
Join Date: Jan 2014
Location: PA
Vehicle:
2006 STI
OB

Default

Quote:
Originally Posted by CowboyD Eng6ine View Post
Is there an adapter cord for a Galaxy S5 like there is for the iPhones for this unit? Just switched from a iPhone 4S to a Galaxy S5 and am using just BT. New to Android so I dunno what actually works.
Only your contact list syncs with the head unit for android. Can't see music or anything
Scooby06doo is offline   Reply With Quote
Old 04-21-2014, 02:37 PM   #110
evilspoons
Scooby Specialist
 
Member#: 321311
Join Date: May 2012
Location: Edmonton, AB
Vehicle:
2012 STi 5-door
World Rally Blue

Default

Android phones typically use Bluetooth for everything head unit related - the iPhone has a specialized protocol for talking over its USB connector (dock/lightning port) while Android devices do not... since Bluetooth can do it already.
evilspoons is offline   Reply With Quote
Old 04-21-2014, 08:04 PM   #111
GReddy5
Scooby Newbie
 
Member#: 24071
Join Date: Sep 2002
Chapter/Region: SCIC
Location: San Diego, CA
Vehicle:
2011 WRX Hatchback
Satan White Pearl

Default

Quote:
Originally Posted by CowboyD Eng6ine View Post
Is there an adapter cord for a Galaxy S5 like there is for the iPhones for this unit? Just switched from a iPhone 4S to a Galaxy S5 and am using just BT. New to Android so I dunno what actually works.
I have the samsung MHL adaptor plugged into my deck. I use a Galaxy S4. I did this instead of buying the pioneer CD-AH200C adapter.

With this MHL adapter, i can use the "Pandora" input on the deck and also I can mirror my phone screen onto the deck. If you mirror the phone screen to the deck, you will not be able to use the deck touchscreen to control the phone. I use it mainly for google maps.

http://www.samsung.com/us/mobile/cel...ET-H10FAUWESTA
GReddy5 is offline   Reply With Quote
Old 04-21-2014, 08:58 PM   #112
Scooby06doo
Scooby Newbie
 
Member#: 378550
Join Date: Jan 2014
Location: PA
Vehicle:
2006 STI
OB

Default

Quote:
Originally Posted by GReddy5 View Post

I have the samsung MHL adaptor plugged into my deck. I use a Galaxy S4. I did this instead of buying the pioneer CD-AH200C adapter.

With this MHL adapter, i can use the "Pandora" input on the deck and also I can mirror my phone screen onto the deck. If you mirror the phone screen to the deck, you will not be able to use the deck touchscreen to control the phone. I use it mainly for google maps.

http://www.samsung.com/us/mobile/cel...ET-H10FAUWESTA
That's good to know. Cheap navigation. I am doing this when I get my 5600bhs.
Scooby06doo is offline   Reply With Quote
Old 05-24-2014, 06:07 PM   #113
ggixxer599
Scooby Newbie
 
Member#: 126991
Join Date: Sep 2006
Chapter/Region: TXIC
Location: Northpark Dallas, TX
Vehicle:
2002 Impreza WRX
OBP

Default

I am having an issue with not having Sub control on my deck... I cannot turn it on/off at the deck? Its really bugging me. Any thoughts??
ggixxer599 is offline   Reply With Quote
Old 05-24-2014, 06:18 PM   #114
mezdup
Scooby Newbie
 
Member#: 384257
Join Date: Mar 2014
Chapter/Region: Tri-State
Location: Long Island, NY
Vehicle:
2014 ISM WRX Sedan

Default

Quote:
Originally Posted by foolycooly View Post
The largest junction is a 5-way ground tie between all of the various components:

can someone do me a huge favor and list the 5 wires in this ground? i'm doing it now and i'm only coming up with 4: the 2 harnesses, the swc and the bypass.
mezdup is offline   Reply With Quote
Old 05-24-2014, 06:25 PM   #115
ggixxer599
Scooby Newbie
 
Member#: 126991
Join Date: Sep 2006
Chapter/Region: TXIC
Location: Northpark Dallas, TX
Vehicle:
2002 Impreza WRX
OBP

Default

there should be 3 from the 2 harness' check this link out

http://ae64.com/aswc-install.htm
ggixxer599 is offline   Reply With Quote
Old 05-24-2014, 08:41 PM   #116
mezdup
Scooby Newbie
 
Member#: 384257
Join Date: Mar 2014
Chapter/Region: Tri-State
Location: Long Island, NY
Vehicle:
2014 ISM WRX Sedan

Default

Quote:
Originally Posted by ggixxer599 View Post
there should be 3 from the 2 harness' check this link out

http://ae64.com/aswc-install.htm
Thanks man figured it out. It's because I'm using the idatalink maestro sw instead of the axxess. They're wired a bit differently as the maestro has a wire that goes to the brown black on pin 14 of the svxdc harness
mezdup is offline   Reply With Quote
Old 05-27-2014, 07:51 AM   #117
Kontrl
Scooby Newbie
 
Member#: 391939
Join Date: May 2014
Default

Very Clean setup, great work!
Kontrl is offline   Reply With Quote
Old 05-28-2014, 07:08 PM   #118
Dwilly58
Scooby Newbie
 
Member#: 341570
Join Date: Dec 2012
Chapter/Region: MWSOC
Location: Kansas
Vehicle:
2013 STi GVB
DGM

Default

How do you hook up the MHL adaptor to the deck without a hdmi jack?

Quote:
Originally Posted by GReddy5 View Post
I have the samsung MHL adaptor plugged into my deck. I use a Galaxy S4. I did this instead of buying the pioneer CD-AH200C adapter.

With this MHL adapter, i can use the "Pandora" input on the deck and also I can mirror my phone screen onto the deck. If you mirror the phone screen to the deck, you will not be able to use the deck touchscreen to control the phone. I use it mainly for google maps.

http://www.samsung.com/us/mobile/cel...ET-H10FAUWESTA
Dwilly58 is offline   Reply With Quote
Old 05-28-2014, 07:57 PM   #119
GReddy5
Scooby Newbie
 
Member#: 24071
Join Date: Sep 2002
Chapter/Region: SCIC
Location: San Diego, CA
Vehicle:
2011 WRX Hatchback
Satan White Pearl

Default

Quote:
Originally Posted by Dwilly58 View Post
How do you hook up the MHL adaptor to the deck without a hdmi jack?
Sorry...I meant i have the AVHX8500BHS.
GReddy5 is offline   Reply With Quote
Old 06-02-2014, 10:32 AM   #120
SubiRex89
Scooby Newbie
 
Member#: 386955
Join Date: Apr 2014
Chapter/Region: South East
Vehicle:
2013 Impreza hatch w
satin white

Default

Quote:
Originally Posted by foolycooly View Post
I am really enjoying the unit after a few days of my commute. I played down the HD radio in my OP, but it really is a pretty amazing difference compared to the stock unit. I listen to mostly sports/talk radio during my morning drive and everything comes in much clearer. When it's in full digital/HD I would say the radio music is on par with BT-audio before.

BT audio is much more powerful and clean now. I could see how adding a sub would enhance it further by taking some of the bass out of the speakers, but it really is much improved over the stock unit.

Also, startup is very quick. The unit is fully functional within 5 seconds of turning the key. It takes an additional 5-10 seconds to pair to my iphone 5 (about equivalent to the stock unit).

The only minor annoyance is the seek vs. track thing on the steering controls. I left it on BT audio skip since I use that more frequently. I have to manually change radio presets (but I only do that 2-3 times during my morning commute).
I have been shopping head units for my 13' hatch. I am torn between the 4000nex and the AVH 5600BHS. I am mainly interested in siri hands free. Does your radio have this? Does it work with google maps? The nex is about 300$ more and dosnt have many more features. If the 5600 has siri free and works well with the steering wheel control, it will work fine.
SubiRex89 is offline   Reply With Quote
Old 01-17-2015, 01:31 PM   #121
w8lifter21
Scooby Newbie
 
Member#: 156732
Join Date: Aug 2007
Default

Great write up op! I know it's an older thread but thought I'd share my results. I used his thread as a refresher as its been a while since I've done SWC on a Subie. Just got through installing a 2700bs in a 2011 wrx(BT no nav) with the Axxess ASWC on 3.20 firmware and made the connections below in this order:

Green/orange-->brown(in car)
Black/green-->blue/white(in car)
Grounded yellow(in car)
Red-->red on Pioneer
Black-->black on pioneer

Plugged the 3.5mm in, turned the ignition on and the module auto recognized all the controls(presets change as well and not "seek") for audio as well as bluetooth.
w8lifter21 is offline   Reply With Quote
Old 12-08-2016, 05:00 PM   #122
voyagerman
Scooby Newbie
 
Member#: 42133
Join Date: Aug 2003
Chapter/Region: PRSIC
Location: Ciales,Puerto Rico
Vehicle:
2002 Impreza WRX
Rally Blue Pearl

Default

I have a Pioneer AVH-X2800 BS in My WRX and my radio show artist picture with great details and have a great and beautiful graphic animation.
voyagerman is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

All times are GMT -4. The time now is 05:23 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2018 Axivo Inc.
Copyright ©1999 - 2017, North American Subaru Impreza Owners Club, Inc.