Welcome to the North American Subaru Impreza Owners Club Monday December 17, 2018
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Go Back   NASIOC > NASIOC General > Newbies & FAQs

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads. 
Reply
 
Thread Tools Display Modes
Old 12-02-2018, 07:32 PM   #1
GosuWRX
Scooby Newbie
 
Member#: 494095
Join Date: Nov 2018
Vehicle:
2014 WRX Hatch
Satin White pearl

Default Water leak whenever turning AC on (passenger side)

Hey guys, so I bought my first Subie (2014 WRX Hatchback) about a month ago. However, what I've been noticing is a leak whenever the AC is turned on, this leak varies but recently I've been starting to notice it get a little worse. From where the red box is, there is a wire hanging out of the area where a screw is missing and the head of the cable is brown. Can anyone give me guidance as to what this is? It seems like the previous owner just chopped up a bunch of things on the passenger side.

* Registered users of the site do not see these ads.
GosuWRX is offline   Reply With Quote
Sponsored Links
* Registered users of the site do not see these ads.
Old 12-02-2018, 09:26 PM   #2
oichan
Scooby Newbie
 
Member#: 492327
Join Date: Oct 2018
Location: A garage in the Midwest
Vehicle:
2019 WRX / 16 STI
2017 Golf-R, etc

Default

I don't know the answer to your question, but have you checked whether the drain hose for the evaporator under the car is blocked or not?
oichan is offline   Reply With Quote
Old 12-02-2018, 10:01 PM   #3
jasonwrx86
Scooby Newbie
 
Member#: 472037
Join Date: Jul 2017
Chapter/Region: MWSOC
Vehicle:
2018 WRX Limited
CWP

Default

Drain hose is clogged. Do you see water dripping under the car?
jasonwrx86 is offline   Reply With Quote
Old 12-02-2018, 10:35 PM   #4
GosuWRX
Scooby Newbie
 
Member#: 494095
Join Date: Nov 2018
Vehicle:
2014 WRX Hatch
Satin White pearl

Default

I do not see water dripping under the car, maybe slight. How would I go about unclogging it? Also the panel where the water seems to be coming from has a wire with the brown head coming out of it
GosuWRX is offline   Reply With Quote
Old 12-03-2018, 08:52 AM   #5
Charlie-III
NASIOC Supporter
 
Member#: 30669
Join Date: Dec 2002
Chapter/Region: Tri-State
Location: USA, North NJ, 07456
Vehicle:
1998 Legacy 2.5GT
Silver Sleeper BK, 5MT

Default

Quote:
Originally Posted by oichan View Post
I don't know the answer to your question, but have you checked whether the drain hose for the evaporator under the car is blocked or not?
Quote:
Originally Posted by jasonwrx86 View Post
Drain hose is clogged. Do you see water dripping under the car?
Agreed, hose is clogged. It is likely the hose just below your red box.

Quote:
Originally Posted by GosuWRX View Post
I do not see water dripping under the car, maybe slight. How would I go about unclogging it? Also the panel where the water seems to be coming from has a wire with the brown head coming out of it
Pull the hose off, blow through it, poke a wire down through it, whatever.
Also, check where it comes through the firewall, sorta common for the turbo cars to melt the hose closed.
Charlie-III is offline   Reply With Quote
Old 12-03-2018, 10:10 PM   #6
GosuWRX
Scooby Newbie
 
Member#: 494095
Join Date: Nov 2018
Vehicle:
2014 WRX Hatch
Satin White pearl

Default

So I gave it a shot, and the leak is coming out of the box itself. The leak is where the wire is coming out of. It seems to be missing a screw and it's open. Any thoughts on that?

Also, water is coming out of the car so the pipe isn't clogged, I did blow air through it just incase though.
GosuWRX is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

All times are GMT -4. The time now is 01:46 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2018 Axivo Inc.
Copyright ©1999 - 2017, North American Subaru Impreza Owners Club, Inc.