Welcome to the North American Subaru Impreza Owners Club Tuesday June 18, 2019
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Go Back   NASIOC > NASIOC Technical > Service & Maintenance

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads. 
Reply
 
Thread Tools Display Modes
Old 11-21-2009, 08:28 PM   #1
el_pincho
Scooby Newbie
 
Member#: 137992
Join Date: Jan 2007
Question P0600 code and Er HC, Er SS

My car is a 05 LGT MT, My speedometer stopped working and the car threw all those codes... My dash looks like a Xmas Tree!!! ABS, Check engine Cruise control.... everything is blinking!

Anyway I verified and found one of the wheel speed sensors broken, I am hoping that this will solve the speedometer and the Er SS code.

But does anybody has any idea what the Er HC and the P0600 could mean?

What should I check?,

thanks
* Registered users of the site do not see these ads.
el_pincho is offline   Reply With Quote
Sponsored Links
* Registered users of the site do not see these ads.
Old 01-11-2017, 11:13 PM   #2
codicamartin
Scooby Newbie
 
Member#: 461143
Join Date: Jan 2017
Default

Ttt, Have you found out what is happening yet? I just bought an 05 Impreza with CEL code P0600 as well and my speedometer jumps around between shifting. My Cruise light is also flashing. Hoping to find the issue out soon.
codicamartin is offline   Reply With Quote
Old 04-21-2017, 08:54 AM   #3
alfakarl
Scooby Newbie
 
Member#: 23519
Join Date: Aug 2002
Default

'08 Outback manual with the same issues, any help would be appreciated.
alfakarl is offline   Reply With Quote
Old 04-21-2017, 12:30 PM   #4
Charlie-III
NASIOC Supporter
 
Member#: 30669
Join Date: Dec 2002
Chapter/Region: Tri-State
Location: USA, North NJ, 07456
Vehicle:
1998 Legacy 2.5GT
Silver Sleeper BK, 5MT

Default

Likely is a bad ground to one of the "black boxes" in the car which trips the CEL. It could also be a bad wiring harness.

More background info, like, what work was recently done to the car may help.

Some more reading....... https://www.obd-codes.com/p0600
Charlie-III is offline   Reply With Quote
Old 05-02-2017, 09:59 PM   #5
meebs
Scooby Specialist
 
Member#: 3251
Join Date: Dec 2000
Chapter/Region: NWIC
Location: Buckley, WA
Vehicle:
2009 WRX Hatch
DGM

Default

Just thought I would share...I can reproduce this *almost* every time. It's definitely a "communication" issue, at least with me.

I have an OBDLink LX bluetooth scan tool (the green one) to link to my phone (Google Nexus 5X) to run Torque Pro. I also have the "ActiveOBD TQ" plug in for Torque which gives you a few more parameters to read.

Every time this has happened when I've stopped for gas.

1. Start the car, plug in LX adapter, start Torque, everything is OK.
2. Turn the car fully off, but leave Torque running on phone.
3. Start car up. Dash goes into X-mas tree mode, P0600.

And to fix it, I just clear the codes with a cheapo OBD tool that I have.

What's interesting is I bought this more expensive bluetooth adapter as it's supposed to be more reliable and offer better compatibility than the "cheap $15 Chinese" adapter. To be sure, the LX never loses connection like the cheap blue one did however, I never had a P0600 thrown with it in any situation.

Edit: I forgot to post my work around. I just need to make sure to kill Torque when I turn the car off, and start it fresh when starting the car after it's started.

Last edited by meebs; 05-02-2017 at 10:02 PM. Reason: work around
meebs is offline   Reply With Quote
Old 05-03-2017, 04:13 AM   #6
CosmoTheCat
Scooby Newbie
 
Member#: 3409
Join Date: Jan 2001
Chapter/Region: NWIC
Location: Oly
Vehicle:
98 My FMIC
Is bigger than yours.

Default

Do you have one of those insurance dongles plugged into your OBD2 port? Or anything, for that matter? Get rid of it.
How about anything plugged into the power outlets/cigarette lighter? Remove all of it, as your first step.
CosmoTheCat is offline   Reply With Quote
Old 04-28-2019, 08:47 PM   #7
S4l1b7
Scooby Newbie
 
Member#: 500929
Join Date: Apr 2019
Default Same issue

My suburu threw these codes last night. I got home and parked it. I have been researching and researching (mechanic isnít open today and I have to work tomorrow). Any suggestions on what to do? I unplugged my insurance thing they have you plug in, took it to a car store and they gave me the codes and told me they didnít know what it meant. Iím at a loss and would love some help!!! If I do have to take it in to get fixed, how much am I looking at potentially spending?
S4l1b7 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
codes,codes and more codes grinch77 Newbies & FAQs 8 01-07-2009 05:27 PM
Er HC during reading of ROM normal? z28dreams Open Source Reflashes 0 09-06-2008 06:42 PM
Downloaded stock ROM - now CEL + Er HC z28dreams Open Source Reflashes 11 09-04-2008 09:18 PM
06 Legacy SE Sedan: Error Code Er HC wrxnavigation Service & Maintenance 0 05-13-2006 11:39 AM
HKS SS BOV and TXS V1 vs. SS BOV and Stock IC JayGold Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo) 7 03-11-2003 05:52 PM

All times are GMT -4. The time now is 06:44 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2019 Axivo Inc.
Copyright ©1999 - 2017, North American Subaru Impreza Owners Club, Inc.