Welcome to the North American Subaru Impreza Owners Club Wednesday June 26, 2019
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Go Back   NASIOC > NASIOC Technical > Service & Maintenance

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads. 
Reply
 
Thread Tools Display Modes
Old 05-05-2019, 06:05 PM   #1
scoobe
Scooby Newbie
 
Member#: 180857
Join Date: May 2008
Location: Barrington, IL
Vehicle:
03 WRX
That sexy silverrr

Default Whine noise diagnosis help

This noise started about 700 miles after i rallied a few dark orange puddles in the Utah desert, which are fully of extremely fine sandstone sediment.. i had orange muck thrown everywhere as you could imagine and i believe this noise is from sediment getting in somewhere.

i power washed really hard the entire underbody, axles and brakes etc and it actually stopped for nearly a week, then after i ROLLED through some deeper puddles recently it started again!

* Registered users of the site do not see these ads.
scoobe is offline   Reply With Quote
Sponsored Links
* Registered users of the site do not see these ads.
Old 05-09-2019, 06:40 PM   #2
scoobe
Scooby Newbie
 
Member#: 180857
Join Date: May 2008
Location: Barrington, IL
Vehicle:
03 WRX
That sexy silverrr

Default

anybody?
scoobe is offline   Reply With Quote
Old 05-09-2019, 07:35 PM   #3
n2oiroc
Scooby Specialist
 
Member#: 141952
Join Date: Feb 2007
Chapter/Region: MWSOC
Location: milwaukee'ish
Vehicle:
18 golf arrrr!

Default

did you get between the rotor backing plates and rotors? id say give it another good washing.
n2oiroc is offline   Reply With Quote
Old 05-10-2019, 12:56 AM   #4
jasonwrx86
Scooby Specialist
 
Member#: 472037
Join Date: Jul 2017
Chapter/Region: MWSOC
Vehicle:
2018 WRX Limited
CWP

Default

Could be wheel bearings?
jasonwrx86 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

All times are GMT -4. The time now is 12:13 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2019 Axivo Inc.
Copyright ©1999 - 2017, North American Subaru Impreza Owners Club, Inc.