Welcome to the North American Subaru Impreza Owners Club Saturday August 24, 2019
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Go Back   NASIOC > NASIOC Technical > Electrical & Lighting

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads. 
Reply
 
Thread Tools Display Modes
Old 07-24-2019, 02:24 AM   #1
jizzlets
Scooby Newbie
 
Member#: 347935
Join Date: Feb 2013
Default Dead LED's on Trunk Spoiler

I own a 2013 WRX Sedan... i've noticed that a couple of the LED's on the spoiler brake light are not working. I've also noticed that a couple of the centre LED's also flicker whenever i apply the brakes.

Is it possible to replace the individual bulbs? Or does the whole LED bar needs replacing?

Because I notice that there are no screws to take out the Light bar... so im assuming its a b*tch to get this damn thing fixed...

Suggestions pls

Thanks
Jas



IMAGE

https://www.dropbox.com/s/g0i17tj3kx..._4894.jpg?dl=0
* Registered users of the site do not see these ads.
jizzlets is offline   Reply With Quote
Sponsored Links
* Registered users of the site do not see these ads.
Old 07-24-2019, 05:46 AM   #2
rtv900
Scooby Specialist
 
Member#: 428511
Join Date: Aug 2015
Location: philadelphia
Vehicle:
2016 STI

Default

most likely the whole thing needs replaced.
typically LED's are all made in an array and the individual led's can't be replaced without way more effort than it would ever be worth
rtv900 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

All times are GMT -4. The time now is 09:33 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2019 Axivo Inc.
Copyright ©1999 - 2019, North American Subaru Impreza Owners Club, Inc.