Welcome to the North American Subaru Impreza Owners Club Sunday May 31, 2020
Home Forums Images WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Go Back   NASIOC > NASIOC Technical > Pre-2002 Factory Turbo Powertrain

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.







* As an Amazon Associate I earn from qualifying purchases. 
* Registered users of the site do not see these ads. 
Reply
 
Thread Tools Display Modes
Old 05-20-2020, 02:24 PM   #1
Joey_C
Scooby Newbie
 
Member#: 514929
Join Date: May 2020
Default Strange issues after major overhaul

I have recently put my motor back after pulling it to do headgaskets and other major maintenence.

I ended up having to pull the motor twice because the first time I put it back, I had NO compression on the left side of the motor. Turns out I had put the head gasket on backwards for that side.

After putting it back properly, I now have a huge over fuelling problem. I drove it for a week and had to fill up 3 times. I was getting 200 kms for a tank.

Iíve tested my o2 sensor with a multimeter and the results were good. As for the MAF sensor, the voltage starts around 3volts and DROPS to 1.5v as the revs increase. Compression test yields 150psi on all cylinders but the plugs were gapped way to big. I reduced it to .28 but no change.

Any ideas what might be the matter. I feel like it could be the MAF, because of the whack results, but perhaps itís a bigger issue.
* Registered users of the site do not see these ads.
Joey_C is offline   Reply With Quote
Sponsored Links
* Registered users of the site do not see these ads.
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

All times are GMT -4. The time now is 12:00 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2020 Axivo Inc.
Copyright ©1999 - 2019, North American Subaru Impreza Owners Club, Inc.

As an Amazon Associate I earn from qualifying purchases.